Advertising

SparkyLinux 3.6-dev1 Budgie

 

A new version of SparkyLinux 3.6-dev1 with Budgie desktop is available for testing.

Budgie is the flagship desktop of the Evolve OS Linux Distribution, and is an Evolve OS project. Designed with the modern user in mind, it focuses on simplicity and elegance. A huge advantage for the Budgie desktop is that it is not a fork of another project, but rather one written from scratch with integration in mind.

The new ISO image of Sparky Budgie features:
– Debian testing base as of 2015/01/31
– Budgie desktop from git repository as of 2015/01/31
– a few basic tools for managing the system
– a few Sparky tools
– live system installer

Make sure, that Budgie desktop is still under development and can makes problems.
If you find an issue of Budgie desktop – report it on Evolve OS/Budgie forums
If you find an other problem – report it on SparkyLinux forums

The testing iso images can be downloaded from ‘development’ section of the download page

You can also test the Budgie desktop on the top of your present Debian testing or SparkyLinux installation.

How to install Budgie Desktop from Sparky repository:
sudo apt-get update
sudo apt-get install budgie-desktop

Check is everything Ok:
sudo apt-get install -f
Then:
sudo reboot

SparkyLinux 3.6 Budgie

Known issues:
– a wallpaper has to be set manually after installation Sparky on a hard drive

 

SparkyLinux 3.6-dev2 LXQt + KWin

 

SparkyLinux 3.6-dev2 is the second testing release of out spin with LXQt.

Main keys:
– KWin window manager instead of Openbox
– basic visual effect enabled as default
– access to KWin Settings via a menu entry (sparky-kwin package)
– VLC preinstalled (as KWin dependency) + VLC plugin for Iceweasel
– Flash plugin added (as an option)

This release has been published to let you test it and compare to the dev1 iso (shipped with Openbox).
It works out of the box (not with all graphic cards), what you have to do is switching to OpenGL via the KWin Settings.

As some of our community members suggested, KWin could be the second available (to choose) out of the box window manager preinstalled, together with Openbox in the next Sparky main release.

The system consumes after hard drive installation (with basic effects enabled only):
– 32 bit – 160 MB of RAM
– 64 bit – 250 MB of RAM

I made a short video which captured 3 visual effects running in Live system.

Sparky testing iso images of:
– 3.6-dev1 LXQt spin with Openbox
or
– 3.6-dev2 LXQt spin with KWin
can be downloaded from our download page

Enjoy testing and share your opinion with us, please.

 

SparkyLinux 3.6 GameOver

 

SparkyLinux 3.6 “GameOver” is out.

“GameOver” is a special edition of Sparky targeted to gamers. It has been built on the top of the SparkyLinux 3.6 “Annagerman” and it’s fully compatible with Debian “testing” Jessie.

What is under the hood of GameOver 3.6 ?
– Linux kernel 3.16.0-4 (3.16.7-ckt2-1)
– all packages upgraded from Debian testing repositories as of 2014/12/31
– lxde-common 0.99.0-1
– openbox 3.5.2-8
– PCManFM 1.2.3-1
– Iceweasel 34.0-1
– vlc 2.2.0-rc2
– steam & steam-launcher 1.0.0.49
– desura for linux
– wine & playonlinux
– grub 2.02~beta2-19

Liquorix repository is enabled as default. It lets you upgrade the Linux kernel up to version 3.18 and Wine up to version 1.7 after installation Sparky on a hard drive

New applications:
– Sparky APTus Gamer – a small tool which lets you install all available system’s and machine’s game emulators. Most of them is located in Debian repos, and a few in Sparky repo as well
– Desura Installer – lets you install Desura client for Linux via one click
– EPSXE – (enhanced PSX emulator) is a PlayStation video game console emulator
– Kega Fusion – (also known simply as Fusion) is a Sega Mega Drive/Genesis emulator by Steve Snake and the third and final emulator of the Kega-series
– PPSSPP – is an open source PSP emulator available for Windows, MacOS, Linux and Android

A set of emulators of old machines and systems available via the package manager and Sparky APTus Gamer: AdvenceMENU, Atari800, DeSmuME, Desura Installer, DOSBox, DOSEMU, ePSXe, FCEUX, FS-UAE, GNOME Video Arcade, Hatari, Higan, Hega Fusion, MAME, Mednafen, MESS, Nestopia, PCSX, PlayOnLinux, PPSSPP, Steam, Stella, VisualBoyAdvance, Virtual Jaguar, Wine, Winetricks, Yabause, ZSNES.

Sparky APTus Gamer

A set of preinstalled games : 0ad, 3dchess, airstrike, alienblaster, amphetamine, antigravitaattori, armagetronad, asciijump, asylum, atomix, balder2d, barrage, berusky, billard-gl, biniax2, black-box, blobby, bloaboats, blockout2, brainparty, btanks, bygfoot, chromium-bsu, einstein, extremetuxracer, five-or-more, flare, four-in-a-row, freecraft, freedroid, frozen-bubble, funnyboat, gnome-chess, gnome-hearts, gnome-klotski, gnome-mahjongg, gnome-mastermind, gnome-mines, gnome-nibbles, gnome-robots, gome-sudoku, gnome-tetravex, gnubik, gnuchess, gnugo, gtkatlantic, gtkpool, gunroar, holdingnuts, iango, lbreakout2, lightsoff, liquidwar, ltris, maelstorm, megaglest, minetest, mokomaze, monopd, monsterz, moon-buggy, moon-lander, netmaze, netpanzer, neverball, neverputt, openarena, pacman, performous, pingus, quadrapassel, scorched3d, slimevolley, smc, snake4, snowballz, supertux, supertuxkart, swell-foop, tali, teeworlds, tennix, tetzle, tomatoes, transcend, warzone2100, wesnoth, widelands, xblast, xmoto, zaz

For some reasons I had to remove all previously preinstalled game emulators.
Adding the new tool Sparky APTus Gamer should help you installing any emulator.

Live system user is: live
Password: live
Root password is blank.

Minimum system requirements for SparkyLinux “GameOver” :
– CPU i586 / amd64
– 256 MB of RAM memory (some games need more than that – 500-1000MB recommended)
– an optical DVD drive or 4GB USB stick for Live medium
– 20 GB of space for installation on a hard drive (30GB recommended)
– 16 GB of Flash/Pen USB drive for “normal” installation (32GB recommended)

In a case of any problem with the live installer, you can try to use the older one as well (BIOS machines only):
sudo sparkylinux-installer
or
sudo sparkylinux-installer gui

New iso images of SparkyLinux you can grab from our download page

SparkyLinux 3.6 GameOver

Informacja o wydaniu w języku polskim: https://linuxiarze.pl/sparkylinux-3-6-gameover

 

SparkyLinux 3.6 LXQt dev1

 

When two open-source projects LXDE and Razor-Qt have merged into the one LXQt i knew that the day to make new spin is coming. On the other side, a few guys of our community members were asking me about LXQt spin and pushing me to make it.

I’d like to let you know I don’t have so much time to compile it myself.
I handle e19 for a while which takes a lot of my free time.

So to make you happy and save my time I built LXQt spin using Siduction’s LXQt packages.
I also would like to thank to siduction devs for their good work.
The packages work very well on the top of my installation of Debian testing and I believe that Sparky LXQt spin will be working fine on yours machines as well.

What is under the hood of Sparky 3.6 LXQt dev1 iso?
– base system of Debian testing as of 20/12/2014
– lxqt packages
– a few sparky tools
– live installer

Sparky LXQt spin can be downloaded from the development section of our download page.

Enjoy testing and Merry Xmas.

Sparky LXQt

 

SparkyLinux 3.6 Enlightenment19, JWM, Openbox & CLI

 

SparkyLinux 3.6 Enlightenment19, JWM, Openbox and CLI is out.

ISO images of Sparky 3.6 e19, JWM and Openbox belong to the Base Edition.
Base Edition features core system, X server, window manager, web browser, text editor and a few tools. All the ISO images of Base Editions 3.6 are codecs free. It means that they don’t have preinstallled multimedia codecs, players, editors or plugins.

SparkyLinux 3.6 E19 features two themes for your choice:

1. RadianceE19-Sparky – it’s a RadianceE19 modified theme.
The theme has been prepered to be fitted to the Sparky’s default GTK theme ‘Sparky3-theme’ and the icon set ‘NoirCrystal’. The wallpaper is made by LiquidSky64.
The Radiance theme originally created by Alberto “Duma” Verdoja and released under a CC-by license.
http://avduma.deviantart.com/gallery/

SparkyLinux e19

2. Default (the default Enlightenment theme) + DeLorean-Dark GTK theme for integration with GTK based applications.

The look of the JWM and Openbox desktops have been slightly improved + installed Sparky default theme and icon set.

SparkyLinux JWM    SparkyLinux Openbox

System has been synchronized with Debian “testing” repository as of 15/12/2014.

New iso images features as well:
– Linux kernel 3.16.0-4 (3.16.7-ckt2-1)
– grub 2.02~beta2-18
– jwm 2.1.0+svn579-2
– openbox 3.5.2-8
– pcmanfm 1.2.3-1 (jwm & openbox editions only)
– enlightenment19 – 0.19.1 – compiled from git repository up to version 0.19.99.19173 with:
– EFL & Elementary 1.12.1
– Python-EFL 1.12.0
– Terminology 0.7

The latest version of Enlightenment 0.19.2 is available in Sparky repository as a regular update.

New applications in Sparky repo:
– XnViewMP 0.71 – free photo editor, manager and viewer
– Master PDF Editor – a convenient and smart XPS and PDF editor

The minimal iso image of CLI Edition has gotten additional tool: wicd-curses
Sparky CLI doesn’t support installation on EFi machines.

Use the new iso images to perform fresh Sparky installation.
If you have Sparky installed already on your hard drive, make full system upgrade (as root):
apt-get update
apt-get dist-upgrade
apt-get install -f
reboot

In a case of any problem visit our forums.
In a case of any problem with the default live installer, try to use the older installer which can be run by the command:
sudo sparkylinux-installer gui
or
sudo sparkylinux-installer
The old installer doesn’t work on machines with EFI.

New iso images of SparkyLinux for 32 and 64 bit machines can be downloaded from our download page.
Following changes in Debian testing, the 32 bit kernel is targeted for i586 (non-pae) machines now.

All wallpapers can be downloaded from out account on sourceforge

Informacja o wydaniu w języku polskim: https://linuxiarze.pl/sparkylinux-3-6-enlightenment19-jwm-openbox-cli

 

SparkyLinux 3.6 LXDE, MATE, Razor-Qt & Xfce

 

I am happy to announce the fourth and the last this year iso images of SparkyLinux 3.6 “Annagerman” LXDE, MATE, Razor-Qt and Xfce. At the beginning, I’d like to thank to all of our small but strong community members for their help with searching and solving bugs and problems.

SparkyLinux 3.6 provides (as usual) all packages updating, some bug fixing and small improvements, such as:
– Linux kernel 3.16.0-4 (3.16.7-2)
– xfce 4.10.1
– lxde-common 0.99.0
– razor-qt 0.5.2-4
– mate 1.8.1
– openbox 3.5.2-8
– grub 2.02~beta2
– Twitter’s microblogging client Hotot replaced by Turpial (Hotot is not under development any more)
– the new wallpaper ‘Vortex’ by LiquidSky64
– Sparky Conky Manager updated up to version 0.1.7 having a new applet of battery status

System has been synchronized with Debian “testing” repository as of 03/12/2014.

Added new apps:
– sparky-aptus-upgrade (System Upgrade) – small (recommended) tool for system upgrading
– sparky-systemd-ui – a metapackage which gives you an access to systemd settings as root

Removed packages:
– sparky-tray
– old, deprecated mate packages of 1.4 & 1.6

The Live system is available in English only.
You can choose any localization during the hard drive’s installation process.

Use the new iso images to perform fresh Sparky installation.
If you have Sparky installed already on your hard drive, make full system upgrade (as root):
apt-get update
apt-get dist-upgrade
apt-get install -f
reboot

In a case of any problem visit our forums.

New iso images of SparkyLinux for 32 and 64 bit machines can be downloaded from our download page. Following changes in Debian testing, the 32 bit kernel is targeted for i586 (non-pae) machines now.

SparkyLinux

New wallpapers can be downloaded from our account on sourceforge.

Other Sparky 3.6 editions will be released soon.

Known problems:
– the live installer does not configure Plymouth (preinstalled)

To fix it, after installation edit ‘grub’ config file:
sudo nano /etc/default/grub
and change the line from:
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
to:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
then:
sudo update-grub

 
Informacja o wydaniu w języku polskim: https://linuxiarze.pl/sparkylinux-3-6-lxde-mate-razor-qt-xfce

 

e19 updated

 

I have upgraded e19 package and made some fixing into the deb package.

Enlightenment files have been upgraded from git repository as of 26 Nov 2014 up to version 0.19.99.19173. The e19 package is installed in a custom directory so I also created symlinks to system’s directories.

Changelog:
• EFL and Elementary 1.12.1
• Python-EFL 1.12.0
• added symlinks of all the binary files to /usr/bin
• added symlinks of all the lib files to /usr/lib
• added and compiled terminology

To upgrade your present e19 version, run:
su
apt-get update
apt-get dist-upgrade

Make sure is everything OK:
apt-get install -f
Then:
reboot

 

SparkyLinux 3.5.1 E19 is out

 

SparkyLinux 3.5.1 “Annagerman” Enlightenment 19 is ready to go.

What is “under the hood” of SparkyLinux 3.5.1 E19?

ISO image of SparkyLinux 3.5.1 E19 Live/Install provides packages updating from Debian ‘testing’ repository and updating Enlightenment packages from the git repository.

The Enlightenment packages have been updated up to version 0.19.19.18964.
The system runs on Linux kernel 3.16 with systemd 215-5.

This edition joined to the Sparky Base Edition group.
What does it mean?
The ISO image features base system, X Server, Enlightenment and a minimal set of tools.
You have gotten a ready to use environment to configure it as you like. Install additional applications via Synaptic, Sparky-APTus, Sparky-APTus-Extra or just APT.

SparkyLinux 3.5.1 E19 features two themes for your choice.

1. RadianceE19-Sparky – it’s a RadianceE19 modified theme. The theme has been prepered to be fitted to the Sparky’s default GTK theme ‘Sparky3-theme’ and the icon set ‘NoirCrystal’.
The wallpaper is made by LiquidSky64.
The Radiance theme originally created by Alberto “Duma” Verdoja and released under a CC-by license.
http://avduma.deviantart.com/gallery/

RadianceE19-Sparky

2. Default (the default Enlightenment theme) + DeLorean-Dark GTK theme for integration with GTK based applications.

Dark theme

 

SparkyLinux is rolling release system so you don’t have to reinstall your existing ‘E’ edition.
Simply leave the Enlightenment desktop and make upgrade as following.

E17 users:
apt-get remove e17 && apt-get autoremove
apt-get update
apt-get install e19 dolorean-dark

E18 users:
apt-get remove enlightenment && apt-get autoremove
apt-get update
apt-get install e19 dolorean-dark

Sparky 3.5 E19-dev users (recommended):
apt-get remove e19 && apt-get autoremove
apt-get update
apt-get install e19 dolorean-dark

or (it does not remove ‘e19-dev’ packages):
apt-get apt-get update
apt-get dist-upgrade
apt-get install dolorean-dark

Check has been the upgrade done well:
apt-get install -f

 

Wallpapers made by LiquidSky64 + my two modifications – green and gray:

enlightenmentgoldenradianceSparky    enlightenmentgoldenradianceSparky-green
enlightenmentgoldenradianceSparky-gray    CoffeeBreakSparkylinux
8mmb

New iso images of Sparky can be downloaded from the download page
Enlightenment themes can be downloaded from sourceforge:
http://sourceforge.net/projects/sparkylinux/files/files/themes/

Known issues:
– module ‘cpufreq’ is off in 32 bit edition due to problem with permissions, even set it up as it should be
– module ‘systray’ still doesn’t work, so it’s off too. The system tray is provided by LXDE panel ‘lxpanel’ (minimalized)
– libglib2.0 2.40.0-5 and its libs have been not upgraded to the newest version 2.42.0-1 due to an issue – don’t upgrade it and wait for a newer version

 
Informacja o wydaniu w języku polskim -> https://linuxiarze.pl/sparkylinux-3-5-1-e19

 

SparkyLinux 3.5 MATE, Xfce, Openbox & JWM is out

 

SparkyLinux 3.5 “Annagerman” MATE, Xfce and Base Openbox & JWM is out.

New Live/Install iso images provide packages update and a few changes.
All packages have been synchronized with Debian “testing” repository as of 22/09/2014.

Base Edition is available in two separated flavours now: Openbox and JWM.
JWM Edition offers traditional desktop look and minimal set of applications as well as Openbox Edition. JWM Edition uses a little less the computer’s power even that Openbox and can be used on old machines. Sparky JWM 32 bit consumes less that 90 MB of RAM memory after installation on a hard drive.

All multimedia packages have been removed from Base Editions so both of them are codecs free now.

The system runs on Linux kernel 3.14.2 (3.14.15-2) and offers:
– MATE 1.8.1
– Xfce 4.10.1
– Openbox 3.2.5-7
– JWM 2.1.0
– ‘Custom ISO Builder’ – lets you rebuild iso images of SparkyLinux
– ‘Sparky-APTus-Extra’ – lets you quick install additional applications from SparkyLinux repository
– ‘Sparky Conky Manager’ has been updated up to version 0.1.6 having new option which lets change the color
– ‘TrueCrypt’ has been removed from the system – the reason is well known for everybody for sure. There is zuluCrypt available in our repo, which offers a CLI and GUI front-end for ‘cryptsetup’.

Added new repository and the public keys:
– virtualbox
– liquorix
– google earth
– google talk plugin
– google music manager

Additional repositories are off.
To activate a new repo go to Synaptic-> Repository or Sparky APTus-> Repository-> Additional Repository Edition

SparkyLinux Base Edition JWM

 
All the ISO images can be downloaded from download page

 

Donate

Donate SparkyLinux project

 

 

Informacja o wydaniu w języku polskim:
https://linuxiarze.pl/sparkylinux-3-5-mate-xfce-openbox-jwm/

 

Advertising