Advertising

Sparky 2019.09

There are new live/install media of Sparky 2019.09 “Po Tolo” available to download. This is the 2nd snapshot of the (semi-)rolling line, which is based on the testing branch of Debian “Bullseye”.

Changes:
• system upgraded from Debian testing “Bullseye” repos as of September 1, 2019
• fixed issue in Advanced Installer which did not set home partition on non-root partition with no-formatting option (thank’s lami07)
• Firefox-ESR replaced with Firefox Latest
• GCC 9 is the default compiler now, GCC 8 removed
• Calamares installer 3.2.13
• Linux kernel 5.2.9 (5.2.11 & 5.3-rc6 available in Sparky unstable repos)
• Xfce 4.14
• LXQt 0.14.1
• Openbox 3.6.1-8

No reinstallation is required if you have Sparky 2019.08 (of the line 6) installed, simply make full system upgrade.

New rolling iso images can be downloaded from the download/rolling page.

Know issues:
– upgrading Xfce desktop to the latest version 4.14 lost some desktop settings (wallpaper) so set it back after rebooting.

 

Sparky 2019.08

There are new live/install media of SparkyLinux 2019.08 “Po Tolo” available to download. This is the 1st snapshot of the new (semi-)rolling line, which is based on the testing branch of Debian “Bullseye”.

Changes:
• system updated from Debian testing “Bullseye” repos as of August 1, 2019
• added gcc 9 (gcc 8 is still the default one)
• new Sparky6 theme
• new Tela icon set
• refreshed desktop look
• sddm instead of lightdm (LXQt edition)
• Linux kernel 4.19.37 (5.1.21 EOL, 5.2.5 & 5.3-rc2 available at Sparky unstable repos)

As I mentioned before, Sparky of the rolling line is available to amd64/x86_64 machines only. Sparky rolling 32 bit is fully supported so if you have it, simply keep it up to date.

System reinstallation is not required.
If you have Sparky rolling installed:
• make sure your OS uses Debian ‘testing’ repos
• change Sparky repos to ‘testing’ if your OS uses ‘stable’ repo already
• make full system upgrade:
sudo apt update
sudo apt install sparky6-apt
sudo apt update
sudo apt full-upgrade

New 64bit rolling iso images of Sparky Xfce, LXQt, MinimalGUI & MinimalCLI can be downloaded from the download/rolling page.

Big thanks go to lami07 for his deep testing and reporting bugs.

Sparky Xfce

 

Sparky 5.8 “Nibiru”

There are new live/install media of SparkyLinux 5.8 “Nibiru” available to download.
This is the 1st release of the new stable line, which is based on the Debian 10 “Buster”.

Changes:
– based on Debian 10 stable “Buster” now, repositories changed from ‘testing’ to ‘stable’
– system upgraded from Debian stable “Buster” repos as of July 14, 2019
– Linux kernel 4.19.37-5 (i686 & amd64)
– Linux kernel 4.19.57-v7+ (ARMHF)
– the Calamares installer updated up to version 3.2.11
– apt-daily.service disabled
– sparky-tube installed as dafault
– removed old 3rd party repositories
– added obconf-qt (LXQt edition)
– nm-tray installed instead of network-manager-gnome (LXQt edition)
– network-manager added to CLI ARMHF image
– small fixes

System reinstallation is not required. If you have Sparky 5.x installed make sure your OS uses Debian’s ‘buster’ or ‘stable’ repos, and make full system upgrade:
sudo apt update
sudo apt install sparky5-apt
sudo apt update
sudo apt full-upgrade

Sparky 5.8 is available in the following flavors:
– amd64 & i686: LXQt, Xfce, MinimalGUI (Openbox) & MinimalCLI (text mode)
– armhf: Openbox & CLI (text mode)

New stable iso/img images can be downloaded from the download/stable page.

Changing the repositories moves Sparky 5 from ‘rolling’ to ‘stable’ line now.
If you would like to keep Sparky rolling, read the post: https://sparkylinux.org/sparky-5-transition/

Sparky 5.8 RC

New live/install iso images of Sparky 5.8 RC are out. Sparky 5.8 RC is a release candidate of the next stable line and is based on upcoming Debian stable Buster.

Changes between Sparky 5.7.x and 5.8 RC:
• Debian repo set to buster now, not to testing
• Sparky repo still points to testing, and will be updated automatically soon
• usrmerge set dirs symlinks (can be removed after)
• added inxi tool to all iso images
• all packages updated from Debian Buster repos as of July 3, 2019
• due to a few feedbacks I got, some of you are not happy with switching from LXDE to LXQt edition, so there is the Xfce edition re-built and ready to use
• due to problem with sparky5 theme in the Xfce edition, a new sparky6 theme is set as default (Xfce only)
• many Sparky apps have gotten Russian translations, thank’s to ChourS
• Calamares updated up to 3.2.9
• Firefox replaced by Firefox ESR

Please test the new iso images and report whatever you find.
The 5.8 release candidate iso images can be downloaded from the download/development page.

Sparky 5.3

There are new live/install iso images of SparkyLinux 5.3 “Nibiru” available to download.
Sparky 5 follows rolling release model and is based on Debian testing “Buster”.

Sparky 5.3 provides fully featured operating system with lightweight desktops: LXQt, MATE and Xfce.

Sparky MinimalGUI (Openbox) and MinimalCLI (text mode) lets you install the base system with a desktop of your choice and a minimal set of applications, via the Sparky Advanced Installer.

Changes:
– full system upgrade from Debian testing repos as of March 7, 2018
– Linux kernel 4.15.4 as default (4.15.8-sparky is available in Sparky ‘unstable’ repo)
– the default system installer Calamares updated up to version 3.1.12
– added packages to support btrfs & xfs file systems
– cleaning out old files configs
– added new tool for cleaning your system from old files and configs: bleachbit
– missing language package installer (a part of APTus) has gotten gnome, kde & qt language package installtion option
– gdebi has been removed; locale stored debs can be installed via APTus-> Install-> Install package
– cli edition has been re-configured; it uses sudo as default after installing it on a hard drive as well
– many small fixes and improvements

No system reinstallation is required, simply make full system upgrade:
sudo apt-get update
sudo apt-get dist-upgrade

If any problem, run:
sudo dpkg --configure -a
sudo apt-get install -f

New iso images of the rolling edition can be downloaded from download/rolling page.

Known issues:
– possible problem with unmounting the live system squashfs if running inside of a virtual machine – ignore, shot the live system down, remove the live media and run your machine normally.

Sparky 5.2

There are new live/install iso images of SparkyLinux 5.2 “Nibiru” available to download.
Sparky 5 follows rolling release model and is based on Debian testing “Buster”.

Sparky 5.2 provides fully featured operating system with lightweight desktops: Xfce, MATE and LXQt.
Sparky 5.2 MinimalGUI (Openbox) and MinimalCLI (text mode) lets you install the base system with a desktop of your choice and a minimal set of applications, via the Sparky Advanced Installer.

Important !
Sparky based on Debian testing is not a stable edition; can make problems sometimes and can need individual fixing. If you prefer much stable operating system – Sparky 4.x of the stable line will be better choice.

Changes of all editions:
– full system upgrade from Debian testing repos as of December 17, 2017
– Linux kernel 4.14.2 from Debian Sid repos (4.14.8-sparky is available in Sparky ‘unstable’ repo)
– Calamares 3.1.10 as the default system installer
– the full disk encryption option has been activated in the Calamares, so Sparky can be installed on an encrypted disk now
– added 8 new wallpapers of Polish nature to ‘sparky-artwork-nature’ package
– added symlink of ‘sparkylinux-installer’ to ‘sparky-installer’ (Advanced Installer), and ‘spb’ shortcut to ‘sparkybackup’ command (backup tool)

Changes in Xfce edition:
– due to abnormal CPU usage of the ‘xfce4-pulseaudo-plugin’ (with Sparky 5 icon set), the plugin has been replaced by ‘pasystray’

Changes in MinimalGUI edition:
– PCManFM file manager replaced by Thunar
– external USB disks are mounted automatically now

No system reinstallation is required, simply make full system upgrade:
sudo apt-get update
sudo apt-get dist-upgrade

If any problem, run:
sudo dpkg --configure -a
sudo apt-get install -f

New iso images of the rolling edition can be downloaded from the download/rolling page.

Known issues:
– possible problem with unmounting the live system’s squashfs if running inside of a virtual machine (tested in VirtualBox only) – ignore it, shot the live system down, remove the live media and run your machine normally.

Merry Christmas to all Sparkers
from Aneta i Paweł

 

Sparky 4.7

There is an update of SparkyLinux 4.7 “Tyche” out there.
This is Sparky edition based on Debian stable line 9 code name “Stretch”.

No big changes, the new iso images provide updates of all installed packages, from Debian “Stretch” and Sparky repositories as of November 17, 2017.

Highlights:
– Linux kernel 4.9.0-4 (4.9.51)
– Xfce 4.12.3
– LXDE 0.99.2
– Openbox 3.6.1
– Firefox ESR 52.5.0
– Thunderbird 52.4.0
– Pidgin 2.12.0
– HexChat 2.12.4
– VLC 2.2.6
– DeaDBeeF 0.7.2
– LibreOffice 5.2.7
– Transmission 2.92
– Calamares 3.1.8

The new iso images can be used to perform fresh Sparky installation.

If you already have Sparky installed on a hard drive, simply make full system upgrade:
sudo apt update
sudo apt full-upgrade

ISO images of Sparky 4.7 LXDE, Xfce, MinimalGUI (Openbox) & MinimalCLI (text mode) for i686 and x86_64/amd64 machines can be download from the download/stable page.

Consider a small donation which would help to keep Sparky project alive.

SparkyLinux

 

Sparky 5.1

There are new live/install iso images of SparkyLinux 5.1 “Nibiru” available to download.
Sparky 5 follows the rolling release model and is based on Debian testing “Buster”.

Sparky “Home” edition provides fully featured operating system with lightweight desktops: Xfce, MATE and LXQt.
Sparky MinimalGUI (Openbox) and MinimalCLI (text mode) lets you install the base system with a desktop of your choice and a minimal set of applications via the Sparky Advanced Installer.

Changes between version 5.0 and 5.1:
– full system upgrade from Debian testing repos as of September 25, 2017
– Linux kernel 4.12.13 as default (4.13.3-sparky is available in Sparky ‘unstable’ repo)
– gcc 6 removed from the live media; the default compiler is gcc 7
– obmenu-generator updated up to version 0.80 (MinmalGUI edition), what speeded up launching the menu with svg icons
– the default system installer Calamares updated up to version 3.1.4
– added new tool for installing a web browser: Sparky Web Browser Installer
– new desktop environment added to Sparky repos: Manokwari
– live system’s memtest86+ issue has been fixed
– source code repos moved to GitHub

No system re-installation is required, simply make full system upgrade:
sudo apt-get update
sudo apt-get dist-upgrade

If any problem, run:
sudo dpkg --configure -a
sudo apt-get install -f

New iso images of the rolling edition can be downloaded from download/rolling page.

 

Sparky 5.0

There are new live/install iso images of SparkyLinux 5.0 “Nibiru” available to download.
Sparky 5 follows rolling release model and is based on Debian testing branch “Buster”.

From Wikipedia:

In Babylonian astronomy, Nibiru (in cuneiform spelled dné-bé-ru or MULni-bi-rum). The term refers to the equinox and the astronomical objects associated with it…
…Nibiru was considered the seat of the summus deus who shepherds the stars like sheep, in Babylon identified with Marduk.

Sparky “Home” edition provides fully featured operating system with lightweight desktops: LXQt, MATE and Xfce.

As usually, Sparky MinimalGUI (Openbox) and MinimalCLI (text based) lets you install the base system with a minimal set of applications and a desktop of your choice, via the Sparky Advanced Installer.

Changes between version 4.5 and 5.0:
– full system upgraded from Debian testing repos as of July 14, 2017
– Linux kernel 4.11.6 as default (4.12.x is available in Sparky ‘unstable’ repo)
– new theme “Sparky5”
– new theme of LXQt edition
– new default wallpaper created by our community member “barti”
– new set of wallpapers of the Nature category, with a few nice landscapes from Poland
– Calamares 3.1.1 as the default system installer
– new tool for checking and displaying notification on your desktop about available updates

Other changes:
– added new repos (not active): wine-staging.com
– email client Icedove replaced by Thunderbird
– changed http to https protocol of all Sparky services, including repository; updating the ‘sparky-apt’ package fixes it automatically
– added two new live system boot options:
1. toram – lets you load the whole live system into ram memory (if you have enough);
2 – text mode – if any problem with normal or failsafe boot, this option runs sparky in text mode and lets you install it using the advanced installer

Sparky edition based on the Openbox window manager (MinimalGUI) has gotten 3 key shortcuts:
– Super+t -> terminal emulator
– Super+r -> gexec
– Super+q -> logout window

No system reinstallation is required.

If you have Sparky up to 4.5 installed on your hard drive, simply make full system upgrade:
sudo apt-get update
sudo apt-get dist-upgrade

If any problem, run:
sudo dpkg --configure -a
sudo apt-get install -f

New iso images of the rolling edition can be downloaded from download/rolling page.

SparkyLinux LXQt

 

Sparky 4.6.1 STB

There is an update of SparkyLinux stable line 4.6.1-STB “Tyche”.
This is Sparky edition based on Debian stable 9 “Stretch”.

New live/install media features fixes of 3 issues found in the 4.6 release:
1. system installed via Calamares sets wrong chmod 777 of the root directory “/”, (should be 755); it is NOT Calamares related issue, but happens using Calamares. The issue has been reported by lesio – thank’s a lot.
2. Wrong UUID Resume number, copied from the base system – it sets wrong configuration to GRUB bootloader
3. Calamares 3.1 features weak salt. In cryptography, a salt is random data that is used as an additional input to a one-way function that “hashes” a password or passphrase. Systems installed by Calamares up to and including Calamares 3.1 have a weaker password salt than they should. This weakness is important if an attacker has a way to obtain the password hash. The new 4.6.1 iso images are shipped with Calamares 3.1.1.

NO re-installation is required.

If you have Sparky 4.6 installed on your hard drive, you can manually fix the issues.

1. Wrong chmod can be fixed by the command:
sudo chmod 755 /

2. Wrong UUID Resume number.

Check your swap UUID:
sudo lsblk -f | grep swap

Check resume UUID:
cat /etc/initramfs-tools/conf.d/resume

If they are different, change (by a text editor, as root) resume UUID to the first one, has gotten by ‘lsblk’ command, and then update ram disk and grub:
sudo update-initramfs -u -t -k all
sudo update-grub

3. Weak password salt can be fixed by creating new password, via the command:
passwd

If you have separated root password, change it in the same way:
su
passwd

New iso image can be download from the download/stable page.

Advertising