Sparky 7.4

The 4th update of Sparky 7 – 7.4 is out.

It is a quarterly updated point release of Sparky 7 “Orion Belt” of the stable line. Sparky 7 is based on and fully compatible with Debian 12 “Bookworm”.

Changes:
– all packages updated from Debian and Sparky stable repos as of June 9, 2024
– Linux kernel PC: 6.1.90 LTS (6.9.4, 6.6.32-LTS, 6.1.92-LTS, 5.15.160-LTS in sparky repos)
– Linux kernel ARM: 6.6.31 LTS
– LibreOffice 7.4.7
– KDE Plasma 5.27.5
– LXQt 1.2.0
– MATE 1.26
– Xfce 4.18
– Openbox 3.6.1
– Firefox 115.11.0esr (127.0 & 115.12.0esr in sparky repos)
– Thunderbird 115.11.0
– added Debian backports Linux kernels installation to APTus: 64bit, 64bit RT, 686-pae, 686-pae RT, 686 non-pae

Sparky 7.4 “Orion Belt” is available in the following versions:
– amd64 BIOS/UEFI+Secure Boot: Xfce, LXQt, MATE, KDE Plasma, MinimalGUI (Openbox) & MinimalCLI (text mode)
– i686 non-pae BIOS/UEFI (Legacy): MinimalGUI (Openbox) & MinimalCLI (text mode)
– ARMHF & ARM64 Openbox & CLI

Due to an error being detected at the last moment, the Xfce and MATE iso have been reconfigured and recreated as the 7.4.1.

Make sure that the ‘os-prober’ will be not executed to detect other bootable partitions as default, but Sparky provides a GRUB option to detect other OSes anyway.
But, a next updating of GRUB packages override the option.
To fix that manually, add the line:
GRUB_DISABLE_OS_PROBER=false
on the end of the file (as root):
/etc/default/grub
Then update grub:
sudo update-grub

PC live user:password = live:live
ARM user:password = pi:sparky

If you have Sparky 7 installed – simply keep it up to date. No need to reinstall your OS.

New ISO/IMG images of Sparky 7 “Orion Belt” can be downloaded from the download/stable page.

Informacja o wydaniu w języku polskim: https://linuxiarze.pl/sparky-7-4/

Leave a Comment

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.