Advertising

Sway

There is a new, small desktop available for Sparkers: Sway

What is Sway?

Sway (SirCmpwn’s Wayland compositor) is a tiling Wayland compositor and a drop-in replacement for the i3 window manager for X11. It works with your existing i3 configuration and supports most of i3’s features, plus a few extras. This means it is a minimalist, tiling window manager.

Sway is available for users of Sparky 5/Debian Buster amd64 only (in this moment).

Installation:
Make sure you have Sparky Unstable repo enabled, then:
sudo apt update
sudo apt install sway

To launch Sway in Wayland session, you need GDM3, SDDM or tbsm to be installed and set as default display manager.
If you don’t want to install gdm3 (and gnome-shell), you can use other display managers, such as LightDM, LXDM, XDM, etc., but they can run Sway in Xorg session with Xwayland (xwayland package has to be installed).

Sway

The Sway project page: swaywm.org

 

Enlightenment 0.21.4

 

There is an update of Enlightenment 0.21.4 ready in Sparky repository now.

Make upgrade as usually:
sudo apt-get update
sudo apt-get dist-upgrade

If you would like to make fresh installations, run:
sudo apt-get update
sudo apt-get install enlightenment

 

There are also a few important, 3rd party updates landed to the repos as well:
– EFL 1.18.3
– Firefox 50.0.2
– Palemoon 27.0.1
– Thunderbird 45.5.1
– TOR Browser 6.0.7

 

e19 0.19.3 is available

 

The Enlightenment team has announced the release of version 0.19.3 of Enlightenment DR19.

E19 0.19.3 packages have been built from the project git repos (0.19.99.19338) and debs are already in Sparky repository now.
Sparky users can easily upgrade the Sparky e19 installations via the package manager.

To do so, run (as root):
apt-get update
apt-get dist-upgrade

You can use System-Upgrade tool or Synaptic instead of the command line as well.

 

Enlightenment 0.19.2

 

The Enlightenment team has announced the release of Enlightenment 0.19.2.

Enlightenment has been built from git repository up to version 0.19.99.19234 as of 18/Dec/2014.
Sparky users can easily upgrade their Sparky e19 installations via the package manager:
sudo apt-get update
sudo apt-get dist-upgrade

Then check is everything OK:
sudo apt-get install -f

 

Sparky-Compton

 

We have a new packege called “sparky-compton” available in our repository.

Compton is a composite manager – a bug-fixed fork of dcompmgr, which is a fork of xcompmgr.

“Sparky-compton” package providing :
– easy way to install compton
– simply graphical interface with a few option: start, stop, load and edit config file
– sample configuration file, so you don’t need to look for it yourself

The sample config file has been provided by our community member Albedo 0.64 and it is available on Arch Linux wiki as well.

This is SparkyLinux Openbox desktop with Compton running on it.

Sparky Openbox + Compton

 

Advertising