Du to issue with ‘policykit-1-gnome’ authentication agent I moved a newer version of the package from Sid to Sparky repos.

Desktop environments which use the agent need to upgrade the package to the newest version and reboot to take effects.

Window managers/Desktop environments available and pre-configured for Sparkers via APTus and MinimalGUI/CLI iso images (awesome, bspwm, Enlightenment, i3, IceWM, JWM, Lumina, Openbox, PekWM, Trinity, WindowMaker) have to be fixed manually.

Easy way:
Make full system upgrade or just upgrade two packages to their newest versions:
– policykit-1-gnome
– sparky-desktop-data (and sparky-aptus)

Then run APTus-> Desktop tab and click/run on a desktop icon (window manager) you have installed and would like to fix. It doesn’t install new packages (upgrade only), but re-install user’s startup packages to correct the agent exec patch. Then reboot.

Manual way:
Make full system upgrade or just the ‘policykit-1-gnome’ and replace the agent exec path in your window manager startup config file from:
/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
to:
/usr/lib/polkit-gnome-authentication-agent-1
Then reboot to take effects.


 

Related Post