There is a new, small tool available for Sparkers: Update Checker & Notifier

The tool checks (in shadow) packages to be upgraded and displays notification on desktop.

Installation:
sudo apt update
sudo apt install sparky-aptus-upgrade-checker

Then reboot to let it start working.

It doesn’t run if:
• running live system
• no active internet connection
• ‘sparky-firstrun’ is installed

It runs ones per system boot, with 30 second of delay.
If runs and finds packages to be upgraded, it lets you start the default Sparky’s upgrade tool (sparky-aptus-upgrade).

It uses Yad, so it’s desktop independent.

Update checker & notifier