The first stable version of Linux kernel of 4.8.x line – 4.8.0 landed in Sparky “unstable” repository.

Make sure you have Sparky “unstable” repository enabled:
to upgrade or install the latest kernel.

Follow the Wiki page: to install the latest Sparky’s Linux kernel.

Then reboot your machine to take effects.

To quick remove older version of the Linux kernel, simply run APTus-> Remove-> Uninstall Old Kernel script.