There is an update of Budgie Desktop 8.2-20150629 in our repository.

One of updates came from Debian testing removed ‘libmutter0e’ package and Budgie Desktop as well.
So the Budgie Desktop has been re-built and uses ‘libmutter0f’ as one of its dependencies now.

If you haven’t upgraded the previous version of Budgie Desktop yet, you can do it now or install it if you’d like:

sudo apt-get update
sudo apt-get install budgie-desktop