Advertising

EFL 1.18.0

 

There is an update of EFL 1.18.0 ready in Sparky repository now.

Due to the Enlightenment’s developers changes, the ‘evas-generic-loaders’, ’emotion-generic-players’ and ‘elementary’ have been merged into the EFL package and they are no available (as separated packages) in Sparky repos any more.

There is no changes with installing Enlightenment, so do it as before:
sudo apt-get update
sudo apt-get install enlightenment

To upgrade EFL and other Enlightenment’s tools, do:
sudo apt-get update
sudo apt-get dist-upgrade

It removes ‘evas-generic-loaders’, ’emotion-generic-players’ and ‘elementary’ automatically so no need any special users attention.

 

Updates 2016/06/27

 

3rd party updates in Sparky repository ready to go:
– Boot Repair 4ppa38
– EFL 1.17.2
– ePSXe 2.0.5 – the emulator is available for 32 and 64 bit systems now. If you have older version (32 bit) installed on a 64 bit system, uninstall it before installing newer 64 bit version.
– WPS Office 10.1.0.5672-alpha21
– XnView 0.80

Upgrade your system as usually:
sudo apt-get update
sudo apt-get dist-upgrade

or via ‘Update Tool’ or ‘Synaptic’ if you wish.

 

Updates 2016/06/08

 

There are some 3rd party updates in our repository ready to go:
– DDM 2.2.7
– Itch 17.6.6
– Linux kernel 4.6.2 (in Sparky unstable repository, check howto)
– MEGASync 2.9.5
– SMTube 16.6.0
– TOR Browser 6.0.1
+ added libcrypto++9v5 for the latest version of MEGASync
+ moved Sparky APTus Upgrade 0.2.2 from ‘unstable ‘ to ‘testing’ repos

Upgrade your system as usually:
sudo apt-get update
sudo apt-get dist-upgrade

or via ‘Update Tool’ or ‘Synaptic’ if you wish.

Due to changes in the KDE 5.6 packages, users of the Sparky KDE spin should make safe upgrade:
apt-get update
apt-get upgrade

 

Enlightenment 0.20.8

 

There is an update of Enlightenment 0.20.8 ready in Sparky repository now.

If you have an older version installed, simply make system upgrade:
sudo apt-get update
sudo apt-get dist-upgrade

If you would like to make fresh installations, do:
sudo apt-get update
sudo apt-get install enlightenment

Due to changes in Debian testing repos (what is normal), it’s highly recommended to make upgrade all the Enlightenment libs, which I have rebuilt too: EFL, Evas Generic loaders, Emotion Generic Players, Elementary, and Python-EFL.

If you find any problem with building the tools from source, simply let mm know that, posting it on our forums.

 

Linux kernel 4.5.2

 

There is an update of the latest stable version of Linux kernel 4.5.2 available in Sparky “unstable” repository.

To install or upgrade it, activate Sparky “unstable” repository and install the latest kernel via the meta packages.
amd64:
sudo apt-get install linux-image-sparky-amd64
686 non-pae:
sudo apt-get install linux-image-sparky-686
686-pae:
sudo apt-get install linux-image-sparky-686-pae

Then reboot you machine to take effects.

To quick remove older version of the Linux kernel, simply run APTus-> Remove-> Uninstall Old Kernel script.

 

Linux kernel 4.5.1

 

There is an update of the latest stable version of Linux kernel 4.5.1 available in Sparky “unstable” repository.

To install or upgrade it, activate Sparky “unstable” repository:
sudo nano /etc/apt/sources.list.d/sparky.list
and make sure the list looks like that:
## sparky
deb http://sparkylinux.org/repo/ testing main
deb-src http://sparkylinux.org/repo/ testing main
deb http://sparkylinux.org/repo/ unstable main
deb-src http://sparkylinux.org/repo/ unstable main

Then refresh package list:
sudo apt-get update

And install the latest kernel via the meta packages.
amd64:
sudo apt-get install linux-image-sparky-amd64
686 non-pae:
sudo apt-get install linux-image-sparky-686
686-pae:
sudo apt-get install linux-image-sparky-686-pae

or just make full system upgrade if you have the previous Sparky Linux kernel meta-packages already installed.

Then reboot you machine to take effects.

 

Updates 2016/04/03

 

There are a few 3th party updates in our repository ready to go:
– Grub Customizer 5.0.5
– Steam & Steam Launcher 1.0.0.52
– Tint2 0.12.9
– TOR Messenger 0.1.0b6 (beta)
– Xfdashboard 0.5.92
– XnViewMP 0.79

Upgrade your system as usually:
sudo apt-get update
sudo apt-get dist-upgrade

or via ‘Update Tool’ or ‘Synaptic’ if you wish.

 

Linux kernel 4.5.0

 

There is the Linux kernel 4.5.0 available in Sparky “unstable” repository.

It is a home roasted, the latest stable Linux kernel which provides the latest set of drivers for many devices. The kernel is placed in Sparky “unstable” repository, which is inactive as default to make sure you will enable it only if you wish.

Anyway if you would like to install Sparky’s Linux kernel, do:

1. Activate Sparky “unstable” repository, editing (as root), the file:
/etc/apt/sources.list.d/sparky.list
and make the list as below:
## sparky
deb http://sparkylinux.org/repo/ testing main
deb-src http://sparkylinux.org/repo/ testing main
deb http://sparkylinux.org/repo/ unstable main
deb-src http://sparkylinux.org/repo/ unstable main

2. Refresh package list:
sudo apt-get update

3. Install the latest kernel.
amd64:
sudo apt-get install linux-image-sparky-amd64
686 non-pae:
sudo apt-get install linux-image-sparky-686
686-pae:
sudo apt-get install linux-image-sparky-686-pae

Then reboot you machine to take effects.

The Linux headers packages are also available to install.
amd64:
sudo apt-get install linux-headers-sparky-amd64
686 non-pae:
sudo apt-get install linux-headers-sparky-686
686-pae:
sudo apt-get install linux-headers-sparky-686-pae

Some external modules should be rebuilt/reinstall after, for example Virtualbox or VMware modules, for example:
sudo dpkg-reconfigure virtualbox-dkms

Make sure that Sparky is shipped with Debian’s Linux kernel as default, but the newest kernel can be installed manually from our repos, if you wish.

 

Advertising