Advertising

Yarock

There is a new appliacation available for Sparkers: Yarock.

From the project web site:

Yarock is a modern looking music player, packed with features, that doesn’t depend on any specific desktop environment. Yarock is designed to provide an easy and pretty music browser based on cover art. Yarock is easy to build with a minimal set of dependancies, and offers the choose of differents audio back-end.

It is a Qt based application, which supports multiple audio back-ends (Phonon, vlc, mpv); compiled with the Phonon as default; supports MP3, Ogg Vorbis, FLAC, WMA, MPEG-4 AAC music files (depending on audio back-end). It also supports radio stream services such as TuneIn, SHoutCast, Dirble.

Installation:
sudo apt update
sudo apt install yarock

Yarock

 

RSS Guard

There is a new appliacation available for Sparkers: RSS Guard.

RSS Guard is simple, light and easy-to-use RSS/ATOM feed aggregator developed using Qt framework which supports online feed synchronization.

Installation:
– via Synaptic
– via APTus Extra >= 0.1.50
– via APT:
sudo apt update
sudo apt install rssguard

Then run the tool from menu-> Network

The appliacation reqiures Qt >= 5.8, so it is compatible with, and can be installed on Sparky 5 / Debian Buster/Sid.

RSS Guard

 

Dooble

A new application landed in Sparky repos: Dooble.

Dooble is a secure, open source, WebKit based web browser that provides solid performance, stability, and cross-platform functionality.

From Wikipedia:

Dooble was created to improve privacy. Currently, Dooble is available for FreeBSD, Linux, OS X, OS/2, and Windows. Dooble uses Qt for its user interface and abstraction from the operating system and processor architecture. As a result, Dooble should be portable to any system that supports OpenSSL, POSIX threads, Qt, SQLite, and other libraries.

Installation:
sudo apt update
sudo apt install dooble

Dooble

If Dooble will not start, try to launch it in a terminal emulator via the command:
dooble
and paste an output on ours forums, please.

 

QT 5.7.0 doesn’t support GTK theming

The QT 5.7.0 doesn’t support GTK theming, so after upgrade Qt related packages, the Qt based applications look… not really nice on GTK based desktops.

How to fix it:
sudo apt update
sudo apt install qt5-style-plugins

Then:
sudo echo "QT_QPA_PLATFORMTHEME=gtk2" >> /etc/environment
or
su
nano /etc/environment

and past into the file:
QT_QPA_PLATFORMTHEME=gtk2
then:
sudo reboot

That’s all. The first screen shows a Qt5 based application before, the second one after.

QMPlay2 before    QMPlay2 after

 

Otter browser

 

The Otter web browser 0.9.10 landed in Sparky repository.

From Wikipedia:

Otter Browser is a free and open-source web browser that aims to recreate the best aspects of the classic Opera (web browser) (12.x) using Qt framework while keeping seamless integration with users’ desktop environments. Otter Browser is licensed under GPLv3.

The present version is still in beta stage, but I recommend to give it a try.

Installation:
sudo apt-get update
sudo apt-get install otter-browser

Otter browser

 

Advertising