Advertising

Author Topic: <SOLVED>I have an issue with ndiswrapper.  (Read 432 times)

Offline kreitzer

  • Newbie
  • *
  • Posts: 2
<SOLVED>I have an issue with ndiswrapper.
« on: August 12, 2019, 04:36:36 am »
I tried ndiswrapper on a couple of distros before and my wireless card goes better, especially with a weak connection.

But in sparky is not working. I just installed and updated SparkyGameOver ed. And when I installed ndiswrapper I realized that it doesn't work.

Code: [Select]
~$ ndiswrapper -v
modinfo: ERROR: Module ndiswrapper not found.
module version is too old!
utils version: '1.9', utils version needed by module: '0'
module details:
modinfo: ERROR: Module ndiswrapper not found.

You may need to upgrade driver and/or utils to latest versions available at
http://ndiswrapper.sourceforge.net


I downloaded ndiswrapper source and I couldn't install it either.

Code: [Select]
:/usr/src/modules/ndiswrapper$ sudo make
[sudo] password for sparky:
Makefile:32: *** No .config found in /usr/lib/modules/4.19.0-5-amd64/build, please set KBUILD to configured kernel.  Stop.


Is there a way to fix it easily? Thanks in advance.
« Last Edit: August 12, 2019, 07:42:44 pm by kreitzer »

Offline lami07

  • Global Moderator
  • Full Member
  • *****
  • Posts: 105
    • Sparky Community Repos
Re: I have an issue with ndiswrapper.
« Reply #1 on: August 12, 2019, 07:31:08 am »
Have you read this article ?
https://wiki.debian.org/NdisWrapper
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline kreitzer

  • Newbie
  • *
  • Posts: 2
Re: I have an issue with ndiswrapper.
« Reply #2 on: August 12, 2019, 07:41:32 pm »
I'd skimmed through the page a few times before. But what I didn't know was that I had to install a module manually. I'm still very new to linux.

Anyway, thank you very much for your help.

This is what I had to do:

Code: [Select]
apt-get install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') ndiswrapper-utils-1.9 wireless-tools