Advertising

Author Topic: No Cache for Ultra-Flat-Icons  (Read 5943 times)

Offline lnranger

  • Newbie
  • *
  • Posts: 1
No Cache for Ultra-Flat-Icons
« on: July 28, 2019, 09:36:55 pm »
Under Appearance-Icons, I am warned that there is no cache for ultra-flat-icons. Tried running gtk-update-icon-cache /usr/share/icons/ultra-flat-icons/ in terminal. It did not work. Please advise.

Offline paxmark1

  • Hero Member
  • *****
  • Posts: 625
Re: No Cache for Ultra-Flat-Icons
« Reply #1 on: July 28, 2019, 10:56:57 pm »
more info - DE - Version     

inxi is installed automatically now in Sparky.
Don't make a FrankenDebian

Offline penguin

  • Full Member
  • ***
  • Posts: 127
Re: No Cache for Ultra-Flat-Icons
« Reply #2 on: September 09, 2019, 06:59:10 am »
I noticed the same fact yesterday after installing of Sparky 6 (semi rolling) in a new partition of my SSD. I tried to generate icon-cache(by icon cache command in terminal), but said that icon cache generated was not valid(or something like this). But.... do not use these icons (with missing icon cache ) because XFCE 4.14 will suffer by a small delay when you click on each application. Yes. The are delays. XFCE reacts badly .
pavroo. repair icon cache for ultra flat icon(as said ,I have been not able to generate a valid new one), or remove and substitute with another one icon set. Personally I did not liked Sparky6 theme with Tela (starting Sparky initially).Was to gray and gives me a bad perception. Sparky5 theme was good but in my opinion should be combined with Numix icons.

I will advice to use more colorful theme and more colorful icon set.Those can be more attractive for new users.There are plenty of icon set in internet. Combination of lets say Adwaita with Faenza (blue with blue and similar window set to Redmond or Mac 3 color pills as Agua,Agualemon,Gnububble,Pills),
Personally, I use for years Revival icons, (modified a little bit from myself to display a vibrant green color), XFCE theme modified by me to coincide with my modified Revival and Walis windows decoration or such kind of window decorations as Gelly,Smoothwall, Daloa,Wildbush,Tyrex,Balckwall etc. (similar to Redmond).


P.S.
I have tried to install KDE desktop from Aptus in Sparky6 but installer did not concluded and stooped with error.I will try today,by a manual install or by Synaptic.I am not sure if installers of other desktop works because generally I use XFCE. The same for installer of other utilities. I will try to gave a test.
« Last Edit: September 09, 2019, 04:22:14 pm by penguin »

Offline penguin

  • Full Member
  • ***
  • Posts: 127
Re: No Cache for Ultra-Flat-Icons
« Reply #3 on: September 09, 2019, 05:35:00 pm »
Under Appearance-Icons, I am warned that there is no cache for ultra-flat-icons. Tried running gtk-update-icon-cache /usr/share/icons/ultra-flat-icons/ in terminal. It did not work. Please advise.

Seems that I found a solution by try and error.

Lets say that you will have your icons in this folder ( /usr/share/icons/). I have tried with a new icons set (Anthu icons set , very colorful) that also had an invalid cache.  I installed all set of icons under local directory ( /home/penguin/.local/share/icons/ . My user name is penguin). Applying of the the follow command in Terminal
Code: [Select]
gtk-update-icon-cache -f /home/penguin/.local/share/icons/Antu-universal-fast-safe-mode/
gave me this : The generated cache was invalid. Hmmm. First approach. I copied a valid icon cache from another icon theme( /usr/share/icons/My Revival icon Set ) to
Code: [Select]
/home/penguin/.local/share/icons/Antu-universal-fast-safe-mode/ directory and... no icon cache error(when open Xfce>Settings>Icons). Hmmm.

But this is not the right way. Comparing two icon cache files I found the difference. My icon-theme.cache from /usr/share/icons/My Revival icon Set was not hidden (not with dot before name ) and had Permission executable set . So???

I reapplied command
Code: [Select]
gtk-update-icon-cache -f /home/penguin/.local/share/icons/Antu-universal-fast-safe-mode/ and renamed file .icon-theme.cache to icon-theme.cache.  You can try in this way. Rename icon-theme.cache file in the /use/local/icons/ultra flat (the correct name, or move ultra flat icon directore under ./home/user//local/share/icons/ , reapply command and rename file to  icon.theme.cache as I did.
« Last Edit: September 10, 2019, 08:09:16 am by penguin »