Advertising

Author Topic: <SOLVED>Upgrade issue  (Read 335 times)

Offline TheFalcon

  • Newbie
  • *
  • Posts: 11
  • Thank you Linus!
<SOLVED>Upgrade issue
« on: June 04, 2019, 02:13:12 pm »
Running SparkyLinux 4 tyche 64bit on Intel i7 with 4.9.0-8-amd64 kernel. Desktop is LXDE/Openbox and the system is several years old. Just recently during scheduled updates the apt-us dialog has started displaying 'Can NOT detect sparky installation'. This occurs immediately after the normal header download terminal window closes.

I can go to the terminal and do an apt-get update and also apt dist-upgrade without any problems so I'm not exactly stuck, however it's a bit annoying given the usually easy upgrade process. Any ideas?  :-\

« Last Edit: June 05, 2019, 04:00:29 pm by TheFalcon »
Regards,
    TheFalcon.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2011
    • SparkyLinux
Re: Upgrade issue
« Reply #1 on: June 04, 2019, 08:20:35 pm »
Show me output of the commands, please:
Code: [Select]
cat /etc/issue
cat /etc/os-release
apt policy sparky4-apt
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net

Offline TheFalcon

  • Newbie
  • *
  • Posts: 11
  • Thank you Linus!
Re: Upgrade issue
« Reply #2 on: June 05, 2019, 01:21:16 am »
Thank you for your prompt reply, as always pavroo. Following is the requested command output.

Code: [Select]
$ cat /etc/issue

          .sm`        .-/oy:
         :shN    .:+shdmNh+`
        /sodh ./shyhmNNy`
       :sooNyyyyyhmmmdhhddddhhyso/-
       yo+oNyssymdhhhhdmmmmmmmmmmmmmy`  SSS  PPPP   AA  RRRR  K  K Y   Y L    III N   N U   U X   X
      :o++yyooydyyhdyo/:::/++oyo::/++` S     P   P A  A R   R K K   Y Y  L     I  NN  N U   U  X X
yy+.  o+++hsoomosm/ `:/++/:--::os:      SSS  PPPP  AAAA RRRR  KK     Y   L     I  N N N U   U   X
+hoys+ss//sd+om/ds:dy/:--/oydho++sh:       S P     A  A R R   K K    Y   L     I  N  NN U   U  X X
 yy+++sm+//dd+hhhNNhdddhdy/:/omNhssds` SSSS  P     A  A R  RR K  K   Y   LLLL III N   N  UUU  X   X
  sh/::/yy/:sdhdNd   .hh./dy//+dNhmddd.
   :ds:---+ooosyhms:s+/N+--ms+ooN-`+dNm:   Small Business Server Edition      _
     +dy+-.```.-..+my//N/::ydoosms   :yo                                  |  | |
      `/dmdhyyyyhdysosms///mNyssmy       __   __          ,_  ,__  ,_  ,__|  | |
  syyhdhhhhhhhyyyyyhmdsooodNomyyN+      |  | /  `_|  |  | |_| |  | |_| |  |  |  `_|  |
  :+shdmNNmmmmmmNNddhssshNd. ohmN`      |__| `__/  `/ `/  |__ |    |__ |__|  |__/  `_|
         `.----.` /hhhdNm+   .NM+      /|                                           /|
                `smmNms:      +/       `|                                           `|
                dmy+-
          _,met$$$$$gg.
       ,g$$$$$$$$$$$$$$$P.                             _,           _,      ,'`.
     ,g$$P""       """Y$$.".             $$           $$        `'
    ,$$P'              `$$$.             $$           $$         _,           _
  ',$$P       ,ggs.     `$$b:      ,d$$$g$$  ,d$$$b.  $$,d$$$b.`$$' g$$$$$b.`$$,d$$b.
  `d$$'     ,$P"'   .    $$$      ,$P'  `$$ ,$P' `Y$. $$$'  `$$ $$  "'   `$$ $$$' `$$
   $$P      d$'     ,    $$P      $$'    $$ $$'   `$$ $$'    $$ $$  ,ggggg$$ $$'   $$
   $$:      $$.   -    ,d$$'      $$     $$ $$ggggg$$ $$     $$ $$ ,$P"   $$ $$    $$
   $$;      Y$b._   _,d$P'        $$    ,$$ $$.       $$    ,$P $$ $$'   ,$$ $$    $$
   Y$$.    `.`"Y$$$$P"'           `$g. ,$$$ `$$._ _., $$ _,g$P' $$ `$b. ,$$$ $$    $$
   `$$b      "-.__                 `Y$$P'$$. `Y$$$$P',$$$$P"'  ,$$. `Y$$P'$$.$$.  ,$$.
    `Y$$b
     `Y$$.                         /S /Debian GNU/Linux 9
       `$$b.                       \v
         `Y$$b.                    \n \U
           `"Y$b._                 (\l)

END cat /etc/issue -------------------------------------------------

Code: [Select]
$ cat /etc/os-release

PRETTY_NAME="SparkyLinux 4 (tyche)"
NAME="SparkyLinux"
VERSION_ID="4"
VERSION="4 (tyche)"
ID=debian
HOME_URL="https://sparkylinux.org/"
SUPPORT_URL="https://sparkylinux.org/forum/"
BUG_REPORT_URL="https://sourceforge.net/p/sparkylinux/tickets"

END cat /etc/os-release ------------------------------------------

Code: [Select]
$ apt policy sparky4-apt
sparky4-apt:
  Installed: (none)
  Candidate: 20190127.3
  Version table:
     20190127.3 1001
       1001 https://sparkylinux.org/repo core/main amd64 Packages
       1001 https://sparkylinux.org/repo core/main i386 Packages

END cat /etc/os-release ------------------------------------------

« Last Edit: June 05, 2019, 08:09:41 am by lami07 »
Regards,
    TheFalcon.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2011
    • SparkyLinux
Re: Upgrade issue
« Reply #3 on: June 05, 2019, 02:19:39 pm »
You have to install the latest version of sparky-apt and sparky4-apt packages, then refresh package list and make upgrade.
Code: [Select]
sudo apt update
sudo apt install sparky-apt sparky4-apt
sudo apt update
sudo apt full-upgrade
Read the wiki if any problem:
https://sparkylinux.org/wiki/doku.php/repository_stable
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net

Offline TheFalcon

  • Newbie
  • *
  • Posts: 11
  • Thank you Linus!
Re: Upgrade issue
« Reply #4 on: June 05, 2019, 03:59:54 pm »
Ok, well that's shed some light on the issue and it is likely my own fault. I'm a C/C++ programmer and I may have at some stage broken my own sparky system. Libc is the problem and the light is shed by the response to your suggested sudo apt install sparky-apt sparky4-apt.

sparky4-apt : Depends: libc6 (<= 2.27) but 2.27-3 is to be installed.

Sparky wants 2.27 and I have 2.27-3 installed. Dropping back to the previous 2.24-11+deb9u1 unleashes dependency hell and I've been working with this version of libc for some time now. Not sure what might break there but as stated earlier it's not a huge issue as I can still update from the terminal or via synaptic. I'll probably leave it that way for now. Should fix itself in time as long as I don't get smart with libc again. So thanks for your assistance pavroo and sorry to waste your time like that when I was at fault. I'll mark as solved so someone else may think twice before getting clever.  ::)

PS: Apologies for not posting in the upgrade section, I didn't notice it until after I'd posted here. Feel free to move it if you wish. ;)
« Last Edit: June 05, 2019, 04:02:59 pm by TheFalcon »
Regards,
    TheFalcon.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2011
    • SparkyLinux
Re: <SOLVED>Upgrade issue
« Reply #5 on: June 06, 2019, 12:07:35 am »
It is misunderstanding for me now.
You have Sparky 4 which is based on Debian Stretch so you should have libc6 2.24.x installed not 2.27.
How did you install it from?
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net

Offline TheFalcon

  • Newbie
  • *
  • Posts: 11
  • Thank you Linus!
Re: <SOLVED>Upgrade issue
« Reply #6 on: June 06, 2019, 01:38:27 am »
Truth is I don't recall pavroo,

I do a lot of compiling from source and recently I've been looking at various software tools and libraries not all available from the repos. Somewhere along the line it's likely one of these compilations required the 2.27 version of libc and I upgraded. It's unlikely I compiled libc from source so it has probably come from one of the other debian repos. All a bit embarrassing really as I am a seasoned Linux guy having been using this OS almost since it's release back in the 90's. I should know better, libc is a central part of the system and it is not wise to get out of sync with the distro version of libc. I know this but obviously did it anyway and don't recall why. So you see no one to blame but myself and I'll probably end up installing Sparky 5 and move my programming stuff over when ready. Anyway I'll sort it out and try to refrain from future silly actions.  :-[
Regards,
    TheFalcon.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2011
    • SparkyLinux
Re: <SOLVED>Upgrade issue
« Reply #7 on: June 06, 2019, 12:26:59 pm »
I incereased sparky4-apt libc6 deps up to lower than 2.28, so you can try again if you'd like.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net