Advertising

Author Topic: I decided to upgrade to buster  (Read 1716 times)

Offline penguin

  • Full Member
  • ***
  • Posts: 119
Re: I decided to upgrade to buster
« Reply #15 on: July 12, 2019, 07:41:27 am »
@pamark1

I had idea to open a new thread yesterday, after that thought to mix with my thread open times ago.

Simply. I upgraded to Buster. In Sparky 4.11(Stretch) still folks can install deb packages with gdebi. With Buster , simply gdebi quits. Maybe not with all deb packages. For this reason I used terminal with command sudo dpkg -i XX.deb and buummm error that I posted (I lots my original error and for this reason I copied from interment , but practically the same error).
So ? I arrive din conclusion that gdebi did not arrived to install(and quits) because of changing of ENV_PATH. I tried to export path and etc. I googled a lot but no body explains simply as : gdebi needs modification ( or did not arrive to install deb packages) for this simple think. for this fact I posted  in the forum to share my experience and conclusion. Anyone with the same problem ? This was/is the reason. So ...? To install a package in Buster (a deb package) , proceed as follow:

In terminal
1- su - and not su / give the sudo password
2- dpkg - i XX.deb or use aptitude(I did not tried to see how the aptitude react with su and not su -)

If you use sudo dpkg -i XX.deb or su and after dpkg -i XX.deb you will get error.


Solution (the simplest one) . Use gdebitool  install it ( thank you pavroo)

That was.

P.S.
Simple question. I use XFCE desktop. Passing to new the version of XFCE when I right click in desktop, in the menu that shows up - no anymore : Open Terminal Here or Search(i use fsearch). For the right click menu in desktop ,I use custom actions in Thunar , as here :
Code: [Select]
https://docs.xfce.org/xfce/thunar/custom-actionsSparkyLinux 4.10 or 4.11 did not suffer from this issue ( previous XFCE) .I played I little bit with as shown here :

Code: [Select]
https://forum.xfce.org/viewtopic.php?id=6234
or here

Code: [Select]
https://wiki.xfce.org/howto/customize-menu

but I did not arrived to substitute some actions in right click menu that shows up in desktop. I use also ARCH Linux. ARCH maybe have use a more updated version of XFCE and this problem now is solved (also XFCE in ARCH suffered some months before from this ). Any one has arrived to have the same menu ( right click in desktop > Open Terminal Here .... directly on menu and not under Applications (submenu)) ?

Old right click menu on desktop :

https://i.stack.imgur.com/MOrm5.png
and the new one on the follow picture.

https://arcolinux.com/wp-content/uploads/2018/09/context.jpg
Someone mention here:

Code: [Select]
https://forum.xfce.org/viewtopic.php?id=12491
https://i.imgur.com/bzSi3T1.jpg
« Last Edit: July 13, 2019, 06:29:34 am by penguin »

Offline paxmark1

  • Hero Member
  • *****
  • Posts: 606
Re: I decided to upgrade to buster
« Reply #16 on: July 12, 2019, 09:51:45 pm »
Thank you. That is a very nice and clear and clean ending.

 I did go into deep detail why my opinion that some of your cited sources could get people into trouble or were a sidetrack (tangential).   Very interesting that "sudo dpkg -i XX.deb" yields an error.  That is not good

Looking at https://packages.debian.org/jessie/gdebi    and the change logs and then especially looking at

https://packages.debian.org/stretch/gksu    and it's change logs does show that there are some deep problems with gksu tht affect gdebi. 

But, yes, you did a fantastic job on the previous post.  Thank you. 

Don't make a FrankenDebian