Advertising

Author Topic: Aptus Window can you allow vertically resize?  (Read 263 times)

Offline penguin

  • Full Member
  • ***
  • Posts: 107
Aptus Window can you allow vertically resize?
« on: April 08, 2019, 09:39:35 am »
Aptus.

Hi Pavro. I will recommend ( if this will no cause troubles to you ) some cosmetic changes to Aptus.

Te Aptus window cannot resized vertically, probably because yad settings do not allow it. Can you allow it because actually is not comfortable. If you can save Aptus settings somewhere it is great(that yad can remember the last settings). Smaller icons ? Why not. I began to modify the Aptus file from /usr/bin but I stopped.

I do not thinks that is difficulty to produce something similar to Aptus by Lazarus or Gambas. I think that some people can offer help there.
I can try to produce something very fast(believe is no difficulty). Lazarus produces portables but Gambas can produce also deb packages.
The ''hardest'' part is only the command behind the click.

Take your time , because is not urgent.

Thanks for your dedication and wonderful job.
 



Offline penguin

  • Full Member
  • ***
  • Posts: 107
Re: Aptus Window can you allow vertically resize?
« Reply #1 on: April 16, 2019, 09:39:01 am »
Hi pavro. Sorry being embarrassing .

I use latest Sparky Stable XFCE.

Please check and upgrade versions e software in Aptus.
Today I found a new version of Lucky Backup (deb file) , tried to install and give me same errors(conflict) with Sparky Lucky Backup (that is older).
It is impossible to install Falcon Browser from Aptus. Gives Error.

I would like to have the latest of qt-fsarchiver or qt5-fsarchiver in Aptus. Is really worthy.
I downloaded both above versions, managed to install successfully but no one did not start (strange ... they should start from /usr/sbin/qt5-fsarchiver.sh ). 
I need to check the difference with qt4-fsarchiver that I get from MX Linux repositories because 64 bit version is not available in https://sourceforge.net/projects/qt4-fsarchiver/
qt4-fsarchiever from MX repos, runs fine in Sparky Linux.




Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1987
    • SparkyLinux
Re: Aptus Window can you allow vertically resize?
« Reply #2 on: April 16, 2019, 02:04:21 pm »
Hi
The latest version of luckybackup in Stretch repos is 0.4.8 which you probably have installed (I guess).
And if you downloaded deb version 0.5.0 from the luckybackup project page - it makes conflict for sure.
I happens couse debian devs devide packaes to a few ones, and oryginal devs don't.
So...
Uninstall luckybackup & luckybackup-data packages, then install the deb from the project page.

qt4-fsarchiver and qt5-fsarchiver are not under development any more, mayby that's why they don't work.
Did you try to install qt-fsarchiver instead?

Edit
Have installed qt-fsarchiver and it doesn't start as you said, so digging into found a problem.
You can manually start the app via the command:
/usr/sbin/qt-fsarchiver

Will redebianize it and move to sparky repos after.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net

Offline penguin

  • Full Member
  • ***
  • Posts: 107
Re: Aptus Window can you allow vertically resize?
« Reply #3 on: April 16, 2019, 04:32:43 pm »
Removed Lucky Backup 0.4.8 and tried to install Lucky Backup 0.5.0.1


Aptus does not fully remove  lucky backup 0.4.8 and I removed by hand follow entries:

Quote
/usr/share/lucky backup
/usr/share/doc/lucky backup
Couples of errors ..

Quote
(Reading database ... 306389 files and directories currently installed.)
Preparing to unpack .../luckybackup_0.5.0-1_amd64.deb ...
Unpacking luckybackup (0.5.0-1) ...
dpkg: error processing archive /mnt/storage/penguin/downloads/luckybackup_0.5.0-1_amd64.deb (--install):
 trying to overwrite '/usr/share/doc/luckybackup/manual/data/CommandLine.png', which is also in package luckybackup-data 0.4.8-3
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for gnome-menus (3.13.3-9) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for mime-support (3.60) ...

As per qt-fasrchiver.
I tried the latest version. After nstall, the path should be changed manually (as I and You mentioned .... to /urs/bin/qt-fsarchiver instead of qt-archiver in whisker menu > I use XFCE ). Application can be launched also by Terminal but takes few times more than qt4-fsarchiver to start.I removed this version and tried to install and run qt5-fsarchiver. The path should be changed manually to /usr/sbin/qt5-fsarchiver instead of /usr/sbin/qt-fsarchiver in whisker menu.But application does not run. Should be launched by terminal as sudo or by XFCE whisker > gksudo /usr/sbin/qt-fsarchiver.  The sparky remsu /usr/sbin/qt-fsarchiver does not start application.
Errors as follow:

Quote
penguin@penguin-pc:~$ remsu /usr/sbin/qt5-fsarchiver
QXcbConnection: Could not connect to display
/usr/bin/remsu: line 7: 10243 Aborted                 pkexec "$@"

I will stick will qt4-fsarchiver fom MX Linux Repos ( I suggest to include this version in Aptus)
 
If you decide to include latest version consider my test or test before by yourselves

P.S.
Please allow resizing of Aptus vertically (and if possible keep somewhere on settings the height that user chose). The Aptus windows is to big for some screens.
« Last Edit: April 16, 2019, 04:39:35 pm by penguin »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1987
    • SparkyLinux
Re: Aptus Window can you allow vertically resize?
« Reply #4 on: April 16, 2019, 06:17:58 pm »
APTus removed luckybackup package only, did not remove data, so:
Code: [Select]
sudo apt purge luckybackup-dataor
Code: [Select]
sudo dpkg -r luckybackup-data
APTus can not be resized verticaly due to the categories dispalyed on the left side, it is the smallest height as I can do.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1987
    • SparkyLinux
Re: Aptus Window can you allow vertically resize?
« Reply #5 on: April 17, 2019, 03:49:28 pm »
According to the qt-fsarchiver question, I have compiled it myself so it is available for Sparky 4 and 5 i386 and amd64 straight from Sparky repos:
https://sparkylinux.org/qt-fsarchiver/
Have a test, please.
Dont't forget to remove the developer's deb before installing from repos.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net