Advertising

Author Topic: for the record, I think sparky LXDE/LXQt is perfect, "Out of the box!"  (Read 308 times)

Offline kanliot

  • Jr. Member
  • **
  • Posts: 57
Right now I'm running sparky Stable and sparky Rolling.  The Stable machine, which is older had it's main hard disk go "BRRRTTTTTTT" (Seagate 3TB) and then crash, so it's getting fixed.


I think LXDE/LXQT is perfect.  I use alt-tab, alt-esc, (Firefox and terminals)  for long periods, and LXQt is above what I need.

I do have major problems getting xterm to load the .Xresources file that it needs.  it seems to ignore it.   I think the .profile file isn't getting loaded when I run xterm from "lxqt runner" , and even when I use a different method, there's still a very evident color problem.  I guess I'm asking for an explanation.

I could use qterminal, however "vimdiff" seems buggy in qterminal, with lines randomly not showing.  I also use Ctrl+pagedown in Midnight Commander and qterminal doesn't always allow that keystroke.

Good decisions!  Let me know if I can help your team!

Online lami07

  • Global Moderator
  • Jr. Member
  • *****
  • Posts: 88
    • Sparky Community Repos
Quote
I do have major problems getting xterm to load the .Xresources file that it needs.  it seems to ignore it.   I think the .profile file isn't getting loaded when I run xterm from "lxqt runner" , and even when I use a different method, there's still a very evident color problem.

Could you provide more details on this? Will try to diagnose this issue.
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline kanliot

  • Jr. Member
  • **
  • Posts: 57
I think part of the problem is that lxqt-runner randomly switches between uxterm and xterm.

I really did think it was a .profile problem, just because the colors in my bash prompt seem disabled  until I start doing things.

XTerm*metaSendsEscape: true  #doesn't work for uxterm
xterm*metaSendsEscape: true  #does work for uxterm


confusing huh?  And by work, I mean doesn't output non-latin characters when I'm typing ALT+ABCDEF....

Offline kanliot

  • Jr. Member
  • **
  • Posts: 57
on the prompt color problem, i think it's just a bug in .bashrc  I think it's the original sparky lxqt .bashrc.



# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color|*-256color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
   # We have color support; assume it's compliant with Ecma-48
   # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
   # a case would tend to support setf rather than setaf.)
   color_prompt=yes
    else
   color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac


You can see that color_prompt isn't set.
then later on in the script, xterm-256-color is set... but after the code i've pasted.
so if you run bash twice, it runs correctly, but not unless it's run twice.