Advertising

Author Topic: freshclam enters infinite loop (Solved)  (Read 415 times)

Offline xamaco

  • Newbie
  • *
  • Posts: 4
freshclam enters infinite loop (Solved)
« on: March 08, 2019, 10:25:55 pm »
Hello,

since the last two system uprades freshclam is entering an infinite loop when upgrading, eating up about 50% of CPU performance. The last two lines in my /var/log/clamav/fresclam.log are (string http changed to xttp to avoid automatic formatting):

Fri Mar  8 21:28:37 2019 -> Trying to download xttp://db.local.clamav.net/daily-25380.cdiff (IP: 104.16.218.84)
Fri Mar  8 21:28:49 2019 -> Downloading daily-25380.cdiff [100%]

Here it comes to hanging... A ping shows that the download source 104.16.218.84 is living so it really seems to be a local problem. ClamAV itself was recently updated. Are there any changes in configuration, which have to be done manually?

The program version is
                                    ClamAV 0.101.1/25378/Mon Mar  4 11:47:26 2019

Is anybody there with the same problem? Killing freshclam after every boot is annoying so I would appreciate any idea to get rid of this behaviour.
« Last Edit: April 01, 2019, 11:15:23 pm by xamaco »

Offline paxmark1

  • Hero Member
  • *****
  • Posts: 551
Re: freshclam enters infinite loop
« Reply #1 on: March 09, 2019, 06:39:42 am »
Nothing on BTS that catches my eye
https://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=clamav;dist=unstable

You might want to look upstream in development.
Don't make a FrankenDebian

Offline suthron

  • Newbie
  • *
  • Posts: 1
Re: freshclam enters infinite loop
« Reply #2 on: March 09, 2019, 11:01:27 am »
I have the exact same problem on Mint 19.1. I have tried uninstalling, purging, reinstalling, second purge and reinstall from different source, no difference.

Offline xamaco

  • Newbie
  • *
  • Posts: 4
Solved: freshclam enters infinite loop
« Reply #3 on: April 01, 2019, 11:12:37 pm »
Hello out there,

meanwhile I did some more work to solve the freshclam loop issue.

One of the URLs given in file /etc/clamav/freshclam.conf could not be resolved by my network (I am running from behind a pihole). A ping to current.cvd.clamav.net ended up with this result:

ping: current.cvd.clamav.net: No address associated with hostname

Updating pihole to the latest version did not help.

Reconfiguring clamav (basically change to a db server more close to me) with

       sudo dpkg-reconfigure clamav-freshclam

did'nt help too.

Then I removed and purged clamav from the machine:

         sudo apt-get remove --purge clamav
         
Finally clamav was reinstalled:

         sudo apt-get install clamav

The configurations file /etc/clamav/freshclam.conf still contains the line

       DNSDatabaseInfo current.cvd.clamav.net

and the ping result for current.cvd.clamav.net is still the same as described above. The database mirror is pointing to a server in my country.

I do not understand why, but clamav is now working properly.
« Last Edit: April 01, 2019, 11:17:31 pm by xamaco »