Advertising

Author Topic: Kernel 5.0.2 sparky 64 bit  (Read 359 times)

Offline penguin

  • Full Member
  • ***
  • Posts: 116
Kernel 5.0.2 sparky 64 bit
« on: March 19, 2019, 08:54:44 pm »
I tried to install and run Kernel 5.0.2 in Sparky Stable (XFCE desktop).

This kernel starts but laptop hang on when I furnish my credentials on Lightdm login . Installing was made by Aptus and removing also too. But seems a problem because Aptus does not remove kernel correctly and system upgrade shows up in the next startup (when I start laptop by latest Debian Kernel ) . The upgrade continuous in loop,because upgrade wants to remove sparky kernel 5.0.2. I tried manually but gives me error.
Please pavro, can you investigate ? Any one has tried to run kernel 5.0.2 in sparky stable or has managed to remove it correctly?

P.S.
My fault. I managed to remove kernel 5.0.2. My grub has an additional line(added by me) to force Fujitsu AH532 to start fan. I removed this line and kernel was removed , but I am not very sure if kernel 5.0.2-sparky-64 function in Sparky stable XFCE.
« Last Edit: March 21, 2019, 07:54:28 am by penguin »

Offline lami07

  • Global Moderator
  • Jr. Member
  • *****
  • Posts: 91
    • Sparky Community Repos
Re: Kernel 5.0.2 sparky 64 bit
« Reply #1 on: March 20, 2019, 08:52:52 am »
Hi penguin. After initial reading of your thread I tried to recreate the issue on my machine. Unfortunately my sparky stable with xfce has no problem with newest sparky kernel (5.0.3-sparky-64). It might be individual issue of yours.
Quote from: penguin
This kernel starts but laptop hang on when I furnish my credentials Lightdm
Could you elaborate on this. Does your system hangs forever? Have you tried clicking your mouse and/or keyboard ? I know those two questions are silly, but they have some diagnostic value.
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net

Offline penguin

  • Full Member
  • ***
  • Posts: 116
Re: Kernel 5.0.2 sparky 64 bit
« Reply #2 on: March 20, 2019, 12:58:44 pm »
As I said . I had an additional line to start my Fujitsu AH532 fan on my laptop.
more or less this line : GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="!Windows 2012"" recommended on this forum :

Code: [Select]
https://askubuntu.com/questions/527909/fan-does-not-work-lifebook-ah532 . THis line gives me error in MX Linux when I updated kernel to 4.19 ( during kernel upgrade process). But this not happens to Sparky. Everything has gone fine (installing by Aptus). As I said. I installed kernel 5.0.2-sparky-64 in my XFCE desktop.

I have tried/used LXQT or LXDE in Sparky Stable or Sparky Rolling - but I have found/seen no any benefit from LXQT or LXDE desktops. Really are 100 mb lighter but XFCE is much more responsible and friendly to use, judging by my experience or by my point of view.And I thought that one of the reasons that Sparky is not so familiar to new users is using of LXDE or LXQT as default desktop(my opinion). Also personally love to much TDE (Trinity). Light, responsible and has all tools to manage users, processes and everything. but sadly is used by default only in Q4os or ExegnuLinux. This second one(Devuan based),is not mixed by author optimizations as first one , but suffer some personalisations issues.

So... I installed sparky 5.0.2 kernel-64 bit and laptop starts. I use Lightdm. Every thing goes fine up to log in scree, I furnish my Credentials / user/ pass and .... Sparky hangs. Should this famous line in grub that caused hang ? But Sparky runs fine with Debian Kernel 4.9.0.8 with this line. I can make another test today.
« Last Edit: March 20, 2019, 02:33:37 pm by penguin »