Advertising

Author Topic: Is system up to date ?  (Read 215 times)

Offline DanBe

  • Newbie
  • *
  • Posts: 2
Is system up to date ?
« on: March 10, 2019, 04:33:50 pm »
Hello,
Using Sparky 4.9.
Menu->System tools->Update system shows: "Your system is up to date"
While 'sudo apt update ' shows "114 packages can be upgraded."
Is my system up to date, or not ?

Is it safe to do:
apt upgrade
apt dist-upgrade ?

TIA for your help.
DanBe
--- Originall text -----------------------------------------------------------------------------------------------
Bonjour,
Je suis sous Sparky 4.9.
Menu->Outils système->Mise à jour du système indique "Votre système est à jour".
Alors que sudo apt update indique "114 packages can be upgraded."
Mon système est-il à jour, ou non ?

Est-ce sans danger de faire:
apt upgrade
apt dist-upgrade ?

Md'av pour votre aide.
DanBe

Offline paxmark1

  • Hero Member
  • *****
  • Posts: 514
Re: Is system up to date ?
« Reply #1 on: March 10, 2019, 09:41:11 pm »
Might I suggest

sudo apt -s  upgrade      ##followed by

sudo apt -s full-upgrade   ##   the "-s" switch will show a simulation of what would happen (as best as it can simulate). 

and compare.  Please post whatever seems most appropriate then in reply - please mark up as code. 

Please write up any modifications you have made to your Stable - non-rolling system especially if you have pinned packages and/or use DebianpBackports.  Please also write up any repos that you have added that are not from Sparky.  Or just post the output of inxi -r     In a spirit of openess - my inxi -r follows from a Debian stable machine - I am not on my virtual Sparky's or intel atom Sparky's
Code: [Select]
inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list                                                                                                 
           deb http://debian.mirror.rafal.ca/debian/ stretch main non-free contrib                                                                           
           deb-src http://debian.mirror.rafal.ca/debian/ stretch main non-free contrib                                                                       
           deb http://security.debian.org/debian-security stretch/updates main contrib non-free                                                             
           deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free                                                         
           deb http://httpredir.debian.org/debian stretch-backports main contrib non-free                                                                   
           Active apt sources in file: /etc/apt/sources.list.d/spideroakone.list                                                                             
           deb https://apt.spideroak.com/ubuntu/ release restricted     

Using a Ubuntu ppa is a true recipe for disaster all too often.  See my sig.    The one ppa you see for me is fairly well vetted for Debian.  It is my cloud backup provider. 
Don't make a FrankenDebian

Offline hedon

  • Newbie
  • *
  • Posts: 33
Re: Is system up to date ?
« Reply #2 on: March 11, 2019, 09:18:04 pm »
I have experienced something similar recently. 

As a newcomer to the rolling release model of distros in general, and Sparky specifically, I've been using Sparky in a VM for several months before I swap out all the OSes on my 8-10 network machines.  I've been diligently updating/upgrading Sparky whenever the Aptus(?) notification tells me something is available.  Starting sometime in early January, I stopped receiving notifications.  However, this was coincidental with notifications for "feature freezes" of Testing, and as a 9-year veteran of LTS distros I just chalked it up to business as usual for a rolling release model.  But I started seeing forum messages from pavroo(?) that indicated Testing repos were in motion again, so I started checking manually.  But Aptus kept telling me everything was up-to-date.  Except I KNEW that LXQt 0.14.1 was now available, and I've been waiting (not so) patiently for some newly added features in that release.  So even though Aptus indicated everything was fine, I tried from the CLI.

Code: [Select]
sudo apt update
indicated there were over 1060 packages to be updated!  continuing with the CLI, I typed:

Code: [Select]
sudo apt upgrade
and learned that there were "lock" files in place, even though no other applications were using apt.  I double-checked with

Code: [Select]
top
and verified nothing was running.  and for good measure, killed any running processes of apt.  i had previously encountered something similar in Lubuntu and solved with this link:

Quote
https://itsfoss.com/fix-ubuntu-install-error/

Inasmuch as Lubuntu is derived from Debian, I followed instructions, removed the lock files, reconfigured dpkg, re-ran

Code: [Select]
sudo apt upgrade
and everything was fine.  I watched Sparky upgrade 1060 files, totaling over 990MB, after slightly more than 2 months of inactivity, sitting on pins & needles the entire process!  But everything proceeded without issue, Sparky rebooted, and all was good again.  Despite the snafu, I'm pretty astonished that such a large upgrade happened without issue.  KUDOS to the devs!

So without knowing all the details of the original poster's scenario, I strongly suspect something similar.  I honestly don't know what caused the "locked file" message.  Could've even been something I did that I shouldn't have.  But I see the Aptus upgrade tool as partly culpable here.  I normally perform manual upgrades from the CLI, but coming to a new distro with a new tool, I followed the recommended way to update/upgrade.  But Aptus was failing spectacularly, telling me everything was up-to-date when, in fact, it wasn't.  The problem, as I see it, is that Aptus only throws 2 messages:  1 - upgrades are available or 2 - system is up-to-date

May I suggest that Aptus be modified to throw a third message, such as "something went wrong, try from the CLI".  If Aptus did this, I would've caught it immediately.  Just a suggestion, FWIW...

Offline DanBe

  • Newbie
  • *
  • Posts: 2
Re: Is system up to date ?
« Reply #3 on: March 11, 2019, 11:59:38 pm »
Thank you for you reply, paxmark1

Code: [Select]
$ (sudo) inxi -r
bash: inxi : commande introuvable (command not found)
No change or addition to the initial repos automatically programmed by the distro.
Only installed from the repos: linux-headers-686, mc (Midnight Commander),  geany (text editor), Firefox ESR, AisleRiot Solitaire + own bash and python scripts

Menu->System tools->Update system indicates: "Your system is up to date"

Output of $ sudo apt -s full-upgrade > full-upg.txt  :
Code: [Select]
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
Calcul de la mise à jour…
Les paquets suivants seront ENLEVÉS :
  sparky-core-x86
Les NOUVEAUX paquets suivants seront installés :
  sparky4-apt
Les paquets suivants seront mis à jour :
  apt apt-transport-https apt-utils calendar-google-provider chromium cups
  cups-client cups-common cups-core-drivers cups-daemon cups-ppdc
  cups-server-common curl dirmngr firefox-esr firefox-esr-l10n-fr
  fonts-opensymbol ghostscript gnupg gnupg-agent gnupg2 gpgv intel-microcode
  libapt-inst2.0 libapt-pkg5.0 libc-bin libc-dev-bin libc-l10n libc6 libc6-dev
  libcups2 libcupscgi1 libcupsimage2 libcupsmime1 libcupsppdc1 libcurl3
  libcurl3-gnutls libgd3 libgs9 libgs9-common libldb1 libpam-systemd
  libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5printsupport5
  libqt5widgets5 libreoffice libreoffice-avmedia-backend-gstreamer
  libreoffice-base libreoffice-base-core libreoffice-base-drivers
  libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
  libreoffice-gtk3 libreoffice-help-fr libreoffice-impress
  libreoffice-java-common libreoffice-l10n-fr libreoffice-math
  libreoffice-report-builder-bin libreoffice-style-galaxy
  libreoffice-style-tango libreoffice-writer libsmbclient libssh-4 libssl1.0.2
  libsystemd0 libudev1 libwayland-client0 libwayland-cursor0
  libwayland-server0 libwbclient0 libxapian30 lightning
  linux-compiler-gcc-6-x86 linux-headers-4.9.0-8-686
  linux-headers-4.9.0-8-common linux-image-4.9.0-8-686 linux-kbuild-4.9
  linux-libc-dev locales multiarch-support openssh-client python-ldb
  python-samba python3-uno rtkit samba-common samba-common-bin samba-libs
  smbclient sparky-apt sparky-aptus sparky-aptus-extra sparky-codecs
  sparky-core sparky-desktop sparky-desktop-data sparky-office
  sparky-usb-formatter sparky-webbrowser-installer systemd systemd-sysv
  thunderbird thunderbird-l10n-fr timeshift tzdata udev uno-libs3 ure
114 mis à jour, 1 nouvellement installés, 1 à enlever et 0 non mis à jour.
Inst libc6-dev [2.24-11+deb9u3] (2.24-11+deb9u4 Debian:9.8/stable [i386]) []
Inst libc-dev-bin [2.24-11+deb9u3] (2.24-11+deb9u4 Debian:9.8/stable [i386]) []
Inst linux-libc-dev [4.9.130-2] (4.9.144-3 Debian:9.8/stable [i386]) []
Inst libc6 [2.24-11+deb9u3] (2.24-11+deb9u4 Debian:9.8/stable [i386])
Conf libc6 (2.24-11+deb9u4 Debian:9.8/stable [i386])
Inst libc-bin [2.24-11+deb9u3] (2.24-11+deb9u4 Debian:9.8/stable [i386])
Conf libc-bin (2.24-11+deb9u4 Debian:9.8/stable [i386])
Inst libapt-pkg5.0 [1.4.8] (1.4.9 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf libapt-pkg5.0 (1.4.9 Debian:9.8/stable, Debian-Security:9/stable [i386])
Inst libapt-inst2.0 [1.4.8] (1.4.9 Debian:9.8/stable, Debian-Security:9/stable [i386])
Inst apt [1.4.8] (1.4.9 Debian:9.8/stable, Debian-Security:9/stable [i386]) [apt-utils:i386 ]
Conf apt (1.4.9 Debian:9.8/stable, Debian-Security:9/stable [i386]) [apt-utils:i386 ]
Inst apt-utils [1.4.8] (1.4.9 Debian:9.8/stable, Debian-Security:9/stable [i386])
Inst gpgv [2.1.18-8~deb9u3] (2.1.18-8~deb9u4 Debian:9.8/stable [i386])
Conf gpgv (2.1.18-8~deb9u4 Debian:9.8/stable [i386])
Inst libcurl3-gnutls [7.52.1-5+deb9u8] (7.52.1-5+deb9u9 Debian:9.8/stable, Debian-Security:9/stable [i386])
Inst apt-transport-https [1.4.8] (1.4.9 Debian:9.8/stable, Debian-Security:9/stable [i386])
Remv sparky-core-x86 [4~20171101] [sparky-core:i386 ]
Inst sparky-core [4~20171101] (4.20190128 SparkyLinux:stable [all]) []
Inst sparky-apt [4.20181227] (20190127 SparkyLinux:core [all]) []
Inst sparky4-apt (20190127.3 SparkyLinux:core [all])
Inst systemd-sysv [232-25+deb9u6] (232-25+deb9u9 Debian-Security:9/stable [i386])
Inst libpam-systemd [232-25+deb9u6] (232-25+deb9u9 Debian-Security:9/stable [i386]) []
Inst libsystemd0 [232-25+deb9u6] (232-25+deb9u9 Debian-Security:9/stable [i386]) [systemd:i386 ]
Conf libsystemd0 (232-25+deb9u9 Debian-Security:9/stable [i386]) [systemd:i386 ]
Inst systemd [232-25+deb9u6] (232-25+deb9u9 Debian-Security:9/stable [i386])
Inst udev [232-25+deb9u6] (232-25+deb9u9 Debian-Security:9/stable [i386]) []
Inst libudev1 [232-25+deb9u6] (232-25+deb9u9 Debian-Security:9/stable [i386])
Conf libudev1 (232-25+deb9u9 Debian-Security:9/stable [i386])
Inst libcupsmime1 [2.2.1-8+deb9u2] (2.2.1-8+deb9u3 Debian:9.8/stable [i386]) []
Inst cups-core-drivers [2.2.1-8+deb9u2] (2.2.1-8+deb9u3 Debian:9.8/stable [i386]) []
Inst cups-server-common [2.2.1-8+deb9u2] (2.2.1-8+deb9u3 Debian:9.8/stable [all]) []
Inst libcupsimage2 [2.2.1-8+deb9u2] (2.2.1-8+deb9u3 Debian:9.8/stable [i386]) []
Inst cups-common [2.2.1-8+deb9u2] (2.2.1-8+deb9u3 Debian:9.8/stable [all]) []
Inst cups-client [2.2.1-8+deb9u2] (2.2.1-8+deb9u3 Debian:9.8/stable [i386]) []
Inst libcupscgi1 [2.2.1-8+deb9u2] (2.2.1-8+deb9u3 Debian:9.8/stable [i386]) []
Inst libcupsppdc1 [2.2.1-8+deb9u2] (2.2.1-8+deb9u3 Debian:9.8/stable [i386]) []
Inst ghostscript [9.26~dfsg-0+deb9u2] (9.26a~dfsg-0+deb9u1 Debian:9.8/stable, Debian-Security:9/stable [i386]) []
Inst libgs9 [9.26~dfsg-0+deb9u2] (9.26a~dfsg-0+deb9u1 Debian:9.8/stable, Debian-Security:9/stable [i386]) []
Inst libgs9-common [9.26~dfsg-0+deb9u2] (9.26a~dfsg-0+deb9u1 Debian:9.8/stable, Debian-Security:9/stable [all]) []
Inst cups-ppdc [2.2.1-8+deb9u2] (2.2.1-8+deb9u3 Debian:9.8/stable [i386]) []
Inst cups-daemon [2.2.1-8+deb9u2] (2.2.1-8+deb9u3 Debian:9.8/stable [i386]) []
Inst libcups2 [2.2.1-8+deb9u2] (2.2.1-8+deb9u3 Debian:9.8/stable [i386]) [cups:i386 ]
Inst cups [2.2.1-8+deb9u2] (2.2.1-8+deb9u3 Debian:9.8/stable [i386])
Inst uno-libs3 [5.2.7-1+deb9u4] (5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386]) [ure:i386 ]
Inst ure [5.2.7-1+deb9u4] (5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386])
Inst libreoffice-base-drivers [1:5.2.7-1+deb9u4] (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386]) [libreoffice-base:i386 ]
Inst libreoffice-base [1:5.2.7-1+deb9u4] (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386]) []
Inst libreoffice-calc [1:5.2.7-1+deb9u4] (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386]) []
Inst libreoffice-impress [1:5.2.7-1+deb9u4] (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386]) []
Inst libreoffice-draw [1:5.2.7-1+deb9u4] (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386]) []
Inst libreoffice-gtk3 [1:5.2.7-1+deb9u4] (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386]) []
Inst python3-uno [1:5.2.7-1+deb9u4] (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386]) []
Inst libreoffice-base-core [1:5.2.7-1+deb9u4] (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386]) [libreoffice-writer:i386 ]
Inst libreoffice-report-builder-bin [1:5.2.7-1+deb9u4] (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386]) [libreoffice-writer:i386 ]
Inst libreoffice [1:5.2.7-1+deb9u4] (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386]) [libreoffice-writer:i386 ]
Inst libreoffice-math [1:5.2.7-1+deb9u4] (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386]) [libreoffice-writer:i386 ]
Inst libreoffice-style-galaxy [1:5.2.7-1+deb9u4] (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [all]) [libreoffice-writer:i386 ]
Inst libreoffice-style-tango [1:5.2.7-1+deb9u4] (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [all]) [libreoffice-writer:i386 ]
Inst libreoffice-help-fr [1:5.2.7-1+deb9u4] (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [all]) [libreoffice-writer:i386 ]
Inst libreoffice-l10n-fr [1:5.2.7-1+deb9u4] (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [all]) [libreoffice-writer:i386 ]
Inst libreoffice-java-common [1:5.2.7-1+deb9u4] (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [all]) [libreoffice-writer:i386 ]
Inst libreoffice-common [1:5.2.7-1+deb9u4] (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [all]) [libreoffice-writer:i386 ]
Inst libreoffice-avmedia-backend-gstreamer [1:5.2.7-1+deb9u4] (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386]) [libreoffice-writer:i386 ]
Inst libreoffice-writer [1:5.2.7-1+deb9u4] (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386]) []
Inst libreoffice-core [1:5.2.7-1+deb9u4] (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386])
Inst fonts-opensymbol [2:102.7+LibO5.2.7-1+deb9u4] (2:102.7+LibO5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [all])
Inst libc-l10n [2.24-11+deb9u3] (2.24-11+deb9u4 Debian:9.8/stable [all])
Inst locales [2.24-11+deb9u3] (2.24-11+deb9u4 Debian:9.8/stable [all])
Inst python-ldb [2:1.1.27-1+b1] (2:1.1.27-1+deb9u1 Debian-Security:9/stable [i386]) []
Inst libldb1 [2:1.1.27-1+b1] (2:1.1.27-1+deb9u1 Debian-Security:9/stable [i386])
Inst python-samba [2:4.5.12+dfsg-2+deb9u4] (2:4.5.16+dfsg-1 Debian:9.8/stable [i386]) []
Inst libwbclient0 [2:4.5.12+dfsg-2+deb9u4] (2:4.5.16+dfsg-1 Debian:9.8/stable [i386]) [samba-libs:i386 smbclient:i386 ]
Inst smbclient [2:4.5.12+dfsg-2+deb9u4] (2:4.5.16+dfsg-1 Debian:9.8/stable [i386]) [samba-libs:i386 ]
Inst samba-common-bin [2:4.5.12+dfsg-2+deb9u4] (2:4.5.16+dfsg-1 Debian:9.8/stable [i386]) [samba-libs:i386 ]
Inst libsmbclient [2:4.5.12+dfsg-2+deb9u4] (2:4.5.16+dfsg-1 Debian:9.8/stable [i386]) [samba-libs:i386 ]
Inst samba-libs [2:4.5.12+dfsg-2+deb9u4] (2:4.5.16+dfsg-1 Debian:9.8/stable [i386]) []
Inst samba-common [2:4.5.12+dfsg-2+deb9u4] (2:4.5.16+dfsg-1 Debian:9.8/stable [all])
Inst multiarch-support [2.24-11+deb9u3] (2.24-11+deb9u4 Debian:9.8/stable [i386])
Conf multiarch-support (2.24-11+deb9u4 Debian:9.8/stable [i386])
Inst tzdata [2018g-0+deb9u1] (2018i-0+deb9u1 Debian:9.8/stable [all])
Inst dirmngr [2.1.18-8~deb9u3] (2.1.18-8~deb9u4 Debian:9.8/stable [i386])
Inst gnupg [2.1.18-8~deb9u3] (2.1.18-8~deb9u4 Debian:9.8/stable [i386]) []
Inst gnupg-agent [2.1.18-8~deb9u3] (2.1.18-8~deb9u4 Debian:9.8/stable [i386])
Inst libssl1.0.2 [1.0.2q-1~deb9u1] (1.0.2r-1~deb9u1 Debian-Security:9/stable [i386])
Inst libxapian30 [1.4.3-2+deb9u2] (1.4.3-2+deb9u3 Debian:9.8/stable [i386])
Inst openssh-client [1:7.4p1-10+deb9u4] (1:7.4p1-10+deb9u6 Debian-Security:9/stable [i386])
Inst thunderbird-l10n-fr [1:60.4.0-1~deb9u1] (1:60.5.1-1~deb9u1 Debian-Security:9/stable [all]) []
Inst lightning [1:60.4.0-1~deb9u1] (1:60.5.1-1~deb9u1 Debian-Security:9/stable [all]) []
Inst thunderbird [1:60.4.0-1~deb9u1] (1:60.5.1-1~deb9u1 Debian-Security:9/stable [i386])
Inst calendar-google-provider [1:60.4.0-1~deb9u1] (1:60.5.1-1~deb9u1 Debian-Security:9/stable [all])
Inst chromium [71.0.3578.80-1~deb9u1] (72.0.3626.122-1~deb9u1 Debian-Security:9/stable [i386])
Inst curl [7.52.1-5+deb9u8] (7.52.1-5+deb9u9 Debian:9.8/stable, Debian-Security:9/stable [i386]) []
Inst libcurl3 [7.52.1-5+deb9u8] (7.52.1-5+deb9u9 Debian:9.8/stable, Debian-Security:9/stable [i386])
Inst firefox-esr-l10n-fr [60.4.0esr-1~deb9u1] (60.5.1esr-1~deb9u1 Debian-Security:9/stable [all]) []
Inst firefox-esr [60.4.0esr-1~deb9u1] (60.5.1esr-1~deb9u1 Debian-Security:9/stable [i386])
Inst gnupg2 [2.1.18-8~deb9u3] (2.1.18-8~deb9u4 Debian:9.8/stable [all])
Inst libgd3 [2.2.4-2+deb9u3] (2.2.4-2+deb9u4 Debian:9.8/stable, Debian-Security:9/stable [i386])
Inst libqt5core5a [5.7.1+dfsg-3+b1] (5.7.1+dfsg-3+deb9u1 Debian-Security:9/stable [i386])
Inst libqt5dbus5 [5.7.1+dfsg-3+b1] (5.7.1+dfsg-3+deb9u1 Debian-Security:9/stable [i386])
Inst libqt5network5 [5.7.1+dfsg-3+b1] (5.7.1+dfsg-3+deb9u1 Debian-Security:9/stable [i386])
Inst libqt5gui5 [5.7.1+dfsg-3+b1] (5.7.1+dfsg-3+deb9u1 Debian-Security:9/stable [i386])
Inst libqt5widgets5 [5.7.1+dfsg-3+b1] (5.7.1+dfsg-3+deb9u1 Debian-Security:9/stable [i386])
Inst libqt5printsupport5 [5.7.1+dfsg-3+b1] (5.7.1+dfsg-3+deb9u1 Debian-Security:9/stable [i386])
Inst libssh-4 [0.7.3-2+deb9u1] (0.7.3-2+deb9u2 Debian:9.8/stable [i386])
Inst libwayland-client0 [1.12.0-1] (1.12.0-1+deb9u1 Debian:9.8/stable [i386])
Inst libwayland-cursor0 [1.12.0-1] (1.12.0-1+deb9u1 Debian:9.8/stable [i386])
Inst libwayland-server0 [1.12.0-1] (1.12.0-1+deb9u1 Debian:9.8/stable [i386])
Inst linux-compiler-gcc-6-x86 [4.9.130-2] (4.9.144-3 Debian:9.8/stable [i386])
Inst linux-headers-4.9.0-8-686 [4.9.130-2] (4.9.144-3 Debian:9.8/stable [i386]) []
Inst linux-headers-4.9.0-8-common [4.9.130-2] (4.9.144-3 Debian:9.8/stable [all])
Inst linux-kbuild-4.9 [4.9.130-2] (4.9.144-3 Debian:9.8/stable [i386])
Inst linux-image-4.9.0-8-686 [4.9.130-2] (4.9.144-3 Debian:9.8/stable [i386])
Inst rtkit [0.11-4+b1] (0.11-4+deb9u1 Debian:9.8/stable [i386])
Inst sparky-aptus-extra [0.2.8] (0.2.14 SparkyLinux:core [all])
Inst sparky-codecs [0.2.3] (0.2.4 SparkyLinux:core [all])
Inst sparky-desktop-data [5~20181214] (5~20190206 SparkyLinux:core [all])
Inst sparky-desktop [20181214] (20190227 SparkyLinux:core [all])
Inst sparky-office [0.2.4] (0.2.7 SparkyLinux:core [all])
Inst sparky-webbrowser-installer [20181206] (20190213 SparkyLinux:core [all])
Inst sparky-aptus [0.4.12] (0.4.16 SparkyLinux:core [all])
Inst sparky-usb-formatter [0.1.11] (0.1.12 SparkyLinux:core [all])
Inst intel-microcode [3.20180807a.1~deb9u1] (3.20180807a.2~deb9u1 Debian:9.8/stable [i386])
Inst timeshift [18.9.1] (19.01 SparkyLinux:core [i386])
Conf libc6-dev (2.24-11+deb9u4 Debian:9.8/stable [i386])
Conf libc-dev-bin (2.24-11+deb9u4 Debian:9.8/stable [i386])
Conf linux-libc-dev (4.9.144-3 Debian:9.8/stable [i386])
Conf libapt-inst2.0 (1.4.9 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf apt-utils (1.4.9 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf libcurl3-gnutls (7.52.1-5+deb9u9 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf apt-transport-https (1.4.9 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf sparky-core (4.20190128 SparkyLinux:stable [all])
Conf sparky-apt (20190127 SparkyLinux:core [all])
Conf sparky4-apt (20190127.3 SparkyLinux:core [all])
Conf systemd-sysv (232-25+deb9u9 Debian-Security:9/stable [i386])
Conf libpam-systemd (232-25+deb9u9 Debian-Security:9/stable [i386])
Conf systemd (232-25+deb9u9 Debian-Security:9/stable [i386])
Conf udev (232-25+deb9u9 Debian-Security:9/stable [i386])
Conf libcupsmime1 (2.2.1-8+deb9u3 Debian:9.8/stable [i386])
Conf cups-core-drivers (2.2.1-8+deb9u3 Debian:9.8/stable [i386])
Conf cups-server-common (2.2.1-8+deb9u3 Debian:9.8/stable [all])
Conf libcupsimage2 (2.2.1-8+deb9u3 Debian:9.8/stable [i386])
Conf cups-common (2.2.1-8+deb9u3 Debian:9.8/stable [all])
Conf cups-client (2.2.1-8+deb9u3 Debian:9.8/stable [i386])
Conf libcupscgi1 (2.2.1-8+deb9u3 Debian:9.8/stable [i386])
Conf libcupsppdc1 (2.2.1-8+deb9u3 Debian:9.8/stable [i386])
Conf ghostscript (9.26a~dfsg-0+deb9u1 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf libgs9 (9.26a~dfsg-0+deb9u1 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf libgs9-common (9.26a~dfsg-0+deb9u1 Debian:9.8/stable, Debian-Security:9/stable [all])
Conf cups-ppdc (2.2.1-8+deb9u3 Debian:9.8/stable [i386])
Conf cups-daemon (2.2.1-8+deb9u3 Debian:9.8/stable [i386])
Conf libcups2 (2.2.1-8+deb9u3 Debian:9.8/stable [i386])
Conf cups (2.2.1-8+deb9u3 Debian:9.8/stable [i386])
Conf uno-libs3 (5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf ure (5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf libreoffice-base-drivers (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf libreoffice-base (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf libreoffice-calc (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf libreoffice-impress (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf libreoffice-draw (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf libreoffice-gtk3 (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf python3-uno (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf libreoffice-base-core (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf libreoffice-report-builder-bin (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf libreoffice (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf libreoffice-math (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf libreoffice-style-galaxy (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [all])
Conf libreoffice-style-tango (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [all])
Conf libreoffice-help-fr (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [all])
Conf libreoffice-l10n-fr (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [all])
Conf libreoffice-java-common (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [all])
Conf libreoffice-common (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [all])
Conf libreoffice-avmedia-backend-gstreamer (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf libreoffice-writer (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf libreoffice-core (1:5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf fonts-opensymbol (2:102.7+LibO5.2.7-1+deb9u5 Debian:9.8/stable, Debian-Security:9/stable [all])
Conf libc-l10n (2.24-11+deb9u4 Debian:9.8/stable [all])
Conf locales (2.24-11+deb9u4 Debian:9.8/stable [all])
Conf python-ldb (2:1.1.27-1+deb9u1 Debian-Security:9/stable [i386])
Conf libldb1 (2:1.1.27-1+deb9u1 Debian-Security:9/stable [i386])
Conf python-samba (2:4.5.16+dfsg-1 Debian:9.8/stable [i386])
Conf libwbclient0 (2:4.5.16+dfsg-1 Debian:9.8/stable [i386])
Conf smbclient (2:4.5.16+dfsg-1 Debian:9.8/stable [i386])
Conf samba-common-bin (2:4.5.16+dfsg-1 Debian:9.8/stable [i386])
Conf libsmbclient (2:4.5.16+dfsg-1 Debian:9.8/stable [i386])
Conf samba-libs (2:4.5.16+dfsg-1 Debian:9.8/stable [i386])
Conf samba-common (2:4.5.16+dfsg-1 Debian:9.8/stable [all])
Conf tzdata (2018i-0+deb9u1 Debian:9.8/stable [all])
Conf dirmngr (2.1.18-8~deb9u4 Debian:9.8/stable [i386])
Conf gnupg (2.1.18-8~deb9u4 Debian:9.8/stable [i386])
Conf gnupg-agent (2.1.18-8~deb9u4 Debian:9.8/stable [i386])
Conf libssl1.0.2 (1.0.2r-1~deb9u1 Debian-Security:9/stable [i386])
Conf libxapian30 (1.4.3-2+deb9u3 Debian:9.8/stable [i386])
Conf openssh-client (1:7.4p1-10+deb9u6 Debian-Security:9/stable [i386])
Conf thunderbird-l10n-fr (1:60.5.1-1~deb9u1 Debian-Security:9/stable [all])
Conf lightning (1:60.5.1-1~deb9u1 Debian-Security:9/stable [all])
Conf thunderbird (1:60.5.1-1~deb9u1 Debian-Security:9/stable [i386])
Conf calendar-google-provider (1:60.5.1-1~deb9u1 Debian-Security:9/stable [all])
Conf chromium (72.0.3626.122-1~deb9u1 Debian-Security:9/stable [i386])
Conf curl (7.52.1-5+deb9u9 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf libcurl3 (7.52.1-5+deb9u9 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf firefox-esr-l10n-fr (60.5.1esr-1~deb9u1 Debian-Security:9/stable [all])
Conf firefox-esr (60.5.1esr-1~deb9u1 Debian-Security:9/stable [i386])
Conf gnupg2 (2.1.18-8~deb9u4 Debian:9.8/stable [all])
Conf libgd3 (2.2.4-2+deb9u4 Debian:9.8/stable, Debian-Security:9/stable [i386])
Conf libqt5core5a (5.7.1+dfsg-3+deb9u1 Debian-Security:9/stable [i386])
Conf libqt5dbus5 (5.7.1+dfsg-3+deb9u1 Debian-Security:9/stable [i386])
Conf libqt5network5 (5.7.1+dfsg-3+deb9u1 Debian-Security:9/stable [i386])
Conf libqt5gui5 (5.7.1+dfsg-3+deb9u1 Debian-Security:9/stable [i386])
Conf libqt5widgets5 (5.7.1+dfsg-3+deb9u1 Debian-Security:9/stable [i386])
Conf libqt5printsupport5 (5.7.1+dfsg-3+deb9u1 Debian-Security:9/stable [i386])
Conf libssh-4 (0.7.3-2+deb9u2 Debian:9.8/stable [i386])
Conf libwayland-client0 (1.12.0-1+deb9u1 Debian:9.8/stable [i386])
Conf libwayland-cursor0 (1.12.0-1+deb9u1 Debian:9.8/stable [i386])
Conf libwayland-server0 (1.12.0-1+deb9u1 Debian:9.8/stable [i386])
Conf linux-compiler-gcc-6-x86 (4.9.144-3 Debian:9.8/stable [i386])
Conf linux-headers-4.9.0-8-686 (4.9.144-3 Debian:9.8/stable [i386])
Conf linux-headers-4.9.0-8-common (4.9.144-3 Debian:9.8/stable [all])
Conf linux-kbuild-4.9 (4.9.144-3 Debian:9.8/stable [i386])
Conf linux-image-4.9.0-8-686 (4.9.144-3 Debian:9.8/stable [i386])
Conf rtkit (0.11-4+deb9u1 Debian:9.8/stable [i386])
Conf sparky-aptus-extra (0.2.14 SparkyLinux:core [all])
Conf sparky-codecs (0.2.4 SparkyLinux:core [all])
Conf sparky-desktop-data (5~20190206 SparkyLinux:core [all])
Conf sparky-desktop (20190227 SparkyLinux:core [all])
Conf sparky-office (0.2.7 SparkyLinux:core [all])
Conf sparky-webbrowser-installer (20190213 SparkyLinux:core [all])
Conf sparky-aptus (0.4.16 SparkyLinux:core [all])
Conf sparky-usb-formatter (0.1.12 SparkyLinux:core [all])
Conf intel-microcode (3.20180807a.2~deb9u1 Debian:9.8/stable [i386])
Conf timeshift (19.01 SparkyLinux:core [i386])


Offline paxmark1

  • Hero Member
  • *****
  • Posts: 514
Re: Is system up to date ?
« Reply #4 on: March 12, 2019, 03:54:34 am »
inxi is a nice program to install.  Your call.  I can see that you are a conservative in your Debian habits. 

Since you are 4.9 - stable - a lot of those programs are security upgrades.  I would recommend the usage of "sudo apt update"  followed by "sudo apt-upgrade" 

 I have no idea what caused it, I update and upgrade from the command line myself. 

And just on a very off chance that your Debian mirror is down   No - you are missing Sparky items also.  but useful when downloads seem to stop for Debian

https://mirror-master.debian.org/status/mirror-status.html

There might be a another several day pause for some in Sparky t after March 12 (hard freeze starts), but not for you, you are in stable if you are 4.9
Don't make a FrankenDebian