Advertising

Author Topic: obmenu-generator Installation Issue  (Read 2096 times)

Offline saleem

  • Newbie
  • *
  • Posts: 7
obmenu-generator Installation Issue
« on: February 03, 2019, 07:37:14 am »
Hello,

I am trying to install obmenu-generator on Sparky Rolling release but get a missing package error

sudo apt update && sudo apt install obmenu-generator wm-logout  yad

Reading package lists... Done
Building dependency tree       
Reading state information... Done
13 packages can be upgraded. Run 'apt list --upgradable' to see them.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 yad : Depends: libwebkitgtk-3.0-0 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I checked and libwebkitgtk-3.0-0 is not available on testing ( buster ) repositories.

How to fix this issue?


Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2037
    • SparkyLinux
Re: obmenu-generator Installation Issue
« Reply #1 on: February 03, 2019, 11:08:17 am »
Can't be, it is at sparky testing repos:
Code: [Select]
apt-cache policy libwebkitgtk-3.0-0
libwebkitgtk-3.0-0:
  Zainstalowana: 2.4.11-4
  Kandydująca:   2.4.11-4
  Tabela wersji:
 *** 2.4.11-4 1001
       1001 https://sparkylinux.org/repo testing/main amd64 Packages
        100 /var/lib/dpkg/status
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net

Offline saleem

  • Newbie
  • *
  • Posts: 7
Re: obmenu-generator Installation Issue
« Reply #2 on: February 03, 2019, 12:19:40 pm »
Can't be, it is at sparky testing repos:
Code: [Select]
apt-cache policy libwebkitgtk-3.0-0
libwebkitgtk-3.0-0:
  Zainstalowana: 2.4.11-4
  Kandydująca:   2.4.11-4
  Tabela wersji:
 *** 2.4.11-4 1001
       1001 https://sparkylinux.org/repo testing/main amd64 Packages
        100 /var/lib/dpkg/status

I have following repositories enabled on Sparky Rolling release version

deb https://sparkylinux.org/repo/ testing main 
deb https://sparkylinux.org/repo/ core main 

deb https://sparkylinux.org/repo/ unstable main

Please confirm if these are the correct repositories?

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2037
    • SparkyLinux
Re: obmenu-generator Installation Issue
« Reply #3 on: February 03, 2019, 02:09:53 pm »
My version of Yad reqired libwebkit-3.0-0 which is deprecated, so removed Yad from Sparky repos now.
Refresh package list and try again.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net