Advertising

Author Topic: Updating into Black Screen --  (Read 149 times)

Offline jacobis

  • Newbie
  • *
  • Posts: 3
Updating into Black Screen --
« on: December 07, 2018, 05:32:12 am »
Hello people,

I'm fairly new to linux in general, and I've been distro hopping for awhile trying to find my favorite. I've landed at sparky. I still have a couple features that i'll have to live with not getting on linux (multiple monitor setups and using gsync on one screen without turning the others off), but this next problem I havent been able to make sense of. I've installed it and switched to KDE on my two kids' computers without an issue. Sparky gameover edition x64 5.5 rolling. They both have fairly mediocre toasters, but on my PC, when i update from 4.18-01 to 4.18-03 kernel after install, it just hangs on black screen. Oddly enough, it doesnt do that on the community spin cinnamon 64 bit version.

I like the sparky gameover, cause it took me like a whole night to figure out how to install steam on a debian 64bit computer. Don't judge me, but installing 32bit libraries for a windows pleb on debian isn't small potatoes. lol. Anywho, the problem is, right after i run the update, when i select it in grub, it just hangs on black screen. I flashed the firmware on my 1080ti to the latest version in windows, and still nothing. I can still use advanced options, and boot back to 4.18.01 just fine. I think it has something to do with updating to the x-org nvidia drivers. I fixed it once before like 2 formats ago, but i was just randomly pumping terminal with a bunch of things and cant remember what I Did. Then i got it all perfect... and at 4am i changed my password and forgot what it was when i woke up. SelfRekt.

Ideally I want sparky linux with steam ready to install and nvidia drivers. I'm trying to make my own iso to have everything, cause the games in the gameover edition aren't my flavor. Thank you for reading this, if you've made it this far. I'm in love with linux and sparky is nearly perfect. Openbox and the menu I just cant get myself to like. Is there anyway to modify the DE pre-install? or load my drivers and libraries/drivers in advance? I'd give someone dirty favors if a driver manager ala linux mint was on sparky. dirty dirty favors.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1927
    • SparkyLinux
Re: Updating into Black Screen --
« Reply #1 on: December 07, 2018, 03:46:00 pm »
There are two possible problems:
1. Update went wrong, so run the system in a safe mode and try to fix broken packages if any:
Code: [Select]
dpkg --configure -a
apt install -f
2. The newer version of Linux kernel provided some changes so run the system using the older kernel.
Nothing is easy as it looks.
Danielle Steel

Offline jacobis

  • Newbie
  • *
  • Posts: 3
Re: Updating into Black Screen --
« Reply #2 on: December 14, 2018, 07:27:54 am »
thank you for your help. so same thing happened again after a reinstall. here's a warning i'm getting in terminal.

dpkg: warning: 'ldconfig' not found in PATH or not executable
dpkg: warning: 'start-stop-daemon' not found in PATH or not executable
dpkg: error: 2 expected programs not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin

although i feel like this issue is tied to two things. I've reinstalled like 15 times trying to figure this out. A sudo apt-get install nvidia-driver. it gives me some weirdness at the end about a nouvaeu driver and then says something about modifying "RESUME." I'm a noob. After i install the driver and restart, SDDM just goes to black screen and it hangs. I tried ctrl + alt + f1/f5/f7 cause somewhere i read that it helps. On some installs that takes me back to like a console like thing, and i can type startx and sometimes that works. But only on 4.18.01 not 4.18.03. how do i keep it from going to 4.18.03? and can I revert fully back to that?
« Last Edit: December 14, 2018, 07:31:35 am by jacobis »

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 462
Re: Updating into Black Screen --
« Reply #3 on: December 14, 2018, 08:07:05 pm »
You have a lot of text.  And I do not follow nvidia

0.1  the error
Code: [Select]
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
Did yo do this as root or sudo?  IF you are using Sparky4 you will not be affected by the following. 
The old tried and true "su root" or just "su" in a terminal  will often fail now.  It is a new thing related to /bin /sbin and some merging things.  I have yet to find the a laymans explanation for it.  Short answer  which is for when working in a terminal.

Never do "su root" any more.  Never do "su"  to get to root anymore.  Do "su - root"        ##  I reserve nimbler minds and nimbler tongues to explain. 

1.  You did not post the specific binary that dpkg was trying to configure

Code: [Select]
  Missing code here that would have shown the binary
dpkg: warning: 'ldconfig' not found in PATH or not executable
dpkg: warning: 'start-stop-daemon' not found in PATH or not executable
dpkg: error: 2 expected programs not found in PATH or not executable

2.  output of "inxi -MGC"  in code style (the #  button above) would be helpful.  example

Code: [Select]
root@raunes:~# inxi -MGC
Machine:   Device: desktop System: Gigabyte product: H81M-S2H GSM
           Mobo: Gigabyte model: H81M-S2H GSM v: x.x UEFI: American Megatrends v: F2 date: 08/11/2015
Battery    hidpp__0: charge: N/A condition: NA/NA Wh
CPU:       Dual core Intel Core i3-4170 (-HT-MCP-) cache: 3072 KB
           clock speeds: max: 3700 MHz 1: 997 MHz 2: 997 MHz 3: 997 MHz 4: 997 MHz
Graphics:  Card: Intel 4th Generation Core Processor Family Integrated Graphics Controller
           Display Server: X.org 1.19.2 driver: intel tty size: 271x67 Advanced Data: N/A for root

I searched, so is the 1080ti a $700 ish graphics card from Nvidia? If you do have a shiny new specialized Nvidia - that fills in the "do I need nouveau or bleeding edge binarie?" You need the bleeding edge stuff, not sure if bleeding edge Debian or bleeding edge Nvidia. Have you tried looking in the NVIDIA linux subsection of their forum.    If cards like that are used in bitmining - that is another place to search.

 You could try the Debian kernels if you are using the Sparky ones or try the  Liquorix kernels.  But I would recommend first finding someone who already has a few arrows in them from the bleeding edge of NVIDIA graphics, and try the kernel that worked for them.  Hopefully a Debian and not Centos or Gentoo or Arch, because over 90% of what you have is Debian.   
 
BUT - if you were doing this in a terminal where you became root via "su" or "su root"  try as "su - root" or using sudo.  Hopefully you will get lucky that way.

 I do remember years ago having to to Nvidia blobs for a low end but very new "card" in my Asus netbook with a AMDC-50 processor. I was so happy when I got to go nouveau.   
Don't make a FrankenDebian

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 462
Re: Updating into Black Screen --
« Reply #4 on: December 14, 2018, 08:45:08 pm »
More  This only affects you if you are using Sparky 5.

https://packages.debian.org/buster/nvidia-driver          Lets you see the state of testing nvidia package.

https://metadata.ftp-master.debian.org/changelogs//non-free/n/nvidia-graphics-drivers/nvidia-graphics-drivers_390.87-4_changelog
Code: [Select]
* Drop libnvidia-egl-wayland1, nvidia-egl-wayland-{common,icd} packages.
    These will be provided by src:egl-wayland.  (Closes: #915824)
   
##  Note this should not affect you for a few days.  It might in a few days, see the relevant recent  post in Siduction Forum.  NOTE: You do NOT want to go to Sid.  As you posted - you are new.   

A quick look by me at Debian Forum and the Nvidia forum yields no real information for me.  But there is a lot there on the Nvidia forum, much of it just for Windows.

https://forums.geforce.com/default/board/172/geforce-1000-series/1/

adding 1080ti means much fewer results - actually none on the Debian forum.  Using "1080" as a search items adds all the 1920*1080 dpi results.

Looking at the big picture, if the 1080ti is as very very new as it sounds, you might need the NVIDIA drivers.  You talk about it possibly being 2 separate issues.  You have the new kernels that are in flux, you have the dkms portion of the kernels for more Nvidia specific  things.  The only thing I am sure of is that by next March 2019 the 1080ti will be pretty well supported in Debian and by default also Sparky. 

Since you say you are new, if you do get this thing up and running, I would recommend staying at Sparky 5 when the Buster-5 goes stable. That would be April-May 2019 or so.  The ride gets more bumpy when the freeze ends and Sparky goes to 6. 


edit one more   Debian Bug tracking System
https://bugs.debian.org/cgi-bin/pkgreport.cgi?dist=unstable;package=nvidia-driver
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=903541       ##SDDM black screen.  KDE  Different card. 
« Last Edit: December 14, 2018, 08:54:02 pm by paxmark1 »
Don't make a FrankenDebian

Offline jacobis

  • Newbie
  • *
  • Posts: 3
Re: Updating into Black Screen --
« Reply #5 on: December 15, 2018, 06:30:17 am »
ok, i'm trying to process all the information you guys just said. I feel like a noob trying to understand greek, but the 1080ti was the flagship card that came out about 18 months ago. the next 2080 series is already out. It is a 750$ graphics card. So i did do a lot of updates using su- then apt upgrade apt update apt full-upgrade. I'm going to try these debuggers and i didn't know i'm not supposed to use SID. NVIDIA does have decent drivers through the canonical PPA. I am not an ubuntu fan though, debian gives me a chub. Thank you guys for your detailed information, i'll give you relevant feedback other than my rambling response.

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 462
Re: Updating into Black Screen --
« Reply #6 on: December 15, 2018, 08:19:52 pm »
My sig is "Don't make a FrankenDebian".    One of the quickest ways to totally destroy a Debian or Sparky system is to start adding Ubuntu ppa's, imho.   There are numerous ppa's in Sparky, but they have been investigated by people smarter than I. 

https://wiki.debian.org/DontBreakDebian

If you are going to use newer linux binaries - I would suggest getting it via the Nvidia site. 

However Package: nvidia-driver (390.87-3) [non-free]   (which is found via the www.blah-debian/buster/nividia-driver site I poste) is pretty new.  It entered Nov 12th 2018.  Hopefully people who use new Nvidia cards in sparky5 will reply with their experience. 

But please.
1.   How were your upgrades made.  Aptus?  Synaptic? or in the command line in a terminal?
If command line - were you using sudo or utilizing "su" to get a root terminal.  The
Code: [Select]
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
which I believe is from your error messages leads me to ask that question.  There have been some changes occurring in Unstable and Testing which break the usage of using just su to become root, especially for upgrades and dist-upgrades.  Please use sudo if you are doing it via the command line. 

2.  The bug #903451 over sddm might be another possibility.  Yes, KDE would shine very well on your system, however it has more bugs in Testing due to it's highly integrated design and rapid development.  sddm is my choice DM often, but attempting to install xfce or mate which have lightdm as DM might be easier.  Once you know that you can get your card up (and write down how you did it) you should then be able to re-install with KDE. 

Hopefully others with  nvidia experience will post better and shorter.

Don't make a FrankenDebian