Advertising

Author Topic: Change close notebook lid behavior?  (Read 331 times)

Offline dbear355

  • Newbie
  • *
  • Posts: 5
Change close notebook lid behavior?
« on: October 02, 2018, 09:27:27 pm »
I got 32-bit Sparky 4 installed and updated on my HP Mini. Definitely more responsive than Micro$oft Windoze.  :)

Problem: Closed the notebook lid.
Have re-opened the lid. I assume it went into a sleep mode? I hear the fan, I see various hardware lights are active (power, WiFi), but the screen is completely black. No mouse pointer either.
Power off/on does not help.
Finally unplugged and pulled the battery. Was able to get back to the BIOS and restart.


I assume I'm not the first with this problem, but still enough of a newb I'm not even sure of what terms to search for.

But for starters, how and where can I change the close lid behavior?

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 457
Re: Change close notebook lid behavior?
« Reply #1 on: October 03, 2018, 02:00:27 am »
It is possibly due to the specific computer you have.  It could also be influenced by the DE (Desktop environment) that you have installed.  Others with the same DE or computer in all sorts of distributions (Ubuntu, Centos, Debian, etc. etc. etc.) are probably effected by this.  The solution might be easily fixed with a web search. 

Need more information, please.  Your destop environment and specific model.

Ctl-Alt-F1 might work when frozen. Check for other ways to kill - on some lappies there is a small hole in the back you can insert a pin into.  I would pull power and let drain out before I unhooked battery from computer that is still running, that is just my style. 
Don't make a FrankenDebian

Offline dbear355

  • Newbie
  • *
  • Posts: 5
Re: Change close notebook lid behavior?
« Reply #2 on: October 03, 2018, 06:38:03 pm »
The unit is an HP Mini 210-2145DX. 2GB memory, ~250GB hard drive.

Running Sparky 4.9.0 with whatever desktop came with the sparkylinux-4.8.1-i686-lxde ISO. And subsequent automatic updates.

Offline dbear355

  • Newbie
  • *
  • Posts: 5
Re: Change close notebook lid behavior?
« Reply #3 on: October 03, 2018, 07:05:08 pm »
Oh! My!
paxmark1, thanks for the mention elsewhere about inxi !!

Code: [Select]
System:    Host: HPmini Kernel: 4.9.0-8-686 i686 (32 bit) Desktop: LXDE (Openbox 3.6.1)
           Distro: SparkyLinux 4 (tyche)
Machine:   Device: laptop System: Hewlett-Packard product: HP Mini 210-2100 v: 058C110002203B00000300100
           Mobo: Hewlett-Packard model: 1584 v: 85.2B BIOS: Hewlett-Packard v: F.14 date: 11/30/2010
Battery    BAT0: charge: 51.0 Wh 100.0% condition: 51.0/51.0 Wh (100%)
CPU:       Single core Intel Atom N455 (-HT-) speed/max: 1000/1666 MHz
Graphics:  Card: Intel Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
           Display Server: X.Org 1.19.2 drivers: intel (unloaded: modesetting,fbdev,vesa)
           Resolution: 1024x600@60.02hz
           GLX Renderer: Mesa DRI Intel Pineview M x86/MMX/SSE2 GLX Version: 2.1 Mesa 13.0.6
Network:   Card-1: Broadcom Limited BCM4313 802.11bgn Wireless Network Adapter driver: bcma-pci-bridge
           Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller driver: r8169
Drives:    HDD Total Size: 250.1GB (3.5% used)
Info:      Processes: 136 Uptime: 17 min Memory: 264.0/2008.2MB Client: Shell (bash) inxi: 2.3.5

Any guidance on what to even begin searching for would be appreciated.  :)

But for starters, how and where can I see and hopefully change the close lid behavior?
« Last Edit: October 03, 2018, 07:26:14 pm by dbear355 »

Offline dbear355

  • Newbie
  • *
  • Posts: 5
Re: Change close notebook lid behavior?
« Reply #4 on: October 03, 2018, 09:01:00 pm »
Still no idea why suspend and hibernate go to permanent black screen. However:

I finally tracked down a discussion that pointed to /etc/systemd/logind.conf .
Changed and uncommented HandleSuspendKey, HandleHibernateKey and HandleLidSwitch all to ignore.
Then rebooted.

At least I can close and re-open the lid.  :D
Given that it can do a complete reboot in just over one minute, I'm relatively happy.
Now if I could just get it to come out of hibernation successfully....  ::)

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 457
Re: Change close notebook lid behavior?
« Reply #5 on: October 04, 2018, 07:27:18 pm »
How much memory do you have?
How big is your swap? 
Your DE is LXDE probably.

All my atoms are 1 gb. 

Their wiki is quite good, but will not give you the correct solution for all things Debian-Sparky, but top notch for everything being current for systemd. 
https://wiki.archlinux.org/index.php/Power_management/Suspend_and_hibernate

and of course
"man logind.conf" which will give you info on what you did for the quick fix. 

htop (or top) will all show you (in the topmost section)  how much memory and swap memory you have.  It might be that your system is trying to hibernate to a larger size of memory than you have presently available.  Hibernation and suspend are not my strongest suit.  Others might help or search for what size swap you would need. 

If you have an sdhc slot and an old sdhc card that is not super slow and you do not care if you wear out - you can put  a larger swap and other things on it.  I ran my EEE901 on an sdhc for years, keyboard is shot now unfortunately.  I did not kill the sdhc. 

peace out
Don't make a FrankenDebian

Offline womp

  • Newbie
  • *
  • Posts: 2
Re: Change close notebook lid behavior?
« Reply #6 on: November 03, 2018, 12:38:00 am »
Hello! I have a Dell Latitude 6430, core i5, intel4000, 8gbram, 2hdds (one in optical bay).
I have installed Sparky Home 5.4 (Debian testing)
Everything works great in this fast and really fun distro! Except one thing, it will not wake up after close the lid. The computer turns off after about 10 secs and when I restart it goes to a black screen and I have to reboot again. This is starting to get annoying and I have read a lot about it. I tried first to set parameters in powermanager to suspend and then it did not turn off right away but it will not wake up (I get black screen). I severall differen combinations of  logind.conf but that made no difference at all no matter what I did. I have installed i3lock and made service but it made no difference. I have tried Mint19, Arch, Archlabs, Mx and with all of these suspend/wake up works out of the box. In fact I have never had this problem before so I do not know what more to do.
Anyone with experience of this who is willing to pass me a hint?

womp