Advertising

Author Topic: [SOLVED] GameOver Meta Installation (Mokomaze)  (Read 705 times)

Offline o hai mark

  • Newbie
  • *
  • Posts: 3
[SOLVED] GameOver Meta Installation (Mokomaze)
« on: September 26, 2018, 06:39:08 am »
Hello friends. I've installed SparkyLinux on my laptop and am trying to install the GameOver meta package but am running into a strange error that I can't seem to find any info on anywhere else.

Code: [Select]
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 sparky-meta-game : Depends: mokomaze but it is not installable
E: Unable to correct problems, you have held broken packages.

I tried installing Mokomaze, but...
Code: [Select]
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package mokomaze is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'mokomaze' has no installation candidate

So lastly I went to Mokomaze's website and downloaded the deb package and attempted to run that but got an error that I'm using a 64-bit Linux installation and that it's not available for 64-bit.

So I'm at a bit of a loss. Can I not install the GameOver meta package on a 64 bit linux install? Or is there something I'm missing or a workaround for this error? Any help is appreciated.
« Last Edit: September 29, 2018, 07:48:42 pm by o hai mark »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1952
    • SparkyLinux
Re: GameOver Meta Installation (Mokomaze)
« Reply #1 on: September 26, 2018, 09:41:32 pm »
Hi
It happens on Sparky rolling/Debian testing/Sid.
Packages are moved out and in and sometimes are not available.
It is the same problem with rescue and multimedia meta packages.
I will try to move missing packages to Sparky repos and update the meta as well.
Nothing is easy as it looks.
Danielle Steel

Offline o hai mark

  • Newbie
  • *
  • Posts: 3
Re: GameOver Meta Installation (Mokomaze)
« Reply #2 on: September 26, 2018, 11:11:34 pm »
Oh thank you very much Pavroo! I thought I had downloaded the stable iso instead o f the rolling. I may reinstall as I'm not sure I'm competent enough in Linux to be in the testing environment!

All in all I'm greatly enjoying SparkyLinux. Thank you again for your help!

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1952
    • SparkyLinux
Re: GameOver Meta Installation (Mokomaze)
« Reply #3 on: September 26, 2018, 11:31:38 pm »
All special meta packages updated, so refresh package list and try again.
Nothing is easy as it looks.
Danielle Steel

Offline o hai mark

  • Newbie
  • *
  • Posts: 3
Re: GameOver Meta Installation (Mokomaze)
« Reply #4 on: September 29, 2018, 07:47:31 pm »
All special meta packages updated, so refresh package list and try again.

Perfect! Everything installed smoothly. Thanks!

Offline polgornek

  • Newbie
  • *
  • Posts: 1
Re: [SOLVED] GameOver Meta Installation (Mokomaze)
« Reply #5 on: January 27, 2019, 09:18:38 pm »
Hi I do have the same issue...

Offline paxmark1

  • Hero Member
  • *****
  • Posts: 513
Re: [SOLVED] GameOver Meta Installation (Mokomaze)
« Reply #6 on: January 28, 2019, 01:22:30 am »
Not enough info.  Sparky 4 or 5      32 bit or 64 bit.

Please post output of where it went wrong as the original poster did. 

https://tracker.debian.org/pkg/mokomaze

seriously out of date   
mokomaze web site.

Mokomaze: files

fsoraw_0.01a+svn20-ant1_armv4t.ipk     09 January 2011
mokomaze_0.5.5+git8-r2_armel.deb     09 January 2011
fsoraw_0.01a+svn20_armel.tar.gz     09 January 2011
mokomaze_0.5.5+git8-r1_armv4t.ipk     09 January 2011
mokomaze-0.5.5+git8.tar.gz     09 January 2011
mokomaze_0.5.5+git8-r1_armel.deb     09 January 2011
« Last Edit: January 28, 2019, 01:25:15 am by paxmark1 »
Don't make a FrankenDebian