Advertising

Author Topic: Problems after recent update  (Read 322 times)

Offline toothandnail

  • Newbie
  • *
  • Posts: 13
Problems after recent update
« on: July 26, 2018, 11:23:06 am »
I've got a quite new Sparky rolling install on my laptop - Xfce installed from the minimal iso advanced install. Until earlier this week, it was working fine. Now, it starts and I can enter login details, after which it sits for quite a long period with no hard drive access and not doing much of anything. Eventually it will load the desktop, but it then displays a pop-up with an error saying that an authentication agent is already present. Unfortunately, there are no details with the error, so I don't know what it triggering it.

A friend of mine had a much older Sparky install which was working fine until yesterday. It was updated the day before, but was not rebooted. When he started the machine yesterday morning, it got to the lightdm login, but then went into a loop - enter username and password, hit login and it would just recycle back to the login prompt.

In that case, a clean install (again using the advanced installer from the minimal iso) did exactly the same thing. Brand new user was unable to login at all. Lightdmn was set for the correct Xfce session, but login was not possible. It was possible to login as root from the lightdm prompt, and it was possible to login as the new user from the console.

Once logged in as root, I was able to create a new user. Logging out as root, I was then able to login using the user account I had just created, though I then had to set things up so that that user was able to use sudo. For the moment, the problem on that machine is fixed, but I would like to know what the problem is, and I would like to be able to fix my own installation as well.

Has anybody else seen these sorts of problems in the last few days? Any idea of what I can do to diagnose and fix them?

Paul.

Offline sos12_3

  • Newbie
  • *
  • Posts: 1
Re: Problems after recent update
« Reply #1 on: July 26, 2018, 05:53:36 pm »
Hi Paul,

Same issue here, well, I have your friend's scenario.  I've tried some obvious stuff (permissions on .Xauthority and .ICEauthority and whacking .profile/.bashrc).  no dice.

Creating a brand new user works, as you report, (which screams 'permissions!' to me). But I see nothing out of the ordinary.

Xorg.0.log is clean as is lightdm.log

I'll keep poking at it.
-sos

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1903
    • SparkyLinux
Re: Problems after recent update
« Reply #2 on: July 27, 2018, 11:08:54 pm »
After upgrading all my sparky installations on vbox, all desktops start very, very slowly (3-5 min) after log in (on kernel 4.17).

Code: [Select]
but it then displays a pop-up with an error saying that an authentication agent is already present.Go to Xfce control/settings center-> startup apps and disable 'sparky-polkit' and 'lxpolkit' if they are active.
Xfce uses gnome agent so other ones can make such problems.
Nothing is easy as it looks.
Danielle Steel