Advertising

Author Topic: Network card problem -- possibly temperature-related  (Read 277 times)

Offline niftyprose

  • Newbie
  • *
  • Posts: 18
Network card problem -- possibly temperature-related
« on: July 09, 2018, 01:52:15 pm »
Hi guys, I'm a new Sparky user. I installed the OpenBox version on my Asus E200H a couple of months ago. The distro has worked pretty well, although with more crashes than CrunchBang, my previous main choice. However, in the last week, an annoying problem has appeared.

The computer loses its wifi Internet connection some minutes after startup. If I reboot, I get a good connection, then the same thing happens again.

Shutdown is either very slow or requires a hard reset to complete. The process seems to hang on two unfamiliar messages:

wlan0 failed to remove key from hardware AND
CPUn: Core temperature above threshold, cpu clock throttled

As a newbie I don't want to diagnose too confidently, but I'd say that the present very high temperatures in the UK are causing the kernel to shut down the network card. Is there some way to prevent this? Am I the only person with this problem? I'm writing this letter with an Ethernet cable plugged into the local hub -- not cool.

Best, NP.

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 408
Re: Network card problem -- possibly temperature-related
« Reply #1 on: July 10, 2018, 08:43:25 am »
More info please.  I do like inxi  Others elsewhere also.  If you choose to - install inxi

If you choose - post as "code" via the # forum button  the output of

inxi  -s          ##tells us the temp in C

inxi -n          ## tells us details as to your network cards   ## or use lspci to identify  your cards.

Also you can check your last log of systemd (via sudo or as root) by

journalctl -b -1         or use grep to look for Failed and ailed      journalctl -b -1 | grep ailed

man journalctl will tell you how to find the "tail" end of your journal for info on what

Also - are you on Sparky 4 or 5? - your DE is openbox.

Also if not too difficult, use canned air to remove any dust inside. 
Don't make a FrankenDebian

Offline niftyprose

  • Newbie
  • *
  • Posts: 18
Re: Network card problem -- possibly temperature-related
« Reply #2 on: July 10, 2018, 04:46:50 pm »
Hi, Paxmark, thank you for the careful reply. I'm sorry that I can't respond fully right now, but see below for some of the detail you requested.

BACKGROUND: I'm on an Asus E200H netbook. This is a rebadged X205 with a better network card and a few small improvements. Both the X205 and E200H are cheap laptops with smallish screens and tablet processors. Neither has a cooling fan. I used an X205 for years on #! with no problems other than the network card being slow and unpredictable.

OS: I'm using Sparky 4 with Openbox DE.

INXI: I installed and got the following:

niftyprose@niftybook:~$ inxi -s
Sensors:   System Temperatures: cpu: 46.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 0
niftyprose@niftybook:~$ inxi -n
Network:   Card: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
           driver: ath10k_pci
           IF: wlan0 state: up mac: 74:c6:3b:8c:1c:3b

JOURNALCTL: I tried following your instrs. but there is no persistent journal file despite reconfiguring -- apparently a systemd bug, but one which I can't presently work through because of another commitment. Would any other utilities provide the info you requested?

Best, NP.


Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 408
Re: Network card problem -- possibly temperature-related
« Reply #3 on: July 10, 2018, 06:48:20 pm »
In future please use the # button above to mark up text based machine output  example.

Code: [Select]
inxi -n
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: enp2s0 state: down mac: 40:8d:5c:72:9d:65
           Card-2: Realtek RTL8812AU 802.11a/b/g/n/ac WLAN Adapter
           IF: N/A state: N/A mac: N/A

At 46.0 C sustained for hours you are at strong risk of intermittent errors that are near impossible to debug or replicate and permanently damage mobo and components. 

Systemd  and Journalctl

If your machine presently does not store the journal for systemd - you can wade through the logs in /var/log   

Reading 'man journald.conf"   section Storage

Quote
Storage=
           Controls where to store journal data. One of "volatile", "persistent", "auto" and "none". If "volatile", journal log data will be stored only in memory, i.e. below the
           /run/log/journal hierarchy (which is created if needed). If "persistent", data will be stored preferably on disk, i.e. below the /var/log/journal hierarchy (which is created
           if needed), with a fallback to /run/log/journal (which is created if needed), during early boot and if the disk is not writable.  "auto" is similar to "persistent" but the
           directory /var/log/journal is not created if needed, so that its existence controls where log data goes.  "none" turns off all storage, all log data received will be
           dropped. Forwarding to other targets, such as the console, the kernel log buffer, or a syslog socket will still work however. Defaults to "auto".

Edit  one line in /etc/systemd/journald.conf

[Journal]
Storage=persistent           ## take out the  #   - i.e uncomment that line

and you will have a very efficient way to get at your logs. 

I believe but am not sure that distros are going more and more to setting setting jounrald.conf as persistent   It is a design decision at the distro level.
Don't make a FrankenDebian