Advertising

Author Topic: I Spark The Truth  (Read 128 times)

Offline vmclark

  • Newbie
  • *
  • Posts: 4
I Spark The Truth
« on: June 21, 2018, 01:52:38 am »
I was looking for a LXQT disto. Lubuntu works...barely. Then again, its in its infancy. But Sparky works!
One exception though...
I prefer Chrome, but for what ever reason, under Sparky I keep getting the "google chrome isn't your default browser" message. Of course I've check and recheck under "Default browser" and its has a clickable icon that says default. Whereas under all my other distros, once set its gone. 
I then uninstalled, then install Chromium. It works but all my passwords I have to re-create. I've checked several solutions, including reinstall. All to no avail.
Odd that its only Sparky that this happens. The only other thing it could be, is when deleting Firefox, Chrome somehow things its still default. I have removed Firefox countless times without this error. Tried to find something in "chrome://about/". I need to go through those settings, one by one, maybe something in there.

At any rate I have Chromium to use in the meantime. Great distro! One thing Sparky does that no one else does, is enable networking straight away once up. I turn my wired network off when not in use. And unless I boot up my router first and wait until fully booted the others all get confused until about 5 minutes. I have to
Code: [Select]
sudo service network-manager restart or
Code: [Select]
nmtui-connect to activate.

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 372
Re: I Spark The Truth
« Reply #1 on: June 21, 2018, 07:25:36 am »
xdg issues, I will let others speak.  But for the router here is some ideas but no solution.  It might be better to start a new post for the networking issue. 

Networking
Sparky 5 or 4 (Buster-testing or Stretch-stable)? 

What sort of a router and info? 

Have you done any looking at the systemd logs for network startup?   "sudo journalctl -b -1 | grep etwork" might be a start (etwork shows Network and network)  journalctl uses grep well.  (-b -1 shows all of last boot, -b -0 shows the current boot)
Also for boot up issues try "systemd-analyze blame"  , nice, can be run as user.  In tmux or screen maybe "systemd-analyze blame | less"
man journalct
man systemd-analyze

I have been a strong advocate on connman vs. network manager.  Just search "connman" on the forum, I do like it.  It has been a default for lxqt for several years.  It has been a smooth ride for me with in in sid-unstable when I had time for that and presently in testing in Sparky and Debian.  I am not advocating you switching to it at this point.  Simplest solution if you turn off both router and computer would be to always turn on router first, but not elegant and not useful if you turn off router but keep computer on.  connman is written in C and has has utilized QT5 from the beginning and is well documentated with a lot of love from Intel developers. QT5 and lxqt play very well together of course. But if you ever re-install or set up another LXQt system or virtual environment ...

If you love command line and only use ethernet, systemd-networkd might be an option also.  One person who writes tutorials over that is HOAS who was in Crunchbang and Bunser but is more often found in Debian forum.  I did play with over 2 years ago.  Too much work for me. 

I searched a little over nmtui.  Got a Redhat site with some info, might be old.  A quick glance and I think that connmanctl (an acquired taste) has more capability for various platforms. 

But yes, Sparky is the cat's meow" for getting a network up with a Debian testing base. 

peace out.
Don't make a FrankenDebian

Offline vmclark

  • Newbie
  • *
  • Posts: 4
Re: I Spark The Truth
« Reply #2 on: June 21, 2018, 07:44:55 am »
I wasn't very clear on the networking. If I boot my router first, then bootup any distro, then alls well. Otherwise I have to wait until the distro decides its up or I can kick-it using networking commands.

Sparky is the only distro outside of Windows that doesn't need any kicking, it recognizes when the network is up.

Thank you for your reply!