Advertising

Author Topic: System Upgrade does not complete...  (Read 601 times)

Offline tenfoot

  • Jr. Member
  • **
  • Posts: 73
System Upgrade does not complete...
« on: April 19, 2018, 10:16:55 am »
Using Sparky  Linux (Debian Testing) on Lenovo Thinkpad T450s.
Linux Kernel 4.15.0-2-amd64(x86_64)

For the last three days the System Upgrade does not complete.  The  Upgrade now window appears with the message:e "Need to get 0 8/2.900 kB of archives.  After this operation, 373 kB of additional disk space will be used."

Clicking on OK results in the normal downloading of files results s but then goes back to the Upgrade window.

I've also tried doing an update and upgrade through the terminal, with the same result.

Would appreciate some hint on what to do next, please?
Dogs laugh, but they laugh with their tails.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1892
    • SparkyLinux
Re: System Upgrade does not complete...
« Reply #1 on: April 19, 2018, 10:23:42 pm »
Must be a dependency problem with some packages.
Run:
Code: [Select]
sudo apt-get update
sudo apt-get dist-upgrade
and show an output of the commands, please.
Nothing is easy as it looks.
Danielle Steel

Offline tenfoot

  • Jr. Member
  • **
  • Posts: 73
Re: System Upgrade does not complete...
« Reply #2 on: April 21, 2018, 09:43:16 pm »
Must be a dependency problem with some packages.
Run:
Code: [Select]
sudo apt-get update
sudo apt-get dist-upgrade
and show an output of the commands, please.

Thank you for your prompt reply.

The information you requested is posted below.

Code: [Select]
zed@zed-pc:~$ sudo apt-get update
[sudo] password for zed:
Hit:1 http://ftp.debian.org/debian testing InRelease                           
Hit:2 http://security.debian.org testing/updates InRelease                     
Hit:3 https://sparkylinux.org/repo testing InRelease                       
Reading package lists... Done
                   
Code: [Select]
zed@zed-pc:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  base-passwd dh-strip-nondeterminism gir1.2-freedesktop gir1.2-glib-2.0
  gstreamer1.0-plugins-good gvfs gvfs-backends gvfs-bin gvfs-common
  gvfs-daemons gvfs-fuse gvfs-libs libdatetime-locale-perl
  libfile-stripnondeterminism-perl libgirepository-1.0-1
  libhttp-negotiate-perl libpython2.7 libpython2.7-minimal libpython2.7-stdlib
  libqpdf21 libwww-robotrules-perl libxml-sax-expat-perl nvidia-detect
  python-crypto python2.7 python2.7-minimal python3-pyqt5 qpdf
28 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 12.3 MB/15.2 MB of archives.
After this operation, 381 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ftp.debian.org/debian testing/main amd64 base-passwd amd64 3.5.45 [56.7 kB]
Get:2 http://ftp.debian.org/debian testing/main amd64 libpython2.7 amd64 2.7.15~rc1-1 [1,052 kB]
Get:3 http://ftp.debian.org/debian testing/main amd64 python2.7 amd64 2.7.15~rc1-1 [298 kB]
Get:4 http://ftp.debian.org/debian testing/main amd64 libpython2.7-stdlib amd64 2.7.15~rc1-1 [1,910 kB]
Get:5 http://ftp.debian.org/debian testing/main amd64 python2.7-minimal amd64 2.7.15~rc1-1 [1,351 kB]
Get:6 http://ftp.debian.org/debian testing/main amd64 libpython2.7-minimal amd64 2.7.15~rc1-1 [393 kB]
Get:7 http://ftp.debian.org/debian testing/main amd64 dh-strip-nondeterminism all 0.041-1 [12.0 kB]
Get:8 http://ftp.debian.org/debian testing/main amd64 libfile-stripnondeterminism-perl all 0.041-1 [19.9 kB]
Get:9 http://ftp.debian.org/debian testing/main amd64 libgirepository-1.0-1 amd64 1.56.1-1 [91.5 kB]
Get:10 http://ftp.debian.org/debian testing/main amd64 gir1.2-freedesktop amd64 1.56.1-1 [19.8 kB]
Get:11 http://ftp.debian.org/debian testing/main amd64 gir1.2-glib-2.0 amd64 1.56.1-1 [142 kB]
Get:12 http://ftp.debian.org/debian testing/main amd64 gvfs-bin amd64 1.36.1-1 [17.8 kB]
Get:13 http://ftp.debian.org/debian testing/main amd64 gvfs-backends amd64 1.36.1-1 [350 kB]
Get:14 http://ftp.debian.org/debian testing/main amd64 gvfs-fuse amd64 1.36.1-1 [30.5 kB]
Get:15 http://ftp.debian.org/debian testing/main amd64 gvfs amd64 1.36.1-1 [126 kB]
Get:16 http://ftp.debian.org/debian testing/main amd64 gvfs-daemons amd64 1.36.1-1 [132 kB]
Get:17 http://ftp.debian.org/debian testing/main amd64 gvfs-libs amd64 1.36.1-1 [110 kB]
Get:18 http://ftp.debian.org/debian testing/main amd64 gvfs-common all 1.36.1-1 [509 kB]
Get:19 http://ftp.debian.org/debian testing/main amd64 libdatetime-locale-perl all 1:1.18-1 [2,300 kB]
Get:20 http://ftp.debian.org/debian testing/main amd64 libhttp-negotiate-perl all 6.01-1 [12.8 kB]
Get:21 http://ftp.debian.org/debian testing/main amd64 libqpdf21 amd64 8.0.2-3 [320 kB]
Get:22 http://ftp.debian.org/debian testing/main amd64 libwww-robotrules-perl all 6.02-1 [12.9 kB]
Get:23 http://ftp.debian.org/debian testing/main amd64 libxml-sax-expat-perl all 0.51-1 [12.0 kB]
Get:24 http://ftp.debian.org/debian testing/non-free amd64 nvidia-detect amd64 390.48-2 [191 kB]
Get:25 http://ftp.debian.org/debian testing/main amd64 python-crypto amd64 2.6.1-9 [259 kB]
Get:26 http://ftp.debian.org/debian testing/main amd64 python3-pyqt5 amd64 5.10.1+dfsg-1 [2,287 kB]
Get:27 http://ftp.debian.org/debian testing/main amd64 qpdf amd64 8.0.2-3 [266 kB]
Fetched 12.3 MB in 7s (1,776 kB/s)                                             
Reading changelogs... Done
Preconfiguring packages ...
(Reading database ... 190272 files and directories currently installed.)
Preparing to unpack .../base-passwd_3.5.45_amd64.deb ...
Unpacking base-passwd (3.5.45) over (3.5.44) ...
Setting up base-passwd (3.5.45) ...
(Reading database ... 190272 files and directories currently installed.)
Preparing to unpack .../00-libpython2.7_2.7.15~rc1-1_amd64.deb ...
Unpacking libpython2.7:amd64 (2.7.15~rc1-1) over (2.7.14-8) ...
Preparing to unpack .../01-python2.7_2.7.15~rc1-1_amd64.deb ...
Unpacking python2.7 (2.7.15~rc1-1) over (2.7.14-8) ...
Preparing to unpack .../02-libpython2.7-stdlib_2.7.15~rc1-1_amd64.deb ...
Unpacking libpython2.7-stdlib:amd64 (2.7.15~rc1-1) over (2.7.14-8) ...
Preparing to unpack .../03-python2.7-minimal_2.7.15~rc1-1_amd64.deb ...
Unpacking python2.7-minimal (2.7.15~rc1-1) over (2.7.14-8) ...
Preparing to unpack .../04-libpython2.7-minimal_2.7.15~rc1-1_amd64.deb ...
Unpacking libpython2.7-minimal:amd64 (2.7.15~rc1-1) over (2.7.14-8) ...
Preparing to unpack .../05-dh-strip-nondeterminism_0.041-1_all.deb ...
Unpacking dh-strip-nondeterminism (0.041-1) over (0.040-1) ...
Preparing to unpack .../06-libfile-stripnondeterminism-perl_0.041-1_all.deb ...
Unpacking libfile-stripnondeterminism-perl (0.041-1) over (0.040-1) ...
Preparing to unpack .../07-libgirepository-1.0-1_1.56.1-1_amd64.deb ...
Unpacking libgirepository-1.0-1:amd64 (1.56.1-1) over (1.56.0-2) ...
Preparing to unpack .../08-gir1.2-freedesktop_1.56.1-1_amd64.deb ...
Unpacking gir1.2-freedesktop:amd64 (1.56.1-1) over (1.56.0-2) ...
Preparing to unpack .../09-gir1.2-glib-2.0_1.56.1-1_amd64.deb ...
Unpacking gir1.2-glib-2.0:amd64 (1.56.1-1) over (1.56.0-2) ...
Preparing to unpack .../10-gstreamer1.0-plugins-good_1.14.0-4_amd64.deb ...
Unpacking gstreamer1.0-plugins-good:amd64 (1.14.0-4) over (1.12.4-1+b1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-Cz6ZPm/10-gstreamer1.0-plugins-good_1.14.0-4_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstlame.so', which is also in package gstreamer1.0-plugins-ugly:amd64 1:1.12.3-dmo1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Preparing to unpack .../11-gvfs-bin_1.36.1-1_amd64.deb ...
Unpacking gvfs-bin (1.36.1-1) over (1.36.0-1+b1) ...
Preparing to unpack .../12-gvfs-backends_1.36.1-1_amd64.deb ...
Unpacking gvfs-backends (1.36.1-1) over (1.36.0-1+b1) ...
Preparing to unpack .../13-gvfs-fuse_1.36.1-1_amd64.deb ...
Unpacking gvfs-fuse (1.36.1-1) over (1.36.0-1+b1) ...
Preparing to unpack .../14-gvfs_1.36.1-1_amd64.deb ...
Unpacking gvfs:amd64 (1.36.1-1) over (1.36.0-1+b1) ...
Preparing to unpack .../15-gvfs-daemons_1.36.1-1_amd64.deb ...
Unpacking gvfs-daemons (1.36.1-1) over (1.36.0-1+b1) ...
Preparing to unpack .../16-gvfs-libs_1.36.1-1_amd64.deb ...
Unpacking gvfs-libs:amd64 (1.36.1-1) over (1.36.0-1+b1) ...
Preparing to unpack .../17-gvfs-common_1.36.1-1_all.deb ...
Unpacking gvfs-common (1.36.1-1) over (1.36.0-1) ...
Preparing to unpack .../18-libdatetime-locale-perl_1%3a1.18-1_all.deb ...
Unpacking libdatetime-locale-perl (1:1.18-1) over (1:1.17-1) ...
Preparing to unpack .../19-libhttp-negotiate-perl_6.01-1_all.deb ...
Unpacking libhttp-negotiate-perl (6.01-1) over (6.00-2) ...
Preparing to unpack .../20-libqpdf21_8.0.2-3_amd64.deb ...
Unpacking libqpdf21:amd64 (8.0.2-3) over (8.0.2-2) ...
Preparing to unpack .../21-libwww-robotrules-perl_6.02-1_all.deb ...
Unpacking libwww-robotrules-perl (6.02-1) over (6.01-1) ...
Preparing to unpack .../22-libxml-sax-expat-perl_0.51-1_all.deb ...
Unpacking libxml-sax-expat-perl (0.51-1) over (0.40-2) ...
Preparing to unpack .../23-nvidia-detect_390.48-2_amd64.deb ...
Unpacking nvidia-detect (390.48-2) over (390.48-1) ...
Preparing to unpack .../24-python-crypto_2.6.1-9_amd64.deb ...
Unpacking python-crypto (2.6.1-9) over (2.6.1-8) ...
Preparing to unpack .../25-python3-pyqt5_5.10.1+dfsg-1_amd64.deb ...
Unpacking python3-pyqt5 (5.10.1+dfsg-1) over (5.9.2+dfsg-1+b1) ...
Preparing to unpack .../26-qpdf_8.0.2-3_amd64.deb ...
Unpacking qpdf (8.0.2-3) over (8.0.2-2) ...
Errors were encountered while processing:
 /tmp/apt-dpkg-install-Cz6ZPm/10-gstreamer1.0-plugins-good_1.14.0-4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)



Dogs laugh, but they laugh with their tails.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1892
    • SparkyLinux
Re: System Upgrade does not complete...
« Reply #3 on: April 22, 2018, 12:16:57 am »
As you can see, there is a problem with gstreamer ugly and good packages
Quote
pkg: error processing archive /tmp/apt-dpkg-install-Cz6ZPm/10-gstreamer1.0-plugins-good_1.14.0-4_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstlame.so', which is also in package gstreamer1.0-plugins-ugly:amd64 1:1.12.3-dmo1
so...
Try to remove the problematic package as first:
Code: [Select]
sudo apt-get purge gstreamer1.0-plugins-uglythen try to fix rest of them:
Code: [Select]
sudo apt-get update
sudo apt-get install -f
sudo apt-get dist-upgrade
Show me your output if a problem still exist.
Nothing is easy as it looks.
Danielle Steel

Offline tenfoot

  • Jr. Member
  • **
  • Posts: 73
Re: System Upgrade does not complete...
« Reply #4 on: April 22, 2018, 04:55:30 am »
Hi Pavro

Again, thank you for a very prompt reply.  It is much appreciated.

Running the commands you advised appears to have fixed the problem and I am, to my utter relief, now a very happy geriatric :)

Dogs laugh, but they laugh with their tails.