Advertising

Author Topic: OpenBox desktop  (Read 820 times)

Offline penguin

  • Jr. Member
  • **
  • Posts: 90
OpenBox desktop
« on: April 13, 2018, 10:13:46 am »
Today I decided to configure OpenBox desktop as per www.lxlinux.com.
Openbox is preinstalled on SparkyLinux 4.8

Directly I found that Obconf was not installed
I installed lxappearance, continuing to .... install Obconf that asked to install libobrender29 ,version over 3.5.2 and after another library was required ... and so on.When libobt2 was required for installing, an conflict error comes up.

conky shows that :
Openbox runs on 268 Mb memory on my Sparky 4.7 (64 bit)
XFCE desktop runs on 369 Mb memory on my Sparky 4.7 (64 bit)
As I remember LXDE desktop runs between 28x to 3xx Mb on my Sparky 4.7 (64 bit)


Pavroo. Can you investigate this problem? Seppalta, kindly i am asking you to.

I am hopping that Sparky Linux 4.7 will upgraded smoothly to version 4.8
« Last Edit: April 13, 2018, 10:18:14 am by penguin »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1919
    • SparkyLinux
Re: OpenBox desktop
« Reply #1 on: April 13, 2018, 01:32:08 pm »
Run:
Code: [Select]
sudo apt update
sudo apt install -s obconf
and show the second command output.
Anyway, the obconf should be installed and avialable in the system sub menu as "Openbox Configuration Manger".

To check what use so much your ram, run:
Code: [Select]
ps aux
Nothing is easy as it looks.
Danielle Steel

Offline penguin

  • Jr. Member
  • **
  • Posts: 90
Re: OpenBox desktop
« Reply #2 on: April 13, 2018, 05:00:10 pm »
Run:
Code: [Select]
sudo apt update
sudo apt install -s obconf
and show the second command output.
Anyway, the obconf should be installed and avialable in the system sub menu as "Openbox Configuration Manger".

To check what use so much your ram, run:
Code: [Select]
ps aux


Quote
penguin@penguin-pc:~$ sudo apt install -s obconf
[sudo] password for penguin:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  obconf
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Inst obconf (1:2.0.4+git20150213-2 Debian:9.4/stable [amd64])
Conf obconf (1:2.0.4+git20150213-2 Debian:9.4/stable [amd64])

but on OpenBox desktop from menus (right click on desktop), click on Reconfigure does not shows up nothing and click on on Obconf shows up an dialog box said: failed to execute process ''obconf'' (No such file or directory)

executing obconf by terminal
Quote
penguin@penguin-pc:~$ sudo obconf
[sudo] password for penguin:
sudo: obconf: command not found


Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1919
    • SparkyLinux
Re: OpenBox desktop
« Reply #3 on: April 13, 2018, 07:29:19 pm »
Looks like you have NOT obconf installed, but after updating package list, there is no problem with installing it:
Code: [Select]
sudo apt update
sudo apt install obconf
After installing it, it will be visible in the System submenu.
Nothing is easy as it looks.
Danielle Steel

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 439
Re: OpenBox desktop
« Reply #4 on: April 14, 2018, 06:15:26 pm »
Once installed, it does not need to be run as sudo or via root. Run it as a normal user.

In Sparky wirh debian Buster  running "obconf:" as normal user is the same of going into menu / preferences / openbox configuration manager


Don't make a FrankenDebian