Advertising

Author Topic: sparkylinux 5.3 xfce - broken graphics with flash games + slimjet browser  (Read 411 times)

Offline nubipengen

  • Newbie
  • *
  • Posts: 20
hello everybody,

i am currently using :
- sparkylinux 5.3 xfce 32-bit
- slimjet browser 18.0
- libffmpeg.so version 0.28.2-linux-x32, a slimjet browser plugin for playing flash + mpeg

i have been using slimjet browser since its release 12.* on sparky (since release 5.1) for playing flash-based facebook games, and it has been working well until recent sparky 5.3 upgrade. i am not so sure what caused this, either the browser, its libffmpeg plugin, or else.

it is supposed to be displayed like [picture 1],
https://preview.ibb.co/f3ruPn/FBgame.png
but recently, the graphics is broken after a few seconds playing the game [picture 2].
https://preview.ibb.co/ggOxc7/brokengraph.jpg
as seen in picture 2, it affects not only the graphics in the flash game, but also the whole sparkylinux's user interface.

i have tried :
- reinstalling sparkylinux 5.3 xfce 32-bit
- downgrading slimjet browser to release 17.6
- downgrading libffmpeg.so to release 0.20.3-linux-x32

but the issue is persistent.
any help is appreciated, thank you in advance.



Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 389
Reinstalling your whole operating system is not the most effective way of learning and/or fixing problems in unix/linux/bsd. 
There should be a place to look up information for the slimjet browser.  Edit:added  Did you try https://www.slimjet.com/en/community.php 

I would go there also.  And if they have a an irc channel ask for information there also. (No - no irc.) 

What springs to mind for me first is - Do you have the debian-multimedia repositore enabled in etc/apt/......

Can you supply any text based error messages marked up as code ( use the # button above to format)
« Last Edit: March 31, 2018, 11:58:49 pm by paxmark1 »
Don't make a FrankenDebian

Offline nubipengen

  • Newbie
  • *
  • Posts: 20
What springs to mind for me first is - Do you have the debian-multimedia repositore enabled in etc/apt/......
thank you, sir. it seems to work.
after disabling debian-multimedia in the repository, reload the database, reinstalling slimjet browser + libffmpeg.so, the graphics in the flash game does not break anymore. i have been testing it for a few minutes and it has not yet broken like yesterday.

Quote
Can you supply any text based error messages marked up as code ( use the # button above to format)
i am not sure how to do it when the whole GUI is broken, sir, like shown in the picture 2. any key pressed did not show anything, as if the whole system was frozen too.

Offline nubipengen

  • Newbie
  • *
  • Posts: 20
this issue has not been resolved yet.

at current status, deb-multimedia has already been disabled in the synaptic repositories.
it has been playing well in these recent 3 days.
but after today's sparkylinux automatic update, the same issue is happening again - the whole sparky GUI is broken.

is there any other thing that i need to check ?
thanks again, sir.

Offline nubipengen

  • Newbie
  • *
  • Posts: 20
tonight, after the automatic sparky update/upgrade with apt full-upgrade command, i noticed slimjet browser was updated to release 18.0.2.

i tested playing the flash game again, and the graphics was not damaged anymore.
i am guessing this might relate to slimjet browser update.