Advertising

Poll

Why does Gimp dissapear

help
0 (0%)
help
0 (0%)

Total Members Voted: 0

Author Topic: Gimp  (Read 769 times)

Offline tranzed

  • Newbie
  • *
  • Posts: 7
Gimp
« on: March 17, 2018, 10:55:28 pm »
Hi guys,
When using gimp all the windows close without any warning or error messages.
I open the terminal and typed gimp and this is what follows.

(gimp:8795): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",
(gimp:8795): Gimp-Core-WARNING **: Wrong translation for 'tags-locale:', fix the translation!
(gimp:8795): GLib-GObject-WARNING **: g_object_set_is_valid_property: object class 'GeglConfig' has no property named 'cache-size'

I would really appreciate any help with this.



Offline Wombat

  • Jr. Member
  • **
  • Posts: 53
Re: Gimp
« Reply #1 on: March 18, 2018, 01:01:57 am »
Welcome!

Uninstall gimp.

Do a full manual upgrade of your new system as per-

https://sparkylinux.org/wiki/doku.php/upgrade

and then reinstall gimp ....preferably through Synaptic Package Manager in the menu to avoid any naming issues.

Possibly repeat the above upgrade procedure.

Krita is a simple alternative to gimp while solving this problem.
« Last Edit: March 18, 2018, 08:17:13 am by Wombat »

Offline tranzed

  • Newbie
  • *
  • Posts: 7
Re: Gimp
« Reply #2 on: March 18, 2018, 04:41:03 pm »
Hi,

Thank you for the helpful suggestions even though it has not worked. All gimp windows still close with no warning. When I type gimp into the terminal I still get the output ...
(gimp:24710): GLib-GObject-WARNING **: g_object_set_is_valid_property: object class 'GeglConfig' has no property named 'cache-size'

(gimp:24710): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",
KritaThe program 'gimp' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 41580 error_code 3 request_code 18 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

(script-fu:24728): LibGimpBase-WARNING **: script-fu: gimp_wire_read(): error


Any other suggestions please?


« Last Edit: March 18, 2018, 04:48:42 pm by tranzed »

Offline Wombat

  • Jr. Member
  • **
  • Posts: 53
Re: Gimp
« Reply #3 on: March 19, 2018, 06:21:36 am »
I get similar  warnings from entering ''gimp" in terminal-

Quote
(gimp:17855): GLib-GObject-WARNING **: g_object_set_is_valid_property: object class 'GeglConfig' has no property named 'cache-size'
(gimp:17855): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

Even more with krita. However both open and run normally.

Which version of Sparky did you install?....someone more capable may assist.

https://sparkylinux.org/forum/index.php?topic=4298.0







Offline tranzed

  • Newbie
  • *
  • Posts: 7
Re: Gimp
« Reply #4 on: March 19, 2018, 08:17:07 pm »
I believe it ts SparkyLinux 5.3 LXQt

Offline Wombat

  • Jr. Member
  • **
  • Posts: 53
Re: Gimp
« Reply #5 on: March 20, 2018, 12:17:24 am »
Lxqt!

As both krita and gimp have issues the problem is probably elsewhere in your setup rather than those particular programs.

You may get answers if you resubmit your subject using different wording ...such as  "Program windows closing in new install of SparkyLxQt"

Offline tranzed

  • Newbie
  • *
  • Posts: 7
Re: Gimp
« Reply #6 on: March 21, 2018, 10:15:24 am »
Thank you, I will submit another post with a different heading.