Advertising

Author Topic: [SOLVED] The icon of NetworkManager Applet disappeared  (Read 234 times)

Offline foreigner

  • Newbie
  • *
  • Posts: 4
[SOLVED] The icon of NetworkManager Applet disappeared
« on: March 08, 2018, 08:22:41 pm »
Hello

I installed, a few days ago, SparkyLinux 5.2 MinimalGUI (Openbox only) 64 bit on my laptop.
Today the icon of NetworkManager Applet (usually placed on the tray bar, near the volume icon) disappeared.
The Ethernet (wired) connection works, but I can't disconnect the wired connection and select a wifi network.
How could I restore the icon?
Alternatively, I could handle connections using the terminal, but I would need some suggestions.

Another (less important) issue, about Synaptic, Gufw and GParted (installed by me): in the past days the menu (the one you can open with a right click on the desktop) worked well to launch these programs. Now, the respective entries don't work anymore and I have to launch these programs using the terminal. The menu works fine with the other entries.

Thanks for your help  :)
« Last Edit: March 09, 2018, 07:24:18 pm by foreigner »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1833
    • SparkyLinux
Re: The icon of NetworkManager Applet disappeared
« Reply #1 on: March 08, 2018, 10:43:50 pm »
Yes, I saw that too.
Looks like the Openbox doesn't read the system's autostart options, so have to put some of them to openbox autostart manualy.
Edit ~/.config/openbox/autostart.sh file and add the lines to it:
Code: [Select]
sparky-polkit &make sure you have 'sparky-polkit' package installed
Code: [Select]
/opt/sparky/nm-applet-reload &make sure you have 'sparky-nm-applet' package installed.
Then relogin/reboot to take effects.
Nothing is easy as it looks.
Danielle Steel

Offline foreigner

  • Newbie
  • *
  • Posts: 4
Re: The icon of NetworkManager Applet disappeared
« Reply #2 on: March 09, 2018, 07:22:33 pm »
Pavroo, thank you for your answer and your help.
The changes you've recommended to ~/.config/openbox/autostart.sh worked perfectly.

Thanks.