Advertising

Author Topic: lumina and wm  (Read 119 times)

Offline yannig

  • Newbie
  • *
  • Posts: 5
lumina and wm
« on: February 09, 2018, 10:29:29 pm »
I have sparky stable (4.7) lxde installed on an thinkpad x230 laptop. I tried installing lumina from aptus, it works but ... i can't move the windows. I guess there is a lacking wm ... but no idea how i can fix it. Openbox and fluxbox are both installed on the system, as a lxde user i use openbox everyday.
Can someone telle me what i should edit or fix, to get lumina working correctly and moving the windows ?
Thanks already,
yannig,

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1788
    • SparkyLinux
Re: lumina and wm
« Reply #1 on: February 10, 2018, 02:41:33 pm »
It uses Fluxbox as default, did you check in Lumina settings?
Nothing is easy as it looks.
Danielle Steel

Offline yannig

  • Newbie
  • *
  • Posts: 5
Re: lumina and wm
« Reply #2 on: February 11, 2018, 02:57:38 pm »
no, where are they ? which is the file to edit ?

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1788
    • SparkyLinux
Re: lumina and wm
« Reply #3 on: February 12, 2018, 09:19:29 pm »
Check does the fluxbox work:
Code: [Select]
pidof fluxboxIf a PID number is given, it does, if not run it:
Code: [Select]
fluxbox &
Nothing is easy as it looks.
Danielle Steel

Offline L0rdGaran

  • Newbie
  • *
  • Posts: 1
Re: lumina and wm
« Reply #4 on: Today at 04:26:32 am »
Sorry I cannot be more exact, I am not using Lumina any more so playing this from memory. Hopefully this will get you into the neighborhood.

Go into Configuration Manager and click on Window Manager Settings icon.
At the top of the Window Manager Settings click the radio button to switch to Advanced Editor
In the list of settings scan through the settings. 
- There should be a parameter about key mapping, near the bottom of list. 
- The easy method to decide if you have the correct parameter is the value for the parameter is a reference to a file located in pavroo's home directory.

Simplest solution  is to just remove the parameter line (to revert to system default mapping) and save settings.

A side note. I frequently had Lumina reset the Windows Manager Settings to a very basic list of parameters.  You might want to save your settings into a text note somewhere in case you need to re-enter it.