Advertising

Author Topic: dpkg 1.19.0.5 grave bug  (Read 398 times)

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 360
dpkg 1.19.0.5 grave bug
« on: January 24, 2018, 09:00:07 am »
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=888234

Sneaky little one.  A problem with dpkg  would bide it's time until new things arrive. 

Myself , "apt-mark hold dpkg"    is what I did.  So I am staying at 1.19.0.4 

I do like apt-listbugs   
Don't make a FrankenDebian

Offline Wombat

  • Jr. Member
  • **
  • Posts: 53
Re: dpkg 1.19.0.5 grave bug
« Reply #1 on: January 27, 2018, 01:26:42 am »
1.19.0.5 is already the testing version.  What are our options other than "apt-mark hold dpkg" to avoid problems?

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 360
Re: dpkg 1.19.0.5 grave bug
« Reply #2 on: January 27, 2018, 02:35:23 am »
I was trained for Debian  testing, ... elsewhere. 

1.  Do you have apt-listbugs installed?  I do, it caught it for me and and I did not accept the install.  I'm still at 1.19.0.4  As everything, apt-listbugs has plusses and minusses in it's usage. 

2.  Are you having problems?  It might be that the individuals affected (3 that I have seen now on the bug report) have things that make the bug happen, btrfs, new glibc ...  If you are not having problems, you can be calm, wait, lurk in #debian-next

3.  If you are having problems, they probably won't take you input on the bug list.  You could always post the output of "reportbug" here. 

4.  To fix partial upgrades, probably do as message 10 does. 
dpkg --configure -a and apt install --fix-broken.

5.  search for how to backpedal back to 1.19.04   
Don't make a FrankenDebian

Offline Wombat

  • Jr. Member
  • **
  • Posts: 53
Re: dpkg 1.19.0.5 grave bug
« Reply #3 on: January 27, 2018, 03:07:39 pm »
Yes. The problem does seem restricted to a small number so probably won't need to take precautions.

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 360
Re: dpkg 1.19.0.5 grave bug
« Reply #4 on: January 28, 2018, 07:32:15 am »
Bug has been downgraded to important from grave.  I do have another netbook, ancient EEE901 that has had no problems with 1.19.0.5 last few days.on debian testing.  I am removing the hold myself.  Will mark as solved tomorrow.  Peace out.
Don't make a FrankenDebian