Advertising

Author Topic: Solved: lxqt 0.12 transition done  (Read 678 times)

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 372
Solved: lxqt 0.12 transition done
« on: December 06, 2017, 08:23:47 pm »
Not now, but in the near future 4-5 days there will be an transition in LXQT, it is occurring in unstable - Sid at this time. 
Short hint, If a full- or dist- upgrade mentions getting rid of a large number of qt and lxqt programs, wait, and research. 

Quote
LXQt Transition started
That means - do yourself a favour and don't do dist-upgrades for the next two days.
Füsse stillhalten, das ist in 2 Tagen durch.
  posted by melmarker

This happens less frequently in testing than in unstable.  To track the process of this elsewhere

https://forum.siduction.org/index.php?topic=6953.msg56295;topicseen#new

Nothing noted on
https://release.debian.org/transitions/
at this time 
« Last Edit: December 17, 2017, 01:37:54 am by paxmark1 »
Don't make a FrankenDebian

Offline nedhedrick

  • Newbie
  • *
  • Posts: 3
Re: lxqt transition
« Reply #1 on: December 10, 2017, 05:08:11 pm »
After yesterdays upgrade, my wallpaper and all my desktop icons disappeared.  Some applications won't work at all.  PCMANFM-qt does not work (probably related to desktop issue).  I can browse internet but downloads don't work.  Happened on two notebooks before I decided to stop doing upgrades until it's fixed.

Also, if I right click on the blank desktop, I get a Debian menu.

Will probably re-install and restore home directory from backup to get things back to normal until I can see if it's fixed.

Anyone else with similar experiences?

Ned

Offline nedhedrick

  • Newbie
  • *
  • Posts: 3
Re: lxqt transition
« Reply #2 on: December 10, 2017, 05:28:49 pm »
I forgot to mention above, this is rolling release 5.1.  The system works fine UNTIL a restart.

Ned

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 372
Re: lxqt transition
« Reply #3 on: December 10, 2017, 09:38:55 pm »
I am experiencing problems presently.  The need to go to command line for poweroff was minor.  However I now have a blue window with just the menu strip with menu button, sparku apt-us and 7 applets.  Unless you want to help debug, hold off on upgrading.

About doing a complete reinstall.  Normally I would say that is not the way to learn or to utiilize debian-testing and it's derivatives.  However in this case, well maybe. 
But a less drastic option is to        ### maybe try first with apt -s blah
apt remove  libqt5xdg libqt5xdgiconloader*      ### which will remove a whole lot of things     and then   EDIT:  did not work - wait or do at your own risk.
apt install task-lxqt-desktop         ## which will bump items compiled with previous versions of qtxdg and liblxqt

I HAVE NOT DONE THAT YET.  It does seem rational removing those initial items with the * glob. 

EDIT: I HAVE DONE, did not work at this point. 

From siduction forum.   Poster is melmarker - agaida the debian dev for lxqt.     


Quote
@titan: it seems you lack the basic understanding what LXQt is and how it works - no problem, the informations are well hidden :) So i will try to bring a little bit more light into: the very basic lib is libqtxdg - currently in version libqt5xdg3 3.1.0, built on that is libfm-qt3 (0.12.0) and liblxqt0 (0.12.0) - all other compontents are more or less based on these three libs. Next very important parts of LXQt are the lxqt-session and lxqt-qtplugin. First is the integrational part that deliver the session, set the used platform and start basic services. Second is a kind of glue that provide the session settings to the applications if a lxqt session is running.

And exactly there seems to be a problem, all of these components need to build against the same qtxdg and liblxqt. One can check that - if no session is present one can set the pcmanfm-qt icon theme directly in pcmanfm-qt - with a valid session running these settings are hidden.

Best bet to solve your issues is just to remove libqt5xdg* and libqt5xdgiconloader* - that will take all other LXQt components with it. After that an simple "apt install task-lxqt-desktop" will install a full LXQt with all bells and whistles - if not done yet i would suggest to remove /etc/apt/apt.conf.d/80siduction or change it to install recommends. One can purge not needed packages afterwards.

Edit: forget to mention that LXQt is strictly indipendent from any Window Manager - so on can chose every WM one like. That will work fine in theory, there might be some issues with keybindings and the way different WMs handle background applications - keybindings are handled for LXQt in lxqt-globalkeysd, so if the WM take some bindings that globalkeysd want, one should solve that in one of the settings. Second: i3 seems to mess up the classic desktop layer - so it migth be better that there is no pcmanfm-qt --desktop process running.
« Last Edit: December 10, 2017, 10:15:54 pm by paxmark1 »
Don't make a FrankenDebian

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 372
Re: lxqt transition
« Reply #4 on: December 14, 2017, 08:40:26 am »
NOTE: Things looking better, things appear to have returned to normal.

The transition from 0.11 to 0.12 appears complete.   (note - there are other numbering sequences - 20 vs 21 - I do not understand).   "apt update" and "apt full-upgrade"  tonight gave me several more lxqt components with 0.12   

I had been back to the empty blue screen, prior to a blue screen with the lxqt panel and the first problem I had was the inability to utilze the lxqt menu shutdown option -  a dbus conflict. 

I do not have any problems with pcmanfm-qt either as others have posted/

All of these are gone now. for me. 

If it does not work for you, I have done the

Code: [Select]
apt remove  libqt5xdg libqt5xdgiconloader*
apt install task-lxqt-desktop 
apt full-upgrade --install-recommends

after the second round of lxqt programs came through. Hopefully none of you have to do those things.   

I will wait to see if others have problems before marking solved and kick the tires around a little more myself.

EDIT  Time passed, Marked as solved
« Last Edit: December 17, 2017, 01:38:38 am by paxmark1 »
Don't make a FrankenDebian

Offline nedhedrick

  • Newbie
  • *
  • Posts: 3
Re: Solved: lxqt 0.12 transition done
« Reply #5 on: December 20, 2017, 06:30:52 am »
A quick note to update my issue above -- after a re-install and approx 7 day delay before upgrading, now everything seems to be working.  I realize a re-install may not have been the ideal solution, but I was not able to spend significant time on the issue.  Thus, a re-install was the only option available to me at the time.

It appears the LXQt "transition" was not done all at once, i.e. individual packages were upgraded a few at a time.  I'm guessing there was something that wasn't compatible between newly updated modules and the older ones that were not included in the upgrade.  My wait to upgrade allowed the remaining modules to be included in my eventual upgrade and all was well.

Phased implementations sometimes exhibit issues that aren't easily predicted...

Ned