Advertising

Author Topic: problem installing nvidia proprietary driver on Sparky 5.1 liquorix_64 kernel  (Read 502 times)

Offline Leprotto

  • Newbie
  • *
  • Posts: 1
I had the same problem when trying to install it on sparky 4.13 kernel. It seemed the setup program forgot (or maybe couldn't find the repo) to install the headers needed by the nvidia driver. So i followed this debian link https://wiki.debian.org/NvidiaGraphicsDrivers#Debian_8_.22Jessie.22 to do it manually,step 1 and 2, and it worked.
Then i installed the liquorix 64 bit 4.14 kernel and found the same problem, but now the trick

Code: [Select]
apt-get install linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//')
doesn't work anymore because it says it's already installed in the kernel.
but obviously it is not because doing

Code: [Select]
systemctl status systemd-modules-load.service
tells me this
https://ibb.co/i5txeb
Is there a way to force the reinstallation of the headers?
« Last Edit: December 05, 2017, 09:45:29 pm by Leprotto »

Offline crypto

  • Newbie
  • *
  • Posts: 21
now i'm not a wizard ...... but i think you'll need to compile against the liquirox kernel headers ...
that should work anyway,  with a big  -- i think ...
 

i can't see your other link because of my security settings ..

Offline Capitain_Jack

  • Jr. Member
  • **
  • Posts: 91
Being such a closed mind into Debian world should be shameful...
https://wiki.debian.org/Derivatives

SparkyLinux, in case you missed it, have all three flavors, so the only mistake cryptoa was the sparky repo version you added.

Start over and change the version of that repository and every thing will be fine, as suggested by our not so helpful collage link at debian forum (http://forums.debian.net/viewtopic.php?f=5&t=135603&p=661056#p661056), you cannot mix Debian flavors (stable, testing, unstable), that's when problems occur.

https://sparkylinux.org/wiki/doku.php/repository

The wiki doesn't show the unstable repo because it's meant for advanced users, but as you can notice, simply change the version name after the repo address and package priority.
"Great spirits have always encountered violent opposition from mediocre minds."
Albert Einstein