Advertising

Author Topic: [XFCE4] 100% CPU load for Xorg process  (Read 997 times)

Offline c.monty

  • Newbie
  • *
  • Posts: 6
[XFCE4] 100% CPU load for Xorg process
« on: November 19, 2017, 11:48:21 am »
Hello!

After starting XFCE4 session I get a single process allocating 100% CPU:
/usr/lib/xorg/Xorg :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

This issue does not occur when starting another desktop session, e.g. DDE.

What's causing this issue?
How can I troubleshoot it?

THX

Offline jimdunn

  • Newbie
  • *
  • Posts: 5
Re: [XFCE4] 100% CPU load for Xorg process
« Reply #1 on: November 19, 2017, 05:37:19 pm »
I had the same 100% for Xorg on one of my laptops (but not the others).

Turns out it was the PulseAudio "volume control" in the system tray.  If you remove it... the cpu spike is gone.

Offline c.monty

  • Newbie
  • *
  • Posts: 6
Re: [XFCE4] 100% CPU load for Xorg process
« Reply #2 on: November 19, 2017, 07:11:36 pm »
Interesting... however this workaround is not working with my laptop (T410).
« Last Edit: November 19, 2017, 07:17:34 pm by c.monty »

Offline stroudmw

  • Newbie
  • *
  • Posts: 6
Re: [XFCE4] 100% CPU load for Xorg process
« Reply #3 on: March 06, 2018, 04:27:48 pm »
I've got the same problem. Removing Pulse Audio from the system tray hasn't helped. The fan noise is driving me nuts!

Offline Wombat

  • Jr. Member
  • **
  • Posts: 53
Re: [XFCE4] 100% CPU load for Xorg process
« Reply #4 on: March 10, 2018, 11:50:45 pm »
Uninstalling Conky fixed  CPU overload issues on my KDE.

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 372
Re: [XFCE4] 100% CPU load for Xorg process
« Reply #5 on: March 12, 2018, 05:09:53 am »
So, if you are having a runaway process - it is o.k. to use htop and paste the offending process info into your post.

If it is conky    -    conky can be wonky
Some scripts are designed for the old version   Some old scripts do not convert well with the update script for conky

https://sparkylinux.org/forum/index.php/topic,3302.msg7011.html#msg7011

Much much much more of all things conky at Bunsenlabs forum and also a bit at vsido. 
peace out.
« Last Edit: March 12, 2018, 05:12:30 am by paxmark1 »
Don't make a FrankenDebian

Offline DonTequila

  • Newbie
  • *
  • Posts: 1
Re: [XFCE4] 100% CPU load for Xorg process
« Reply #6 on: April 19, 2018, 05:13:24 pm »
I had the same issue with multiple installations. On all I was able to solve the problem with a different look&feel.

Go to "Settings"->"Appearance".

On the Style tab change to anything different than Sparky5. CPU load will immediately go down.