Author Topic: (solved) dist-upgrade wants to remove what?  (Read 327 times)

Offline 21grams

  • Newbie
  • *
  • Posts: 7
(solved) dist-upgrade wants to remove what?
« on: November 18, 2017, 01:51:34 am »
Morning all.

A few weeks backs I checked dist-upgrade, something I do often (2-3 times a week). The list is below of what was to be removed and what was no longer required along with upgrades. To my surprise I saw with it so many installed programs that were going to be removed and of course I did not proceed. I changed to stable hoping that when changing back to testing, the dist-upgrade would have been corrected.
I use MATE that I've been testing for more than 2 years and have not seen this issue before.
Any help would be appreciated to continue with testing.

Code: [Select]
me@sparky:~$ sudo apt-get dist-upgrade
[sudo] password for me:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  apt-transport-https atril-common avidemux-common avidemux-plugins compton
  conky conky-std dctrl-tools engrampa engrampa-common eom-common fonts-dejavu
  fonts-freefont-ttf fonts-mathjax freepats game-data-packager
  game-data-packager-runtime geoclue-2.0 gir1.2-javascriptcoregtk-3.0
  gir1.2-javascriptcoregtk-4.0 gir1.2-keybinder-3.0 gir1.2-peas-1.0
  gir1.2-soup-2.4 gstreamer1.0-libav gstreamer1.0-nice iio-sensor-proxy
  ioquake3-server libaften0 libbasicusageenvironment1 libbind9-140 libcddb2
  libcdio-cdda2 libcdio-paranoia2 libconfig9 libdc1394-22 libdca0
  libdns-export162 libdns162 libdouble-conversion1 libdvbpsi10 libebml4v5
  libegl-nvidia0:i386 libexempi3 libfaad2 libflite1 libfluidsynth1 libfs6
  libgadu3 libgbm1 libgeoclue-2-0 libgl1-nvidia-glx libgles-nvidia1
  libgles-nvidia1:i386 libgles-nvidia2 libgles1-glvnd-nvidia
  libgles1-glvnd-nvidia:i386 libgles2 libgroupsock8 libgtkspell0 libgxps2
  libharfbuzz-icu0 libhyphen0 libisc-export160 libisc160 libisccfg140
  libiso9660-10 libjavascriptcoregtk-1.0-0 libjavascriptcoregtk-3.0-0
  libjavascriptcoregtk-4.0-18 libjs-mathjax libkate1 libkeybinder-3.0-0
  libkpathsea6 liblavfile-2.1-0 liblavjpeg-2.1-0 liblavplay-2.1-0 liblilv-0-0
  liblirc-client0 liblivemedia58 libllvm3.9 libllvm3.9:i386 liblua5.1-0
  libmatroska6v5 libmeanwhile1 libmms0 libmodplug1 libmp4v2-2 libmpcdec6
  libmuparser2v5 libnvidia-cfg1 libnvidia-cfg1:i386 libnvidia-eglcore:i386
  libofa0 libopenh264-2 libopenh264-2:i386 libopusfile0 libprotobuf-c1
  libproxy-tools libpython3.5 libpython3.5-minimal libpython3.5-stdlib
  libqt4-declarative libqt4-designer libqt4-help libqt4-script
  libqt4-scripttools libqt4-sql libqt4-sql-mysql libqt4-test
  libqt4-xmlpatterns libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5network5
  libqt5qml5 libqt5script5 libqt5sql5 libqt5sql5-sqlite libqt5xml5
  libqtassistantclient4 libquicktime2 librecad-data libresid-builder0c2a
  librpm3 librpm8 librpmio3 librpmio8 libsbc1 libsdl-image1.2 libsdl-ttf2.0-0
  libserd-0-0 libsidplay2 libsord-0-0 libsoundtouch1 libspandsp2 libspectre1
  libsratom-0-0 libsrtp0 libuchardet0 libupnp6 libusageenvironment3 libva-drm1
  libva-drm1:i386 libva-wayland1 libva-x11-1 libva-x11-1:i386 libva1:i386
  libvcdinfo0 libvidstab1.0 libvlc-bin libvlc5 libvlccore8 libvo-aacenc0
  libwayland-server0 libwildmidi-config libwildmidi2 libx264-150
  libx264-150:i386 libx265-116:i386 libx265-116 libxatracker2 libxcb-xinerama0
  libxkbcommon-x11-0 libxnvctrl0 libxvmc1 libzbar0 libzephyr4 libzimg2
  liferea-data mate-backgrounds mjpegtools nvidia-driver-bin
  nvidia-persistenced nvidia-settings openarena-081-maps openarena-081-misc
  openarena-081-players openarena-081-players-mature openarena-081-textures
  openarena-085-data openarena-088-data openarena-data openarena-oacmp1
  pidgin-data python-glade2 python-gst0.10 python-jinja2 python-libturpial
  python-libxml2 python-markupsafe python-oauth python-qt4 python-simplejson
  python-sip python3-yaml python3.5 python3.5-minimal qttranslations5-l10n
  rpm-common rpm2cpio rtcw-common sparky-desktop-data sparky-editor
  sparky-xterm ssft tcpd timidity timidity-daemon twolame ufw vapoursynth
  vlc-bin vlc-data vlc-l10n vlc-plugin-base vlc-plugin-notify vlc-plugin-samba
  vlc-plugin-video-output vlc-plugin-video-splitter vlc-plugin-visualization
  vrms x11-apps x11-session-utils x11-xfs-utils xfonts-100dpi xfonts-75dpi
  xfonts-scalable xinit xserver-xorg-legacy yelp-xsl zenity-common
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  atril avidemux avidemux-qt caja ddm dooble eom ffmpeg gir1.2-webkit-3.0
  gir1.2-webkit2-4.0 gnuplot-qt gstreamer1.0-plugins-bad gufw gzdoom ioquake3
  libatrildocument3 libatrilview3 libavdevice57 libegl1-glvnd-nvidia
  libegl1-glvnd-nvidia:i386 libegl1-mesa libfarstream-0.2-5 libgail-3-0
  libgl1-mesa-glx libgles-nvidia2:i386 libgles2-glvnd-nvidia
  libgles2-glvnd-nvidia:i386 libgles2-mesa libglvnd0-nvidia
  libglvnd0-nvidia:i386 libglx0-glvnd-nvidia libglx0-glvnd-nvidia:i386
  libgstreamer-plugins-bad1.0-0 libgtk-3-bin libopengl0-glvnd-nvidia
  libopengl0-glvnd-nvidia:i386 libpurple-bin libpurple0 libqt5gui5
  libqt5opengl5 libqt5printsupport5 libqt5quick5 libqt5svg5 libqt5webkit5
  libqt5widgets5 libqt5x11extras5 librecad libsdl2-2.0-0 libwebkit2gtk-4.0-37
  libwebkit2gtk-4.0-37-gtk2 libwebkitgtk-1.0-0 libwebkitgtk-3.0-0 libyelp0
  liferea marco mate-core mate-desktop-environment-core mate-user-guide mpv
  nvidia-driver nvidia-driver-libs nvidia-driver-libs:i386
  nvidia-driver-libs-i386:i386 nvidia-egl-icd:i386 openarena pidgin
  pidgin-lastfm pidgin-microblog pidgin-musictracker pidgin-twitter
  python-webkit qt5-gtk-platformtheme quake3 radiotray rtcw smplayer
  smplayer-l10n smplayer-themes sparky-about sparky-aptus sparky-aptus-extra
  sparky-aptus-upgrade sparky-codecs sparky-compton sparky-conky
  sparky-desktop sparky-gufw sparky-live-usb-creator sparky-office
  sparky-usb-formatter sparky-wine steam-launcher task-desktop turpial
  virtualbox-5.1 vlc vlc-plugin-qt vlc-plugin-skins2 xorg xserver-xorg
  xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-evdev
  xserver-xorg-input-libinput xserver-xorg-input-mouse
  xserver-xorg-input-synaptics xserver-xorg-input-wacom xserver-xorg-video-all
  xserver-xorg-video-amdgpu xserver-xorg-video-ati xserver-xorg-video-cirrus
  xserver-xorg-video-fbdev xserver-xorg-video-intel xserver-xorg-video-mach64
  xserver-xorg-video-mga xserver-xorg-video-neomagic
  xserver-xorg-video-nouveau xserver-xorg-video-nvidia xserver-xorg-video-r128
  xserver-xorg-video-radeon xserver-xorg-video-savage xserver-xorg-video-tdfx
  xserver-xorg-video-trident xserver-xorg-video-vesa xserver-xorg-video-vmware
  yad yelp zenity
The following NEW packages will be installed:
  e2fsprogs-l10n gnuplot-x11 libbind9-141 libdata-dump-perl libdns-export190
  libdns190 libegl1 libgl1 libgl1:i386 libgles2 libglvnd0 libglvnd0:i386
  libglx-mesa0 libglx-mesa0:i386 libglx0 libglx0:i386 libisc-export189
  libisc189 libisccfg144 libjson-c3 libllvm5.0 libllvm5.0:i386
  libopenh264-4:i386 libpython3.6 libpython3.6-minimal libpython3.6-stdlib
  librpm8 librpmio8 libtry-tiny-perl libva-drm2 libva-drm2:i386 libva-x11-2
  libva-x11-2:i386 libva2 libva2:i386 libvidstab1.1 libwebp6:i386
  libwebpmux3:i386 libx264-152:i386 libx265-130:i386 libxcb-xfixes0:i386
  python3-debconf python3.6 python3.6-minimal
The following packages have been kept back:
  libmikmod3
The following packages will be upgraded:
  apt apt-transport-https apt-utils arj at autotools-dev avidemux-common
  avidemux-plugins bind9-host binutils binutils-common
  binutils-x86-64-linux-gnu bsdmainutils console-setup console-setup-linux
  cpp-6 cpp-7 cups cups-bsd cups-client cups-common cups-core-drivers
  cups-daemon cups-ipp-utils cups-ppdc cups-server-common curl dbus
  dbus-user-session dbus-x11 debconf debconf-i18n debhelper
  debian-mate-default-settings debianutils dh-autoreconf
  dh-strip-nondeterminism dirmngr distro-info-data dmsetup dnsutils dpkg
  dpkg-dev e2fslibs e2fsprogs extlinux fakeroot findutils flashplayer-mozilla
  fonts-wine fuse2fs g++-7 game-data-packager game-data-packager-runtime gcc-6
  gcc-6-base gcc-6-base:i386 gcc-7 gcc-7-base gcc-7-base:i386
  gir1.2-freedesktop gir1.2-glib-2.0 gir1.2-gtk-3.0
  gir1.2-javascriptcoregtk-4.0 gir1.2-soup-2.4 glib-networking
  glib-networking-common glib-networking-services gnome-accessibility-themes
  gnome-themes-standard gnome-themes-standard-data gnupg gnupg-l10n
  gnupg-utils gnupg2 gnuplot gnuplot-data gpg gpg-agent gpg-wks-client
  gpg-wks-server gpgconf gpgsm gpgv gsfonts gtk-update-icon-cache
  hexchat-python3 hplip hplip-data hunspell-en-us i965-va-driver
  i965-va-driver:i386 ifupdown init init-system-helpers ioquake3-server
  iptables irqbalance isc-dhcp-client isc-dhcp-common keyboard-configuration
  krb5-locales lib32gcc1 lib32stdc++6 libaio1 libapparmor1 libappstream4
  libapr1 libapt-inst2.0 libapt-pkg5.0 libasan3 libasan4 libass9 libatomic1
  libaudit-common libaudit1 libavcodec57 libavcodec57:i386 libavfilter6
  libavformat57 libavresample3 libavresample3:i386 libavutil55
  libavutil55:i386 libbabl-0.1-0 libbinutils libblockdev-crypto2
  libblockdev-fs2 libblockdev-loop2 libblockdev-part-err2 libblockdev-part2
  libblockdev-swap2 libblockdev-utils2 libblockdev2 libboost-filesystem1.62.0
  libboost-iostreams1.62.0 libboost-program-options1.62.0
  libboost-serialization1.62.0 libboost-system1.62.0 libbsd0 libbsd0:i386
  libcairo-gobject2 libcairo2 libcairo2:i386 libcanberra-gtk-module
  libcanberra-gtk0 libcanberra-gtk3-0 libcanberra-gtk3-module libcanberra0
  libcap-ng0 libcc1-0 libcgi-pm-perl libcilkrts5 libclass-accessor-perl
  libclone-perl libcomerr2 libcomerr2:i386 libcups2 libcups2:i386 libcupscgi1
  libcupsimage2 libcupsmime1 libcupsppdc1 libcurl3 libcurl3-gnutls libdbus-1-3
  libdbus-1-3:i386 libdbus-glib-1-2 libdebconfclient0 libdevmapper1.02.1
  libdpkg-perl libdrm-amdgpu1 libdrm-amdgpu1:i386 libdrm-common libdrm-intel1
  libdrm-intel1:i386 libdrm-nouveau2 libdrm-nouveau2:i386 libdrm-radeon1
  libdrm-radeon1:i386 libdrm2 libdrm2:i386 libegl-nvidia0 libegl-nvidia0:i386
  libexif12 libexpat1 libexpat1:i386 libfaac0 libfaad2 libfakeroot
  libfastjson4 libfile-stripnondeterminism-perl libfreetype6 libfreetype6:i386
  libgbm1 libgcc-6-dev libgcc-7-dev libgcc1 libgcc1:i386 libgcrypt20
  libgcrypt20:i386 libgd3 libgeoip1 libgfortran4 libgirepository-1.0-1
  libgl1-mesa-dri libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libgl1-nvidia-glx
  libgl1-nvidia-glx:i386 libglapi-mesa libglapi-mesa:i386 libgles-nvidia1
  libgles-nvidia1:i386 libgles-nvidia2 libgles1-glvnd-nvidia
  libgles1-glvnd-nvidia:i386 libglx-nvidia0 libglx-nvidia0:i386 libgmime-3.0-0
  libgnutls30 libgnutls30:i386 libgomp1 libgomp1:i386 libgpg-error0
  libgpg-error0:i386 libgpgme11 libgphoto2-6 libgphoto2-l10n libgphoto2-port12
  libgssapi-krb5-2 libgssapi-krb5-2:i386 libgtk-3-0 libgtk-3-common
  libgucharmap-2-90-7 libharfbuzz-icu0 libharfbuzz0b libhpmud0
  libhtml-tree-perl libhttp-cookies-perl libimage-exiftool-perl
  libimobiledevice6 libio-socket-ip-perl libio-socket-ssl-perl libip4tc0
  libip6tc0 libiptc0 libisccc140 libitm1 libjavascriptcoregtk-4.0-18
  libjs-sphinxdoc libjson-glib-1.0-0 libjson-glib-1.0-common libk5crypto3
  libk5crypto3:i386 libkrb5-3 libkrb5-3:i386 libkrb5support0
  libkrb5support0:i386 libldb1 liblsan0 liblwres141 libmad0 libmatedict6
  libmbim-glib4 libmbim-proxy libmfx0 libmfx0:i386 libmime-base64-urlsafe-perl
  libmm-glib0 libmpx2 libnet-http-perl libnghttp2-14 libnm-glib-vpn1
  libnm-glib4 libnm-gtk0 libnm-util2 libnm0 libnma0 libnpth0 libnvidia-cfg1
  libnvidia-cfg1:i386 libnvidia-eglcore libnvidia-eglcore:i386
  libnvidia-glcore libnvidia-glcore:i386 libnvidia-ml1 libopenmpt0 libosmesa6
  libosmesa6:i386 libp11-kit0 libp11-kit0:i386 libpeas-1.0-0 libperl5.26
  libpostproc54 libpsl5 libpython-stdlib libpython2.7 libpython2.7-minimal
  libpython2.7-stdlib libpython3-stdlib libpython3.5 libpython3.5-minimal
  libpython3.5-stdlib libqmi-glib5 libqmi-proxy libquadmath0 librsvg2-2
  librsvg2-common libsane-hpaio libsdl-image1.2 libsecret-1-0 libsecret-common
  libsmbclient libsoup-gnome2.4-1 libsoup2.4-1 libsoxr0 libsoxr0:i386
  libsqlite3-0 libss2 libssl1.0.2 libssl1.1 libssl1.1:i386 libstdc++-7-dev
  libstdc++6 libstdc++6:i386 libswresample2 libswresample2:i386 libswscale4
  libtalloc2 libtdb1 libtevent0 libthai-data libthai0 libtiff5 libtiff5:i386
  libtsan0 libubsan0 libudisks2-0 libvisual-0.4-0 libvisual-0.4-0:i386
  libvlc-bin libvlc5 libvlccore8 libwayland-egl1-mesa libwbclient0 libwine
  libwine:i386 libwrap0 libwrap0:i386 libwww-perl libxapian30 libxatracker2
  libxml-libxml-perl libxml2 libxml2:i386 libxres1 libxslt1.1 libxslt1.1:i386
  libxtables12 libzimg2 lintian mate-calc mate-calc-common
  mate-notification-daemon mate-notification-daemon-common mate-power-manager
  mate-power-manager-common mate-session-manager mate-settings-daemon
  mate-settings-daemon-common mate-system-monitor mate-system-monitor-common
  mate-themes mate-utils mate-utils-common mesa-vdpau-drivers
  mesa-vdpau-drivers:i386 modemmanager network-manager network-manager-gnome
  nvidia-alternative:i386 nvidia-detect nvidia-driver-bin nvidia-egl-common
  nvidia-egl-icd nvidia-kernel-dkms nvidia-kernel-support
  nvidia-legacy-check:i386 nvidia-smi nvidia-vdpau-driver openarena-081-maps
  openarena-081-misc openarena-081-players openarena-081-players-mature
  openarena-081-textures openarena-085-data openarena-088-data openarena-data
  openarena-oacmp1 openjdk-8-jre openjdk-8-jre-headless openssl p11-kit
  p11-kit-modules perl perl-base perl-modules-5.26 php-common php7.0
  php7.0-cgi php7.0-cli php7.0-common php7.0-curl php7.0-fpm php7.0-gd
  php7.0-json php7.0-mbstring php7.0-mcrypt php7.0-mysql php7.0-opcache
  php7.0-readline php7.0-xml php7.0-zip printer-driver-hpcups
  printer-driver-hpijs printer-driver-postscript-hp publicsuffix python
  python-certifi python-crypto python-dbus python-debianbts python-gi
  python-gi-cairo python-gobject python-ldb python-libxml2 python-lxml
  python-minimal python-numpy python-pil python-pkg-resources python-samba
  python-setuptools python-sip python-talloc python-tdb python-xapian
  python2.7 python2.7-minimal python3 python3-certifi python3-dbus
  python3-debianbts python3-gi python3-gi-cairo python3-minimal python3-pil
  python3-pkg-resources python3.5 python3.5-minimal qt-at-spi qtchooser
  qttranslations5-l10n rpm-common rpm2cpio rtcw-common samba-common
  samba-common-bin samba-libs smbclient sparky-artwork sparky-core
  sparky-core-x86 sparky-info sparky-plymouth startpar syslinux
  syslinux-common t1utils task-english task-laptop tasksel tasksel-data tcpd
  tzdata udisks2 ufraw-batch va-driver-all va-driver-all:i386 vapoursynth
  vdpau-va-driver vdpau-va-driver:i386 vlc-bin vlc-data vlc-l10n
  vlc-plugin-base vlc-plugin-notify vlc-plugin-samba vlc-plugin-video-output
  vlc-plugin-video-splitter vlc-plugin-visualization wamerican wget wine
  wine32:i386 wine64 winetricks xdg-utils
510 upgraded, 44 newly installed, 128 to remove and 1 not upgraded.
Need to get 868 MB/877 MB of archives.
After this operation, 373 MB disk space will be freed.
Do you want to continue? [Y/n]
« Last Edit: November 19, 2017, 10:38:40 am by 21grams »
21grams >> light in flight

Offline bardo

  • Newbie
  • *
  • Posts: 16
  • PM by PGP encryption preferred
Re: dist-upgrade wants to remove what?
« Reply #1 on: November 18, 2017, 06:54:25 am »
Hi,

i am new to the forum... but:
This is looking like normal behavior when the system is going (or went) through a major upgrade like from jessie to stretch.
From my own experience, i did have problems after executing this. So i would recommend to properly backup before or to create a "playground a.k.a. copied environment" in order to examine its effect prior to making it happen.
In my case, i was able to identify ONE (yes, only one) package, that led to unwanted removal(s) and by marking it as "manually installed", i could execute the autoremove afterwards without the mess, i had seen during my first attempt.

Good to see, you are taking care of your installation in a responsible manner. I think, only few users are aware of the admins responsabilities, they are taking, when they adopt a linux system.

Good luck!

Offline 21grams

  • Newbie
  • *
  • Posts: 7
Re: dist-upgrade wants to remove what?
« Reply #2 on: November 18, 2017, 09:41:21 am »
Indeed bardo, wise to have backups and trial out which I do, did and neglected to add. The outcome was more than a handful to negotiate with graphics, mate-desktop (where I started to reinstall), caja, atril, virtualbox ... .
Perhaps I change from MATE which ran into problems about this time last year and keep trying. This almost looks like a similar issue with https://sparkylinux.org/forum/index.php/topic,4180.0.html

Anyway, thanks for the good luck.  :)
« Last Edit: November 18, 2017, 09:43:54 am by 21grams »
21grams >> light in flight

Offline blaze

  • Full Member
  • ***
  • Posts: 125
  • blazing away
Re: dist-upgrade wants to remove what?
« Reply #3 on: November 18, 2017, 10:05:45 am »
Sometimes one just have to stay  8) and wait it out.
Unstable OpenBoxer

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1722
    • SparkyLinux
Re: dist-upgrade wants to remove what?
« Reply #4 on: November 18, 2017, 01:50:16 pm »
Make safe upgrade as the first:
Code: [Select]
sudo apt-get update
sudo apt-get upgrade
One of the packages is keeping back, so if you don't need it, just try to remove:
Code: [Select]
sudo apt-get purge ibmikmod3
sudo apt-get autoremove
then refresh package list and try to make dist-upgrade again.
Show your output if still problem exist.
« Last Edit: November 18, 2017, 01:52:03 pm by pavroo »
Nothing is easy as it looks.
Danielle Steel

Offline 21grams

  • Newbie
  • *
  • Posts: 7
Re: dist-upgrade wants to remove what?
« Reply #5 on: November 18, 2017, 09:54:52 pm »
Hello pavroo and thanks for your time.

Here is the output :
Code: [Select]
me@sparky:~$ sudo apt-get purge libmikmod3
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following package was automatically installed and is no longer required:
  libsdl-net1.2
Use 'sudo apt autoremove' to remove it.
The following packages will be REMOVED:
  dosbox* libmikmod3* libsdl-sound1.2*
0 upgraded, 0 newly installed, 3 to remove and 125 not upgraded.
After this operation, 3,294 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 219435 files and directories currently installed.)
Removing dosbox (0.74-4.3) ...
Removing libsdl-sound1.2:amd64 (1.0.3-8) ...
Removing libmikmod3:amd64 (3.3.11.1-3) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for desktop-file-utils (0.23-2) ...
Processing triggers for libc-bin (2.24-17) ...
Processing triggers for man-db (2.7.6.1-2) ...
Processing triggers for hicolor-icon-theme (0.17-1) ...
me@sparky:~$ sudo apt-get autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  libsdl-net1.2
0 upgraded, 0 newly installed, 1 to remove and 125 not upgraded.
After this operation, 43.0 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 219402 files and directories currently installed.)
Removing libsdl-net1.2:amd64 (1.2.8-5) ...
Processing triggers for libc-bin (2.24-17) ...
me@sparky:~$ sudo apt-get update
Hit:1 http://mariadb.mirror.digitalpacific.com.au/repo/10.2/debian stretch InRelease
Ign:2 http://dl.google.com/linux/chrome/deb stable InRelease                   
Hit:3 http://repo.steampowered.com/steam precise InRelease                     
Hit:4 http://security.debian.org testing/updates InRelease                     
Hit:5 http://ftp.us.debian.org/debian testing InRelease                       
Hit:6 http://download.virtualbox.org/virtualbox/debian stretch InRelease       
Hit:7 http://dl.google.com/linux/chrome/deb stable Release                     
Hit:9 https://sparkylinux.org/repo testing InRelease                           
Hit:10 http://www.deb-multimedia.org testing InRelease
Reading package lists... Done
me@sparky:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  atril-common avidemux-common avidemux-plugins compton conky conky-std
  dctrl-tools engrampa engrampa-common eom-common fonts-dejavu
  fonts-freefont-ttf fonts-mathjax freepats game-data-packager
  game-data-packager-runtime geoclue-2.0 gir1.2-javascriptcoregtk-3.0
  gir1.2-javascriptcoregtk-4.0 gir1.2-keybinder-3.0 gir1.2-peas-1.0
  gir1.2-soup-2.4 gstreamer1.0-libav gstreamer1.0-nice iio-sensor-proxy
  ioquake3-server libaften0 libbasicusageenvironment1 libbind9-140 libcddb2
  libcdio-cdda2 libcdio-paranoia2 libconfig9 libdc1394-22 libdca0
  libdns-export162 libdns162 libdouble-conversion1 libdvbpsi10 libebml4v5
  libegl-nvidia0:i386 libexempi3 libfaad2 libflite1 libfluidsynth1 libfs6
  libgadu3 libgbm1 libgeoclue-2-0 libgl1-nvidia-glx libgles-nvidia1
  libgles-nvidia1:i386 libgles-nvidia2 libgles1-glvnd-nvidia
  libgles1-glvnd-nvidia:i386 libgles2 libgles2-mesa libgroupsock8 libgtkspell0
  libgxps2 libharfbuzz-icu0 libhyphen0 libisc-export160 libisc160 libisccfg140
  libiso9660-10 libjavascriptcoregtk-1.0-0 libjavascriptcoregtk-3.0-0
  libjavascriptcoregtk-4.0-18 libjs-mathjax libkate1 libkeybinder-3.0-0
  libkpathsea6 liblavfile-2.1-0 liblavjpeg-2.1-0 liblavplay-2.1-0 liblilv-0-0
  liblirc-client0 liblivemedia58 libllvm3.9 libllvm3.9:i386 liblua5.1-0
  libmatroska6v5 libmeanwhile1 libmms0 libmodplug1 libmp4v2-2 libmpcdec6
  libmuparser2v5 libnvidia-cfg1 libnvidia-cfg1:i386 libnvidia-eglcore:i386
  libofa0 libopenh264-2 libopenh264-2:i386 libopusfile0 libprotobuf-c1
  libproxy-tools libpython3.5 libpython3.5-minimal libpython3.5-stdlib
  libqt4-declarative libqt4-designer libqt4-help libqt4-script
  libqt4-scripttools libqt4-sql libqt4-sql-mysql libqt4-test
  libqt4-xmlpatterns libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5network5
  libqt5qml5 libqt5script5 libqt5sql5 libqt5sql5-sqlite libqt5xml5
  libqtassistantclient4 libquicktime2 librecad-data libresid-builder0c2a
  librpm3 librpm8 librpmio3 librpmio8 libsbc1 libsdl-image1.2 libsdl-ttf2.0-0
  libserd-0-0 libsidplay2 libsord-0-0 libsoundtouch1 libspandsp2 libspectre1
  libsratom-0-0 libsrtp0 libuchardet0 libupnp6 libusageenvironment3 libva-drm1
  libva-drm1:i386 libva-wayland1 libva-x11-1 libva-x11-1:i386 libva1:i386
  libvcdinfo0 libvidstab1.0 libvlc-bin libvlc5 libvlccore8 libvo-aacenc0
  libwayland-server0 libwildmidi-config libwildmidi2 libx264-150
  libx264-150:i386 libx265-116:i386 libx265-116 libxatracker2 libxcb-xinerama0
  libxkbcommon-x11-0 libxnvctrl0 libxvmc1 libzbar0 libzephyr4 libzimg2
  liferea-data mate-backgrounds mjpegtools nvidia-driver-bin
  nvidia-persistenced nvidia-settings openarena-081-maps openarena-081-misc
  openarena-081-players openarena-081-players-mature openarena-081-textures
  openarena-085-data openarena-088-data openarena-data openarena-oacmp1
  pidgin-data python-glade2 python-gst0.10 python-jinja2 python-libturpial
  python-libxml2 python-markupsafe python-oauth python-qt4 python-simplejson
  python-sip python3-yaml python3.5 python3.5-minimal qttranslations5-l10n
  rpm-common rpm2cpio rtcw-common sparky-desktop-data sparky-editor
  sparky-xterm ssft timidity timidity-daemon twolame ufw vapoursynth vlc-bin
  vlc-data vlc-l10n vlc-plugin-base vlc-plugin-notify vlc-plugin-samba
  vlc-plugin-video-output vlc-plugin-video-splitter vlc-plugin-visualization
  vrms x11-apps x11-session-utils x11-xfs-utils xfonts-100dpi xfonts-75dpi
  xfonts-scalable xinit xserver-xorg-legacy yelp-xsl zenity-common
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  atril avidemux avidemux-qt caja ddm dooble eom ffmpeg gir1.2-webkit-3.0
  gir1.2-webkit2-4.0 gnuplot-qt gstreamer1.0-plugins-bad gufw gzdoom ioquake3
  libatrildocument3 libatrilview3 libavdevice57 libegl1-glvnd-nvidia
  libegl1-glvnd-nvidia:i386 libegl1-mesa libfarstream-0.2-5 libgail-3-0
  libgl1-mesa-glx libgles-nvidia2:i386 libgles2-glvnd-nvidia
  libgles2-glvnd-nvidia:i386 libglvnd0-nvidia libglvnd0-nvidia:i386
  libglx0-glvnd-nvidia libglx0-glvnd-nvidia:i386 libgstreamer-plugins-bad1.0-0
  libgtk-3-bin libopengl0-glvnd-nvidia libopengl0-glvnd-nvidia:i386
  libpurple-bin libpurple0 libqt5gui5 libqt5opengl5 libqt5printsupport5
  libqt5quick5 libqt5svg5 libqt5webkit5 libqt5widgets5 libqt5x11extras5
  librecad libsdl2-2.0-0 libwebkit2gtk-4.0-37 libwebkit2gtk-4.0-37-gtk2
  libwebkitgtk-1.0-0 libwebkitgtk-3.0-0 libyelp0 liferea marco mate-core
  mate-desktop-environment-core mate-user-guide mpv nvidia-driver
  nvidia-driver-libs nvidia-driver-libs:i386 nvidia-driver-libs-i386:i386
  nvidia-egl-icd:i386 openarena pidgin pidgin-lastfm pidgin-microblog
  pidgin-musictracker pidgin-twitter python-webkit qt5-gtk-platformtheme
  quake3 radiotray rtcw smplayer smplayer-l10n smplayer-themes sparky-about
  sparky-aptus sparky-aptus-extra sparky-aptus-upgrade sparky-codecs
  sparky-compton sparky-conky sparky-desktop sparky-gufw
  sparky-live-usb-creator sparky-office sparky-usb-formatter sparky-wine
  steam-launcher task-desktop turpial virtualbox-5.1 vlc vlc-plugin-qt
  vlc-plugin-skins2 xorg xserver-xorg xserver-xorg-core xserver-xorg-input-all
  xserver-xorg-input-evdev xserver-xorg-input-libinput
  xserver-xorg-input-mouse xserver-xorg-input-synaptics
  xserver-xorg-input-wacom xserver-xorg-video-all xserver-xorg-video-amdgpu
  xserver-xorg-video-ati xserver-xorg-video-cirrus xserver-xorg-video-fbdev
  xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
  xserver-xorg-video-neomagic xserver-xorg-video-nouveau
  xserver-xorg-video-nvidia xserver-xorg-video-r128 xserver-xorg-video-radeon
  xserver-xorg-video-savage xserver-xorg-video-tdfx xserver-xorg-video-trident
  xserver-xorg-video-vesa xserver-xorg-video-vmware yad yelp zenity
The following NEW packages will be installed:
  e2fsprogs-l10n gnuplot-x11 libbind9-141 libdata-dump-perl libdns-export190
  libdns190 libegl1 libgl1 libgl1:i386 libgles2 libglvnd0 libglvnd0:i386
  libglx-mesa0 libglx-mesa0:i386 libglx0 libglx0:i386 libisc-export189
  libisc189 libisccfg144 libjson-c3 libllvm5.0 libllvm5.0:i386 libomp5
  libopenh264-4:i386 libpython3.6 libpython3.6-minimal libpython3.6-stdlib
  librpm8 librpmio8 libtry-tiny-perl libva-drm2 libva-drm2:i386 libva-x11-2
  libva-x11-2:i386 libva2 libva2:i386 libvidstab1.1 libwebp6:i386
  libwebpmux3:i386 libx264-152:i386 libx265-130:i386 libxcb-xfixes0:i386
  python3-debconf python3.6 python3.6-minimal
The following packages will be upgraded:
  avidemux-plugins bind9-host debconf debconf-i18n dnsutils e2fslibs e2fsprogs
  fuse2fs gir1.2-javascriptcoregtk-4.0 hexchat-python3 hplip hplip-data
  i965-va-driver i965-va-driver:i386 isc-dhcp-client libavcodec57
  libavcodec57:i386 libavfilter6 libavformat57 libavresample3
  libavresample3:i386 libavutil55 libavutil55:i386 libegl-nvidia0
  libegl-nvidia0:i386 libgbm1 libgegl-0.3-0 libgl1-mesa-dri
  libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libgl1-nvidia-glx
  libgl1-nvidia-glx:i386 libglapi-mesa libglapi-mesa:i386 libgles-nvidia1
  libgles-nvidia1:i386 libgles-nvidia2 libgles1-glvnd-nvidia
  libgles1-glvnd-nvidia:i386 libgles2-mesa libglx-nvidia0 libglx-nvidia0:i386
  libhpmud0 libisccc140 libjavascriptcoregtk-4.0-18 liblwres141 libmfx0
  libmfx0:i386 libnvidia-cfg1 libnvidia-cfg1:i386 libnvidia-eglcore
  libnvidia-eglcore:i386 libnvidia-glcore libnvidia-glcore:i386 libnvidia-ml1
  libosmesa6 libosmesa6:i386 libpeas-1.0-0 libpostproc54 libpython3-stdlib
  libsane-hpaio libswresample2 libswresample2:i386 libswscale4 libvlc-bin
  libvlc5 libvlccore8 libwayland-egl1-mesa libwww-perl libxatracker2
  mesa-vdpau-drivers mesa-vdpau-drivers:i386 nvidia-alternative:i386
  nvidia-driver-bin nvidia-egl-icd nvidia-kernel-support nvidia-smi
  nvidia-vdpau-driver printer-driver-hpcups printer-driver-hpijs
  printer-driver-postscript-hp python3 python3-dbus python3-gi
  python3-gi-cairo python3-minimal rpm-common rpm2cpio vapoursynth
  vdpau-va-driver vdpau-va-driver:i386 vlc-bin vlc-data vlc-l10n
  vlc-plugin-base vlc-plugin-notify vlc-plugin-samba vlc-plugin-video-output
  vlc-plugin-video-splitter vlc-plugin-visualization
100 upgraded, 45 newly installed, 127 to remove and 0 not upgraded.
Need to get 143 MB/145 MB of archives.
After this operation, 375 MB disk space will be freed.
Do you want to continue? [Y/n]
21grams >> light in flight

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1722
    • SparkyLinux
Re: dist-upgrade wants to remove what?
« Reply #6 on: November 18, 2017, 10:53:59 pm »
If i remember well, there was a conflict between the same packages in Debian's main and multimedia repos.
Disable multimedia and  sparky repos (and any you have active, excluding debian's main, contrib and non-free).
Disable multimedia repos:
Code: [Select]
sudo nano /etc/apt/sources.listand put # in the front of multimedia repos.
Disable sparky repos:
Code: [Select]
sudo nano /etc/apt/sources.list.d/sparky-testing.listand put # in the front of both sparky repos lines.
If youhave other repos active - disable them in the same way, then:
Code: [Select]
sudo apt-get update
sudo apt-get dist-upgrade
If still problem, show the last output, and:
Code: [Select]
apt-cache policy gstreamer1.0-*
« Last Edit: November 18, 2017, 10:55:34 pm by pavroo »
Nothing is easy as it looks.
Danielle Steel

Offline Wombat

  • Newbie
  • *
  • Posts: 29
Re: dist-upgrade wants to remove what?
« Reply #7 on: November 19, 2017, 01:34:12 am »
21grams-

Encountered similar problems with 3 of our pc's, all running sparkykde64 after last month's upgrades. 2 fixed (sparkykde64) from following suggestions from pavroo and others here. The 3rd continued with the dependency issues and since 'sudo apt-get autoremove' buggered everything further so decided to install sparky multimedia amd64, SparkyKDEamd64 is no longer available......but after a couple of days decided against a OpenBox future and return to my preferred sparkykde just by upgrading. Managed to now have everything running ok.

The following issues may assist-

Repos are still as original- sparky 'd'
Quote
deb https://sparkylinux.org/repo/ testing main
deb-src https://sparkylinux.org/repo/ testing main

and main

Quote
deb http://ftp.debian.org/debian/ testing non-free contrib main
deb-src http://ftp.debian.org/debian/ testing main contrib non-free 
deb http://security.debian.org/ testing/updates non-free contrib main
deb-src http://security.debian.org/ testing/updates non-free contrib main
deb http://www.deb-multimedia.org/ testing non-free main

Upgrading through the Sparky Aptus desktop installer didn't initially work, used Synaptic to install kde-full.....still unable to see any options on reboot...the openbox logout feature seems to have problems. Went back and tried installing SparkyKde though Sparky Aptus. This time it came up reporting success however still left with no options.

Added # to auto login in the lightdm.config file...still logging in automatically to openbox.

Installed SDDM and fully removed LightDm via synaptic. On reboot log in with root and password and enter sddm at the next curser prompt this led to a different screen with a OpenBox or Plasma option. The Plasma option started KDE but then halted....couldn't find any simple way to configure sddm so re-installed light-dm through synaptic using the OpenBox option after another reboot. Rebooted again and selected the plasma option that still remained which ran through to the new KDE desktop and now KDE just opens normally using lightdm.

....left out numerous package fixes through aptus and synaptic....maybe the dependency issues were fixed during a upgrade?

NB -Since added the latest kernel

The sparky unstable repo...

Quote
deb http://sparkylinux.org/repo/ unstable main
deb-src http://sparkylinux.org/repo/ unstable main







« Last Edit: November 19, 2017, 02:18:33 am by Wombat »

Offline 21grams

  • Newbie
  • *
  • Posts: 7
Re: dist-upgrade wants to remove what?
« Reply #8 on: November 19, 2017, 02:54:30 am »
Thanks pavroo .. Have tagged multimedia, sparky testing, mariadb, virtualbox, google-chrome and steam to give only security and debian testing a clear run.

output as follows:
Code: [Select]
me@sparky:~$ sudo apt-get update
[sudo] password for me:
Hit:1 http://ftp.us.debian.org/debian testing InRelease                     
Hit:2 http://security.debian.org testing/updates InRelease                   
Reading package lists... Done
me@sparky:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  atril-common avidemux-common avidemux-plugins compton conky conky-std
  dctrl-tools engrampa engrampa-common fonts-dejavu fonts-freefont-ttf
  fonts-mathjax freepats game-data-packager game-data-packager-runtime
  geoclue-2.0 gir1.2-javascriptcoregtk-3.0 gir1.2-javascriptcoregtk-4.0
  gir1.2-keybinder-3.0 gir1.2-peas-1.0 gir1.2-soup-2.4 gstreamer1.0-libav
  gstreamer1.0-nice iio-sensor-proxy ioquake3-server libaften0
  libbasicusageenvironment1 libbind9-140 libcddb2 libcdio-cdda2
  libcdio-paranoia2 libconfig9 libdc1394-22 libdca0 libdns-export162 libdns162
  libdouble-conversion1 libdvbpsi10 libebml4v5 libegl-nvidia0:i386 libfaad2
  libflite1 libfluidsynth1 libfs6 libgadu3 libgbm1 libgeoclue-2-0
  libgl1-nvidia-glx libgles-nvidia1 libgles-nvidia1:i386 libgles-nvidia2
  libgles1-glvnd-nvidia libgles1-glvnd-nvidia:i386 libgles2 libgroupsock8
  libgtkspell0 libgxps2 libharfbuzz-icu0 libhyphen0 libisc-export160 libisc160
  libisccfg140 libiso9660-10 libjavascriptcoregtk-1.0-0
  libjavascriptcoregtk-3.0-0 libjavascriptcoregtk-4.0-18 libjs-mathjax
  libkate1 libkeybinder-3.0-0 libkpathsea6 liblavfile-2.1-0 liblavjpeg-2.1-0
  liblavplay-2.1-0 liblilv-0-0 liblirc-client0 liblivemedia58 libllvm3.9
  libllvm3.9:i386 liblua5.1-0 libmatroska6v5 libmeanwhile1 libmms0 libmodplug1
  libmp4v2-2 libmpcdec6 libmuparser2v5 libnvidia-cfg1 libnvidia-cfg1:i386
  libnvidia-eglcore:i386 libofa0 libopenh264-4 libopusfile0 libprotobuf-c1
  libproxy-tools libpython3.5 libpython3.5-minimal libpython3.5-stdlib
  libqt4-declarative libqt4-designer libqt4-help libqt4-script
  libqt4-scripttools libqt4-sql libqt4-sql-mysql libqt4-test
  libqt4-xmlpatterns libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5network5
  libqt5qml5 libqt5script5 libqt5sql5 libqt5sql5-sqlite libqt5xml5
  libqtassistantclient4 libquicktime2 librecad-data libresid-builder0c2a
  librpm3 librpm8 librpmio3 librpmio8 libsbc1 libsdl-image1.2 libsdl-ttf2.0-0
  libserd-0-0 libsidplay2 libsord-0-0 libsoundtouch1 libspandsp2 libspectre1
  libsratom-0-0 libsrtp0 libuchardet0 libupnp6 libusageenvironment3
  libva-wayland1 libvcdinfo0 libvlc-bin libvlc5 libvlccore8 libvo-aacenc0
  libwayland-server0 libwildmidi-config libwildmidi2 libxatracker2
  libxcb-xinerama0 libxkbcommon-x11-0 libxnvctrl0 libxvmc1 libzbar0 libzephyr4
  libzimg2 liferea-data mate-backgrounds mjpegtools nvidia-driver-bin
  nvidia-persistenced nvidia-settings openarena-081-maps openarena-081-misc
  openarena-081-players openarena-081-players-mature openarena-081-textures
  openarena-085-data openarena-088-data openarena-data openarena-oacmp1
  pidgin-data python-glade2 python-gst0.10 python-jinja2 python-libturpial
  python-libxml2 python-markupsafe python-oauth python-qt4 python-simplejson
  python-sip python3-yaml python3.5 python3.5-minimal qttranslations5-l10n
  rpm-common rpm2cpio rtcw-common sparky-desktop-data sparky-editor
  sparky-xterm ssft timidity timidity-daemon twolame ufw vlc-bin vlc-data
  vlc-l10n vlc-plugin-base vlc-plugin-notify vlc-plugin-qt vlc-plugin-samba
  vlc-plugin-skins2 vlc-plugin-video-splitter vlc-plugin-visualization vrms
  x11-apps x11-session-utils x11-xfs-utils xfonts-100dpi xfonts-75dpi
  xfonts-scalable xinit xserver-xorg-legacy yelp-xsl zenity-common
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  atril avidemux avidemux-qt caja ddm dooble ffmpeg gir1.2-webkit-3.0
  gir1.2-webkit2-4.0 gnuplot-qt gstreamer1.0-plugins-bad gufw gzdoom ioquake3
  libatrildocument3 libatrilview3 libavdevice57 libegl1-glvnd-nvidia
  libegl1-glvnd-nvidia:i386 libegl1-mesa libfarstream-0.2-5 libgail-3-0
  libgles-nvidia2:i386 libgles2-glvnd-nvidia libgles2-glvnd-nvidia:i386
  libgles2-mesa libglvnd0-nvidia libglvnd0-nvidia:i386 libglx0-glvnd-nvidia
  libglx0-glvnd-nvidia:i386 libgstreamer-plugins-bad1.0-0 libgtk-3-bin
  libopengl0-glvnd-nvidia libopengl0-glvnd-nvidia:i386 libpurple-bin
  libpurple0 libqt5gui5 libqt5opengl5 libqt5printsupport5 libqt5quick5
  libqt5svg5 libqt5webkit5 libqt5widgets5 libqt5x11extras5 librecad
  libsdl2-2.0-0 libwebkit2gtk-4.0-37 libwebkit2gtk-4.0-37-gtk2
  libwebkitgtk-1.0-0 libwebkitgtk-3.0-0 libyelp0 liferea marco mate-core
  mate-desktop-environment-core mate-user-guide mpv nvidia-driver
  nvidia-driver-libs nvidia-driver-libs:i386 nvidia-driver-libs-i386:i386
  nvidia-egl-icd:i386 openarena pidgin pidgin-lastfm pidgin-microblog
  pidgin-musictracker pidgin-twitter python-webkit qt5-gtk-platformtheme
  quake3 radiotray rtcw smplayer smplayer-l10n smplayer-themes sparky-about
  sparky-aptus sparky-aptus-extra sparky-aptus-upgrade sparky-codecs
  sparky-compton sparky-conky sparky-desktop sparky-gufw
  sparky-live-usb-creator sparky-office sparky-usb-formatter sparky-wine
  steam-launcher task-desktop turpial vapoursynth virtualbox-5.1 vlc
  vlc-plugin-video-output xorg xserver-xorg xserver-xorg-core
  xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-libinput
  xserver-xorg-input-mouse xserver-xorg-input-synaptics
  xserver-xorg-input-wacom xserver-xorg-video-all xserver-xorg-video-amdgpu
  xserver-xorg-video-ati xserver-xorg-video-cirrus xserver-xorg-video-fbdev
  xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
  xserver-xorg-video-neomagic xserver-xorg-video-nouveau
  xserver-xorg-video-nvidia xserver-xorg-video-r128 xserver-xorg-video-radeon
  xserver-xorg-video-savage xserver-xorg-video-tdfx xserver-xorg-video-trident
  xserver-xorg-video-vesa xserver-xorg-video-vmware yad yelp zenity
The following NEW packages will be installed:
  e2fsprogs-l10n gnuplot-x11 libbind9-141 libdata-dump-perl libdns-export190
  libdns190 libegl1 libgl1 libgl1:i386 libgles2 libglvnd0 libglvnd0:i386
  libglx-mesa0 libglx-mesa0:i386 libglx0 libglx0:i386 libisc-export189
  libisc189 libisccfg144 libjson-c3 libllvm5.0 libllvm5.0:i386 libpython3.6
  libpython3.6-minimal libpython3.6-stdlib librpm8 librpmio8 libtry-tiny-perl
  libva2 libva2:i386 libxcb-xfixes0:i386 python3-debconf python3.6
  python3.6-minimal
The following packages will be upgraded:
  bind9-host debconf debconf-i18n dnsutils e2fslibs e2fsprogs fuse2fs
  gir1.2-javascriptcoregtk-4.0 hexchat-python3 hplip hplip-data i965-va-driver
  i965-va-driver:i386 isc-dhcp-client libegl-nvidia0 libegl-nvidia0:i386
  libgbm1 libgl1-mesa-dri libgl1-mesa-dri:i386 libgl1-mesa-glx
  libgl1-mesa-glx:i386 libgl1-nvidia-glx libgl1-nvidia-glx:i386 libglapi-mesa
  libglapi-mesa:i386 libgles-nvidia1 libgles-nvidia1:i386 libgles-nvidia2
  libgles1-glvnd-nvidia libgles1-glvnd-nvidia:i386 libglx-nvidia0
  libglx-nvidia0:i386 libhpmud0 libisccc140 libjavascriptcoregtk-4.0-18
  liblwres141 libnvidia-cfg1 libnvidia-cfg1:i386 libnvidia-eglcore
  libnvidia-eglcore:i386 libnvidia-glcore libnvidia-glcore:i386 libnvidia-ml1
  libosmesa6 libosmesa6:i386 libpeas-1.0-0 libpython3-stdlib libsane-hpaio
  libwayland-egl1-mesa libwww-perl libxatracker2 mesa-vdpau-drivers
  mesa-vdpau-drivers:i386 nvidia-alternative:i386 nvidia-driver-bin
  nvidia-egl-icd nvidia-kernel-support nvidia-smi nvidia-vdpau-driver
  printer-driver-hpcups printer-driver-hpijs printer-driver-postscript-hp
  python3 python3-dbus python3-gi python3-gi-cairo python3-minimal rpm-common
  rpm2cpio
69 upgraded, 34 newly installed, 126 to remove and 0 not upgraded.
Need to get 116 MB/116 MB of archives.
After this operation, 382 MB disk space will be freed.
Do you want to continue? [Y/n]

apt-cache policy gstreamer1.0-*:
Code: [Select]
me@sparky:~$ apt-cache policy gstreamer1.0-*
gstreamer1.0-plugins-ugly-amr:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer1.0-videosink:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer1.0-alsa:
  Installed: (none)
  Candidate: 1.12.3-1
  Version table:
     1.12.3-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-plugins-ugly-dbg:
  Installed: (none)
  Candidate: 1.12.3-1
  Version table:
     1.12.3-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-plugins-mpeg2enc:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer1.0-plugins-ugly-doc:
  Installed: (none)
  Candidate: 1.12.3-1
  Version table:
     1.12.3-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
        500 http://ftp.us.debian.org/debian testing/main i386 Packages
gstreamer1.0-plugins-base-apps:
  Installed: (none)
  Candidate: 1.12.3-1
  Version table:
     1.12.3-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-rtsp-dbg:
  Installed: (none)
  Candidate: 1.12.3-1
  Version table:
     1.12.3-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-plugins-faac:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer1.0-tools:
  Installed: (none)
  Candidate: 1.12.3-1
  Version table:
     1.12.3-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-plugins-good:
  Installed: 1.12.3-1
  Candidate: 1.12.3-1
  Version table:
 *** 1.12.3-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
        100 /var/lib/dpkg/status
gstreamer1.0-qapt:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer1.0-espeak:
  Installed: (none)
  Candidate: 0.4.0-3
  Version table:
     0.4.0-3 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-nice:
  Installed: 0.1.14-1
  Candidate: 0.1.14-1
  Version table:
 *** 0.1.14-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
        100 /var/lib/dpkg/status
gstreamer1.0-videosource:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer1.0-crystalhd:
  Installed: (none)
  Candidate: 1:0.0~git20110715.fdd2f19-12
  Version table:
     1:0.0~git20110715.fdd2f19-12 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-fluendo-mp3:
  Installed: (none)
  Candidate: 0.10.32.debian-1
  Version table:
     0.10.32.debian-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-rtsp:
  Installed: (none)
  Candidate: 1.12.3-1
  Version table:
     1.12.3-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-plugins-bad:
  Installed: 1:1.12.2-dmo1
  Candidate: 1:1.12.2-dmo1
  Version table:
 *** 1:1.12.2-dmo1 100
        100 /var/lib/dpkg/status
     1.12.3-2 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-plugins-base:
  Installed: 1.12.3-1
  Candidate: 1.12.3-1
  Version table:
 *** 1.12.3-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
        100 /var/lib/dpkg/status
gstreamer1.0-audiosource:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer1.0-plugins-bad-videoparsers:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer1.0-plugins-really-bad:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer1.0-pulseaudio:
  Installed: 1.12.3-1
  Candidate: 1.12.3-1
  Version table:
 *** 1.12.3-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
        100 /var/lib/dpkg/status
gstreamer1.0-pocketsphinx:
  Installed: (none)
  Candidate: 0.8+5prealpha-2+b1
  Version table:
     0.8+5prealpha-2+b1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-plugins-bad-dbg:
  Installed: (none)
  Candidate: 1.12.3-2
  Version table:
     1.12.3-2 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-plugins-bad-doc:
  Installed: (none)
  Candidate: 1.12.3-2
  Version table:
     1.12.3-2 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
        500 http://ftp.us.debian.org/debian testing/main i386 Packages
gstreamer1.0-visualization:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer1.0-plugins-bad-faad:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer1.0-omx-generic:
  Installed: (none)
  Candidate: 1.12.3-2
  Version table:
     1.12.3-2 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-lame:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer1.0-x:
  Installed: 1.12.3-1
  Candidate: 1.12.3-1
  Version table:
 *** 1.12.3-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
        100 /var/lib/dpkg/status
gstreamer1.0-vaapi-doc:
  Installed: (none)
  Candidate: 1.12.3-2
  Version table:
     1.12.3-2 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
        500 http://ftp.us.debian.org/debian testing/main i386 Packages
gstreamer1.0-omx-generic-config:
  Installed: (none)
  Candidate: 1.12.3-2
  Version table:
     1.12.3-2 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-libav:
  Installed: 1:1.12.3-dmo1
  Candidate: 1:1.12.3-dmo1
  Version table:
 *** 1:1.12.3-dmo1 100
        100 /var/lib/dpkg/status
     1.12.3-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-plugins-base-dbg:
  Installed: (none)
  Candidate: 1.12.3-1
  Version table:
     1.12.3-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-plugins-good-dbg:
  Installed: (none)
  Candidate: 1.12.3-1
  Version table:
     1.12.3-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-plugins-base-doc:
  Installed: (none)
  Candidate: 1.12.3-1
  Version table:
     1.12.3-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
        500 http://ftp.us.debian.org/debian testing/main i386 Packages
gstreamer1.0-plugins-good-doc:
  Installed: (none)
  Candidate: 1.12.3-1
  Version table:
     1.12.3-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
        500 http://ftp.us.debian.org/debian testing/main i386 Packages
gstreamer1.0-clutter-3.0:
  Installed: (none)
  Candidate: 3.0.24-1
  Version table:
     3.0.24-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-vaapi:
  Installed: (none)
  Candidate: 1.12.3-2+b1
  Version table:
     1.12.3-2+b1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-libav-dbg:
  Installed: (none)
  Candidate: 1.12.3-1
  Version table:
     1.12.3-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-packagekit:
  Installed: (none)
  Candidate: 1.1.7-1
  Version table:
     1.1.7-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-omx-bellagio-config:
  Installed: (none)
  Candidate: 1.12.3-2
  Version table:
     1.12.3-2 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-ffmpeg:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer1.0-plugins-ugly:
  Installed: 1:1.12.3-dmo1
  Candidate: 1:1.12.3-dmo1
  Version table:
 *** 1:1.12.3-dmo1 100
        100 /var/lib/dpkg/status
     1.12.3-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
gstreamer1.0-doc:
  Installed: (none)
  Candidate: 1.12.3-1
  Version table:
     1.12.3-1 500
        500 http://ftp.us.debian.org/debian testing/main amd64 Packages
        500 http://ftp.us.debian.org/debian testing/main i386 Packages
gstreamer1.0-audiosink:
  Installed: (none)
  Candidate: (none)
  Version table:
me@sparky:~$

Thanks for the heads up Wombat.
21grams >> light in flight

Offline 21grams

  • Newbie
  • *
  • Posts: 7
Re: dist-upgrade wants to remove what?
« Reply #9 on: November 19, 2017, 10:38:08 am »
Yeah.  :) Webmin came to the rescue.
Found that gnuplot had unmet dependencies (-nox, -qt and -x11 would not work together). An old plotting program I used a while back.
Next was libegl1-mesa (libegl1 and libgstreamer-plugins-bad1.0-0 (<1.12.4 but 1:1.12.2-dmo1 was to be installed)
which in turn libwebkit2gtk-4.0.37 and -gtk2 depended upon.

Removed the broken packages and additional files and configurations and dist-upgrade behaved normally.

Thanks for the help and continued enthusiasm has been restored.
21grams >> light in flight