Author Topic: [SOLVED] 2 problems. Resume/Suspend device and old keyboard i boot  (Read 154 times)

Offline penguin

  • Newbie
  • *
  • Posts: 27
First problem :

when I boot in my laptop, laptop hangs on the boot and a message shows : "Gave up waiting for resume/suspend device"

I checked swap UUID in fstab and this UUID I put into /etc/initramfs-tools/conf.d/resume
After , I executed in terminal sudo update-initramfs -u
I gave message : cryptsetup: WARNING: found more than one resume device candidate:

One of UUID is the old Swap of Sparky Linux that is installed in my SD Card and I run it to another laptop.From this SD Card I transfered Sparky Linux from my SD Card to my hdd.
The second one is the new Swap UUID of the laptop that I actually run Sparky (from hdd).
I have no idea where Sparky Linux still find this old UUID Swap.

I checked grub ( was a different UUID for swap there ). Also I changed It as required.
After I executed in terminal sudo update-initramfs -u
the same message I get back: cryptsetup: WARNING: found more than one resume device candidate:
Still when I boot laptop hangs on the boot and a message shows : "Gave up waiting for resume/suspend device"

Maybe is much safer to delete resume device from grub ?
Mx Linux has not resume device in the grub lines.

I use a multiboot of Sparky Linux,MX Linux and Windows.

The second problem :
Because the keyboard configuration in the SD Card (that was original installation) was different from the keyboard of laptop that I am working, I changed keyboard to US / on Settings>Keyboards>Layout.

Also 
I edited /etc/vconsole.conf and changed  KEYMAP=us
I configured keyboard by sudo dpkg-reconfigure keyboard-configuration in Terminal / to be sure for configuration
in the terminal I executed localectl set-x11-keymap us / this tricks from Arch Forums an Polish Guy
Setxkbmap -query gives me:
Quote
penguin@penguin-pc:~$ setxkbmap -query
rules:      evdev
model:      pc105
layout:     us
options:    terminate:ctrl_alt_bksp

But in the boot the old keyboard comes back. I can use US keyboard only when I log on to Sparky Linux.

I use xfce desktop.

Any idea?
thnx in advance.

« Last Edit: November 01, 2017, 11:40:03 pm by penguin »

Offline penguin

  • Newbie
  • *
  • Posts: 27
Re: 2 problems. Resume/Suspend device and old keyboard i boot [ SOLVED]
« Reply #1 on: November 01, 2017, 11:32:34 pm »
Gave up waiting for resume/suspend device was resolved.

I generated sudo update-initramfs -u from Mx_Linux because the  grub is installed in his drive ( sparky is installed on the same laptop) but in another hardrive.

uffff ....  sorry to every one. I had the same problem some times ago and I posted this problem on this forum. And ridiculous I have resolved this problem by myself.
seems that I made questions and responding by myself.

Quote
The keyboard problem solved as described in
Code: [Select]
https://github.com/budgie-desktop/budgie-desktop/issues/731
editing file
Code: [Select]
/etc/X11/xorg.conf.d/00-keyboard.conf:

 :D

 
« Last Edit: November 01, 2017, 11:39:37 pm by penguin »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1707
    • SparkyLinux
Nothing is easy as it looks.
Danielle Steel