Author Topic: [SOLVED] Problems with apps post upgrade (27/10/17)  (Read 294 times)

Offline johnh009

  • Newbie
  • *
  • Posts: 33
[SOLVED] Problems with apps post upgrade (27/10/17)
« on: October 28, 2017, 12:23:11 pm »
On rebooting this morning (28/10/17) after upgrading yesterday:

1.  All apps are missing the 3 buttons (hide/minimise-maximise/quit) on the top right corner.
2.  Windows cannot be dragged to reposition.
3.  With more than one app opened, the last one opened stays on top. Cannot access the other open apps by either clicking on them or using Alt/Shift.
« Last Edit: October 28, 2017, 06:20:32 pm by johnh009 »

Offline a2delariva

  • Newbie
  • *
  • Posts: 2
Re: Problems with apps post upgrade (2710/17)
« Reply #1 on: October 28, 2017, 02:40:30 pm »
Hello.
I have the same problem. May be a problem with marco window manager but i don't know how to solve this.
Any one have any idea?
Thanks.

Offline johnh009

  • Newbie
  • *
  • Posts: 33
Re: Problems with apps post upgrade (27/10/17)
« Reply #2 on: October 28, 2017, 06:14:32 pm »
Thanks, a2delriva. A pointer in the right direction I think!

Checked via synaptic as to what version of marco was installed. NOT installed. Attempted to install (in synaptic) which listed a shed load of additional packages to also be installed. Clicked OK and attempted to 'apply', but was informed that there are broken packages!

Have gone thru the commands listed here:

http://sourcedigit.com/21301-fix-broken-packages-ubuntu-terminal-list-broken-packages-ubuntu/

and then attempted to install marco via a terminal. Relevant part of the message:

The following information may help to resolve the situation:

The following packages have unmet dependencies:
 marco : Depends: zenity
E: Unable to correct problems, you have held broken packages.

Attempted to install zenity, which invoked the following:

The following information may help to resolve the situation:

The following packages have unmet dependencies:
 zenity : Depends: libwebkit2gtk-4.0-37 (>= 2.15.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Attempted to install libwebkit2gtk-4.0.37:

john@Sparky:~$ sudo apt-get install libwebkit2gtk-4.0-37
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libwebkit2gtk-4.0-37 : Depends: libgstreamer-plugins-bad1.0-0 (< 1.12.4) but 1:1.12.2-dmo1 is to be installed
E: Unable to correct problems, you have held broken packages.
john@Sparky:~$ sudo apt-get install libgstreamer-plugins-bad1.0-0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libgstreamer-plugins-bad1.0-0 is already the newest version (1:1.12.2-dmo1).
libgstreamer-plugins-bad1.0-0 set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
john@Sparky:~$

By forcing the latest version of libgstreamer-plugins-bad1.0-0 via synaptic, I could then work backwards and install everything else. Now going to reboot!!

Have now rebooted and everything appears to work as normal. I will mark as 'solved'.
« Last Edit: October 28, 2017, 06:20:03 pm by johnh009 »

Offline kd0rg

  • Newbie
  • *
  • Posts: 1
Re: [SOLVED] Problems with apps post upgrade (27/10/17)
« Reply #3 on: October 29, 2017, 05:04:46 pm »
I have the same problem and it is true that forcing gstreamer fixes the problem but it shouldn't have happened in the first place.  I hope it doesn't happen again when I upgrade again!

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 309
Re: [SOLVED] Problems with apps post upgrade (27/10/17)
« Reply #4 on: October 30, 2017, 05:16:28 am »
For the future It is easier to follow if you place the computer output inside code markup. peace out.
Don't make a FrankenDebian