Author Topic: No boot screen?  (Read 558 times)

Offline Lia

  • Newbie
  • *
  • Posts: 13
No boot screen?
« on: September 17, 2017, 01:52:52 pm »
When I tested the sparkylinux live it had an awesome boot screen with little animation in the bottom kind of like making a sideways 8 but after I have installed it, I only see the commands which boot the system, is there a way to get the boot screen back?

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1715
    • SparkyLinux
Re: No boot screen?
« Reply #1 on: September 17, 2017, 02:23:01 pm »
It is installed by default, but if any problem, reinstall it:
Code: [Select]
sudo apt update
sudo apt install --reinstall sparky-plymouth
Then reboot to check it out.
Nothing is easy as it looks.
Danielle Steel

Offline Lia

  • Newbie
  • *
  • Posts: 13
Re: No boot screen?
« Reply #2 on: September 17, 2017, 04:44:07 pm »
Okay, re-installed and re-booted but that didn't do it. Still showing a bunch of commands, same thing at shutting down too, no screen just lots of commands with ok at the end. :-\

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1715
    • SparkyLinux
Re: No boot screen?
« Reply #3 on: September 17, 2017, 08:24:20 pm »
Depends of your graphic card, settings can be different, so check:
https://wiki.debian.org/plymouth
Nothing is easy as it looks.
Danielle Steel

Offline Lia

  • Newbie
  • *
  • Posts: 13
Re: No boot screen?
« Reply #4 on: September 18, 2017, 04:30:06 am »
I made some changes as suggested in that tutorial, I selected the sparky-blue amongst the others and it shows up now, I don't know if it is the same one which live one had but it looks like it and anything better than command showing up I guess.  :)

Thanks

BTW: What's this message all about?

Code: [Select]
I: The initramfs will attempt to resume from /dev/sda5
I: (UUID=b46c4a7d-f407-4ac2-8764-527509082617)
I: Set the RESUME variable to override this.

One more thing.. Is it possible to have system sounds, like maybe logon/logoff/notifications/errors etc.?
« Last Edit: September 18, 2017, 10:21:37 am by Lia »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1715
    • SparkyLinux
Re: No boot screen?
« Reply #5 on: September 18, 2017, 10:45:40 am »
The sparky's default plymouth theme is sparky-blue.

Edit, as root:
Code: [Select]
/etc/initramfs-tools/conf.d/resumeadd the line to the file:
Code: [Select]
RESUME=UUID=b46c4a7d-f407-4ac2-8764-527509082617(if it is correct UUID of SWAP partition, check via command:
Code: [Select]
sudo blkid | grep swapIf yes, then:
Code: [Select]
sudo update-initramfs -u -t -k all
sudo update-grub

Never used sounds, but some desktop's config tools have option to enable sounds, I think.
Nothing is easy as it looks.
Danielle Steel

Offline Lia

  • Newbie
  • *
  • Posts: 13
Re: No boot screen?
« Reply #6 on: September 18, 2017, 12:53:05 pm »
That fixed the "Set the RESUME variable to override this" message which was showing up when updating initramfs. :) Thanks

What desktop config tools would those be? I installed dconf-editor and changed the default to the new sound scheme, but that didn't do it.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1715
    • SparkyLinux
Re: No boot screen?
« Reply #7 on: September 18, 2017, 11:02:57 pm »
If I remember well, MATE desktop has Control Center-> Sound Preference.
Should check other desktops too.
Nothing is easy as it looks.
Danielle Steel

Offline Lia

  • Newbie
  • *
  • Posts: 13
Re: No boot screen?
« Reply #8 on: September 19, 2017, 04:23:32 am »
Confused.. what should I install or do?

And how does the Custom Startup Services apps work? I want to add a script which should load at startup but not right away with 5s delay. This is how it looks currently. https://i.imgur.com/XeV52zN.png

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1715
    • SparkyLinux
Re: No boot screen?
« Reply #9 on: September 19, 2017, 12:23:37 pm »
Maybe let me know what is your present desktop, so I will check...

The custom autostart tool is simply to use:
- right click to add a new item
- double click on a command line to change a command
- double click on a Notes line to change it, etc

What do you want to add to your startup?
Nothing is easy as it looks.
Danielle Steel

Offline Lia

  • Newbie
  • *
  • Posts: 13
Re: No boot screen?
« Reply #10 on: September 19, 2017, 01:56:47 pm »
LXDE SparkyLinux Nibiru and I want to refresh lxde panel right after restart coz it's a little buggy, the icons on the panel at start up start using the system theme whereas I am using solid color with opacity, so I searched and found this command "lxpanelctl restart" and it fixes it but I hate to have it run manually after every time I log on.

Why you asked about the desktop, I am using the one that comes in default with sparkylinux? LXDE+PCmanFM window manager. This one: https://i.imgur.com/txAzPeV.jpg
« Last Edit: September 19, 2017, 02:20:44 pm by Lia »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1715
    • SparkyLinux
Re: No boot screen?
« Reply #11 on: September 19, 2017, 08:49:35 pm »
1. Create lxpanel restarting file in your home dir, for example:
Code: [Select]
nano .lxpanel-restartAdd to the file:
Code: [Select]
#! /bin/bash
sleep 5
killall -9 lxpanel
lxpanel &
exit 0
chmod it:
Code: [Select]
chmod +x .lxpanel-restart
2. Create desktop file in your autostart dir:
Code: [Select]
nano .config/autostart/lxpanel-restart.desktopAdd to the file:
Code: [Select]
[Desktop Entry]
Name=LXpanel-Restart
Exec=/home/YOUR-NICK/.lxpanel-restart
Terminal=false
Type=Application
change "YOUR-NICK" to your user name.
Use any text editor instead of nano if you'd like.
Should start working after next log in.
Nothing is easy as it looks.
Danielle Steel

Offline Lia

  • Newbie
  • *
  • Posts: 13
Re: No boot screen?
« Reply #12 on: September 20, 2017, 10:37:06 am »
Done the above steps and rebooted and the icons are fine now :) so I guess it's working fine.

Thanks so much!