Author Topic: no background in lightdm  (Read 355 times)

Offline 0day

  • Newbie
  • *
  • Posts: 37
no background in lightdm
« on: September 07, 2017, 07:34:35 pm »
i would not have any background in lightdm.
how can I do?

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1709
    • SparkyLinux
Re: no background in lightdm
« Reply #1 on: September 07, 2017, 07:45:35 pm »
Edit as root the file:
Code: [Select]
/etc/lightdm/lightdm-gtk-greeter.confand change background option.
Nothing is easy as it looks.
Danielle Steel

Offline 0day

  • Newbie
  • *
  • Posts: 37
Re: no background in lightdm
« Reply #2 on: September 07, 2017, 07:52:22 pm »
Code: [Select]
# LightDM GTK+ Configuration
# Available configuration options listed below.
#
# Appearance:
#  theme-name = GTK+ theme to use
#  icon-theme-name = Icon theme to use
#  background = Background file to use, either an image path or a color (e.g. #772953)
#  user-background = false|true ("true" by default)  Display user background (if available)
#  transition-duration = Length of time (in milliseconds) to transition between background images ("500" by default)
#  transition-type = ease-in-out|linear|none  ("ease-in-out" by default)
#
# Fonts:
#  font-name = Font to use
#  xft-antialias = false|true  Whether to antialias Xft fonts
#  xft-dpi = Resolution for Xft in dots per inch (e.g. 96)
#  xft-hintstyle = none|slight|medium|hintfull  What degree of hinting to use
#  xft-rgba = none|rgb|bgr|vrgb|vbgr  Type of subpixel antialiasing
#
# Login window:
#  active-monitor = Monitor to display greeter window (name or number). Use #cursor value to display greeter at monitor with cursor. Can be a semicolon separated list
#  position = x y ("50% 50%" by default)  Login window position
#  default-user-image = Image used as default user icon, path or #icon-name
#  hide-user-image = false|true ("false" by default)
#
# Panel:
#  panel-position = top|bottom ("top" by default)
#  clock-format = strftime-format string, e.g. %H:%M
#  indicators = semi-colon ";" separated list of allowed indicator modules. Built-in indicators include "~a11y", "~language", "~session", "~power", "~clock", "~host", "~spacer". Unity indicators can be represented by short name (e.g. "sound", "power"), service file name, or absolute path
#
# Accessibility:
#  a11y-states = states of accessibility features: "name" - save state on exit, "-name" - disabled at start (default value for unlisted), "+name" - enabled at start. Allowed names: contrast, font, keyboard, reader.
#  keyboard = command to launch on-screen keyboard (e.g. "onboard")
#  keyboard-position = x y[;width height] ("50%,center -0;50% 25%" by default)  Works only for "onboard"
#  reader = command to launch screen reader (e.g. "orca")
#
# Security:
#  allow-debugging = false|true ("false" by default)
#  screensaver-timeout = Timeout (in seconds) until the screen blanks when the greeter is called as lockscreen
#
# Template for per-monitor configuration:
#  [monitor: name]
#  background = overrides default value
#  user-background = overrides default value
#  laptop = false|true ("false" by default) Marks monitor as laptop display
#  transition-duration = overrides default value
#
[greeter]
background=false
#user-background=
#theme-name=
#icon-theme-name=
#font-name=
#xft-antialias=
#xft-dpi=
#xft-hintstyle=
#xft-rgba=
#indicators=
#clock-format=
#keyboard=
#reader=
#position=
#screensaver-timeout=



is it all right?

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1709
    • SparkyLinux
Re: no background in lightdm
« Reply #3 on: September 08, 2017, 02:32:54 pm »
I am not sure, but you can try to comment the line:
Code: [Select]
#background=your-patch
Nothing is easy as it looks.
Danielle Steel

Offline 0day

  • Newbie
  • *
  • Posts: 37
Re: no background in lightdm
« Reply #4 on: September 08, 2017, 05:51:31 pm »
so I get the debian background, but i want no background. thank you

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1709
    • SparkyLinux
Re: no background in lightdm
« Reply #5 on: September 08, 2017, 07:12:24 pm »
The patch is not important, only the '#' in the beginning.
Nothing is easy as it looks.
Danielle Steel

Offline 0day

  • Newbie
  • *
  • Posts: 37
Re: no background in lightdm
« Reply #6 on: September 08, 2017, 09:08:25 pm »
# in the beginning    view debian background

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1709
    • SparkyLinux
Re: no background in lightdm
« Reply #7 on: September 08, 2017, 10:05:26 pm »
In the beginning of the line.
Change from:
Code: [Select]
background=your-patchto:
Code: [Select]
#background=your-patch
Nothing is easy as it looks.
Danielle Steel

Offline 0day

  • Newbie
  • *
  • Posts: 37
Re: no background in lightdm
« Reply #8 on: September 08, 2017, 10:36:28 pm »
done but view debian background