Author Topic: Slow Cursor issue  (Read 176 times)

Offline xendistar

  • Newbie
  • *
  • Posts: 20
Slow Cursor issue
« on: August 12, 2017, 11:16:45 am »
I did a new install of XFCE v5 rolling this morning but I have an issue with the cursor in any application. The cursor is very slow to move either sideways or up and down the page using the arrow keys. Like editing this text it takes over a second to move the cursor left or right, slightly faster going up or down and  I have the same issue  if I wantt to delete text. If I hold the key down it takes an age to move to the next character, it is quicker to keep tapping the keys to either move along the line of text or to delete something.

Any thoughts

Offline xendistar

  • Newbie
  • *
  • Posts: 20
Re: Slow Cursor issue
« Reply #1 on: August 12, 2017, 10:19:07 pm »
Answering my own post (starting to make a habit of this), I reconfigured locales,I found I had a US, ES and a GB locales selected, set it so that only en and now the cursor is flying across the screen. But, if I check on what my locale setting are this is what I get

Code: [Select]
tim@lunar:~$ sudo locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.utf8
LANGUAGE=
LC_CTYPE="en_US.utf8"
LC_NUMERIC="en_US.utf8"
LC_TIME="en_US.utf8"
LC_COLLATE="en_US.utf8"
LC_MONETARY="en_US.utf8"
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT="en_US.utf8"
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=

If there something wrong in the settings somewhere??

Offline xendistar

  • Newbie
  • *
  • Posts: 20
Re: Slow Cursor issue
« Reply #2 on: August 13, 2017, 02:36:23 pm »
Further to the above, doing an apt- update this morning I got the following error although apt- completed without further issue

Code: [Select]
apt-listchanges: Can't set locale; make sure $LC_* and $LANG are correct!
Reading changelogs... Done
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.utf8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").