Author Topic: Session choice on boot...  (Read 153 times)

Offline tenfoot

  • Newbie
  • *
  • Posts: 24
Session choice on boot...
« on: August 05, 2017, 10:27:46 pm »
Using Sparky v5.0 (Testing) Mate.

I  installed Gnome, via Synaptic, and expected a choice of Desktop Environments between Gnome and Mate on reboot.  When I didn't get it, I closed down the computer,  waited a while and then rebooted.  Still did not get an option to boot into Gnome or Mate.

Obviously, I am not doing something correctly and would appreciate any help, please?
Dogs laugh, but they laugh with their tails.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1627
    • SparkyLinux
Re: Session choice on boot...
« Reply #1 on: August 05, 2017, 11:07:59 pm »
Make sure you have installed 'gnome-session' package.
« Last Edit: August 05, 2017, 11:45:41 pm by pavroo »
Nothing is easy as it looks.
Danielle Steel

Offline tenfoot

  • Newbie
  • *
  • Posts: 24
Re: Session choice on boot...
« Reply #2 on: August 06, 2017, 09:17:01 pm »
Make sure you have installed 'gnome-session' package.

Thank you for your prompt reply.  I will check now and report bavk.
Dogs laugh, but they laugh with their tails.

Offline tenfoot

  • Newbie
  • *
  • Posts: 24
Re: Session choice on boot...
« Reply #3 on: August 06, 2017, 10:17:09 pm »
I didn't have the 'gnome-session package installed, so installed it.  Regrettably, upon reboot the computer went straight to my normal desktop without displaying a Sessiion option.  Tried closing down the computer completely and then rebooting after several minutes, with the same result.

Below are detaails of my computer and the installed Gnome packages.

Code: [Select]
-Computer-
Processor : 4x AMD FX(tm)-4100 Quad-Core Processor
Memory : 8161MB (707MB used)
Machine Type : Physical machine
Operating System : SparkyLinux
Date/Time : Mon 07 Aug 2017 07:35:29 NZST
-Display-
Resolution : 1920x1080 pixels
OpenGL Renderer : Gallium 0.4 on NVC1
X11 Vendor : The X.Org Foundation
-Audio Devices-
Audio Adapter : HDA-Intel - HDA ATI SB
Audio Adapter : HDA-Intel - HDA NVidia
Audio Adapter : USB-Audio - USB Device 0x46d

Operating System
----------------

-Version-
Kernel : Linux 4.11.0-1-amd64 (x86_64)
Version : #1 SMP Debian 4.11.6-1 (2017-06-19)
C Library : Unknown

Desktop Environment : lightdm-xsession
-Misc-

Installed packages - GNOME
 
      1870 gnome-music
      1884 gnome-contacts
      2145 gnome-icon-theme-symbolic
      2346 gnome-maps
      2747 gnome-desktop3-data
      4303 gnome-shell-common
      4388 gnome-mime-data
      4475 gnome-documents
      4577 gnome-color-manager
      4733 gnome-keyring
      4771 gnome-klotski
      5408 gnome-software-common
      5558 gnome-calculator
      5601 network-manager-gnome
      5614 gnome-nibbles
      5713 libgnome2-common
      5749 gnome-tetravex
      5803 gnome-taquin
      5828 libgnomevfs2-common
      5835 gnome-weather
      6050 gnome-disk-utility
      6088 gnome-control-center
      6216 gnome-robots
      6709 gnome-accessibility-themes
      6738 gnome-sudoku
      6768 gnome-chess
      7059 gnome-settings-daemon
      7073 gnome-shell
      7313 gnome-mines
      7330 gnome-terminal-data
      8910 gnome-mahjongg
      14764 gnome-backgrounds
      15204 gnome-icon-theme
      16163 gnome-control-center-data
      47627 gnome-user-guide
      171369 gnome-getting-started-docs

in the hope it will reveal what I have done incorrectly.

All advice will be appreciated.


Dogs laugh, but they laugh with their tails.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1627
    • SparkyLinux
Re: Session choice on boot...
« Reply #4 on: August 07, 2017, 03:30:23 pm »
Quote
upon reboot the computer went straight to my normal desktop without displaying a Sessiion option
It happens if your login manager is set to autologin.
Should check the autologin option in the: /etc/lightdm/lightdm.conf
If not, try to install other session manager, such as slim or gdm3.
« Last Edit: August 07, 2017, 08:03:43 pm by pavroo »
Nothing is easy as it looks.
Danielle Steel

Offline tenfoot

  • Newbie
  • *
  • Posts: 24
Re: Session choice on boot...
« Reply #5 on: August 07, 2017, 11:07:52 pm »
 author=pavroo link=topic=4035.msg9875#msg9875 date=1502112623]
Quote
upon reboot the computer went straight to my normal desktop without displaying a Sessiion option

Quote
It happens if your login manager is set to autologin.
Should check the autologin option in the: /etc/lightdm/lightdm.conf

Yes, the computer was set to autologin. I checked as suggested.

/etc/lightdm/conf
all items commented out with #

then I had a look at /etc/lightdm/usersconf in the hope that it could be relevant.

Code: [Select]
# User accounts configuration
#
# NOTE: If you have AccountsService installed on your system, then LightDM will
# use this instead and these settings will be ignored
#
# minimum-uid = Minimum UID required to be shown in greeter
# hidden-users = Users that are not shown to the user
# hidden-shells = Shells that indicate a user cannot login
#
[UserList]
minimum-uid=500
hidden-users=nobody nobody4 noaccess
hidden-shells=/bin/false /usr/sbin/nologin

Changed the file by deleting the word "no" before "login". Saved the altered file.  Closed everything and then rebooted the computer.  Session choice did not appear.

Quote
If not, try to install other session manager, such as slim or gdm3.

Could not find gdm in Synaptic but noted gdm3 was installed!  So, installed lxdm and all the dependencies as an alternative.  Changed /etc/lightdm/usersconf again and rebooted.  Still no choice of session manage >:(

Have decided that, as installing Gnome was only going to be an experimental thing for me - I doubt that I would ever use it as a preferred option - I'll abandon it and return solely to my prefered Mate.  Now for the task of removing both Gnome and LXDE:-)

Thank you pavroo for staying with me on this journey.  I'm a annoyed with myself that I failed to get it to work.






Dogs laugh, but they laugh with their tails.