Author Topic: Calamares keeps crashing  (Read 617 times)

Offline dirkme

  • Newbie
  • *
  • Posts: 3
Calamares keeps crashing
« on: July 12, 2017, 02:27:17 am »
Tried to install Sparky, but Calamares keeps crashing, can't install Sparky XFCE  :o

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1681
    • SparkyLinux
Re: Calamares keeps crashing
« Reply #1 on: July 13, 2017, 12:27:05 am »
1. Try to run calamares from a terminal and check the output:
Code: [Select]
sudo calamares
2. There is Advanced Installer as a backup in a case of the default installer problem.
Nothing is easy as it looks.
Danielle Steel

Offline dirkme

  • Newbie
  • *
  • Posts: 3
Re: Calamares keeps crashing
« Reply #2 on: July 14, 2017, 03:35:20 am »
1. Try to run calamares from a terminal and check the output:
Code: [Select]
sudo calamares
2. There is Advanced Installer as a backup in a case of the default installer problem.

I tried to run calamaris to start from terminal, an there is no output, it just crashes as the script does.

Offline t64vision

  • Newbie
  • *
  • Posts: 1
Re: Calamares keeps crashing
« Reply #3 on: July 19, 2017, 04:04:11 am »
 I can confirm the reported crash of the installer.  When I ran it from the terminal I got the following message as is aborted.  I hope this helps.

20:40:53 [1]: GeoIP reporting "America/Chicago"
02:40:53 [1]: WARNING: guessLocaleConfiguration can't guess from an empty list.
20:40:53 [1]: WARNING: guessLocaleConfiguration can't guess from an empty list.
20:40:53 [1]: WARNING: guessLocaleConfiguration can't guess from an empty list.
20:40:53 [1]: WARNING: guessLocaleConfiguration can't guess from an empty list.
Backtrace has 12 calls on stack:
  12: /lib/x86_64-linux-gnu/libparted.so.2(ped_assert+0x45) [0x7fa9ec1f2fc5]
  11: /lib/x86_64-linux-gnu/libparted.so.2(ped_device_close+0x88) [0x7fa9ec1f34e8]
  10: /lib/x86_64-linux-gnu/libparted.so.2(ped_device_destroy+0x40) [0x7fa9ec1f3550]
  9: /usr/lib/x86_64-linux-gnu/qt5/plugins/libpmlibpartedbackendplugin.so(+0x78dc) [0x7fa9dcf508dc]
  8: /usr/lib/x86_64-linux-gnu/qt5/plugins/libpmlibpartedbackendplugin.so(+0x81bf) [0x7fa9dcf511bf]
  7: /usr/lib/calamares/modules/partition/libcalamares_viewmodule_partition.so(_ZN19PartitionCoreModule6doInitEv+0x39) [0x7fa9e43dab79]
  6: /usr/lib/calamares/modules/partition/libcalamares_viewmodule_partition.so(_ZN19PartitionCoreModule4initEv+0x1d) [0x7fa9e43dc16d]
  5: /usr/lib/calamares/modules/partition/libcalamares_viewmodule_partition.so(_ZN12QtConcurrent15RunFunctionTaskIvE3runEv+0x55) [0x7fa9e43dc785]
  4: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5(+0xaafcf) [0x7fa9f9f88fcf]
  3: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5(+0xaec28) [0x7fa9f9f8cc28]
  2: /lib/x86_64-linux-gnu/libpthread.so.0(+0x7494) [0x7fa9f813c494]
  1: /lib/x86_64-linux-gnu/libc.so.6(clone+0x3f) [0x7fa9f968fa8f]
Aborted

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1681
    • SparkyLinux
Re: Calamares keeps crashing
« Reply #4 on: July 19, 2017, 10:27:30 am »
Can you re-run the live system and the Calamares via the command:
Code: [Select]
sudo -E calamares -d 2>&1 > calamares-output.logIt will be stored in live home dir, so provide the file, so I could report it to the developer's.
Nothing is easy as it looks.
Danielle Steel

Offline xendistar

  • Newbie
  • *
  • Posts: 20
Re: Calamares keeps crashing
« Reply #5 on: August 12, 2017, 10:58:34 am »
I also had this same issue last nightI think in about 6 attempts to run Calamares it it appeared once but then during installation it failed to format the disks as the live distribution had mounted the disks so they were in use. Unfortunately from there I could find no way out of the installer to get back to the desktop to umount the drives, install failed.

Edit


I should also add that I found the Advanced Insttaller icon a bit confusing, to me the explanation (that pop ups when you hold the cursor on the icon) was saying that it would install a live image on to the disk as opposed to installing in the conventional way. So I never went with it, I used the old text installer in the end.
« Last Edit: August 12, 2017, 11:21:08 am by xendistar »