Advertising

Author Topic: SOLVED: gstreamer1.0-plugins-base upgrade  (Read 778 times)

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 338
SOLVED: gstreamer1.0-plugins-base upgrade
« on: June 28, 2017, 04:01:56 am »
The upgrade in todays apt full-upgrade is blocked by gstreamer1.0-plugins-bad

Debian bug #862024
Split More Widely Used Plugins into a Separate Package

to me does not describe the bug - but possibly a hint of the origin of it. 

My output

Code: [Select]
The following packages will be upgraded:
  gstreamer1.0-plugins-base
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/1,557 kB of archives.
After this operation, 108 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
Reading changelogs... Done
(Reading database ... 139145 files and directories currently installed.)
Preparing to unpack .../gstreamer1.0-plugins-base_1.12.1-1_i386.deb ...
Unpacking gstreamer1.0-plugins-base:i386 (1.12.1-1) over (1.10.4-1) ...
dpkg: error processing archive /var/cache/apt/archives/gstreamer1.0-plugins-base_1.12.1-1_i386.deb (--unpack):
 trying to overwrite '/usr/lib/i386-linux-gnu/gstreamer-1.0/libgstrawparse.so', which is also in package gstreamer1.0-plugins-bad:i386 1:1.8.2-dmo2
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/gstreamer1.0-plugins-base_1.12.1-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Not lurking on #debian-next     I will wait   i386 architechture on intel atom.  peace out
« Last Edit: February 14, 2018, 05:23:19 am by paxmark1 »
Don't make a FrankenDebian

Offline tomak

  • Newbie
  • *
  • Posts: 1
Re: gstreamer1.0-plugins-base upgrade
« Reply #1 on: February 13, 2018, 08:09:53 pm »
Hi Paxmark1,

Did you find a solution for that problem ?


Kind regards,

Tom

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1788
    • SparkyLinux
Re: gstreamer1.0-plugins-base upgrade
« Reply #2 on: February 14, 2018, 12:32:14 am »
Check here:
https://sparkylinux.org/forum/index.php/topic,4296.msg10851.html#msg10851
Nothing is easy as it looks.
Danielle Steel

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 338
Re: SOLVED: gstreamer1.0-plugins-base upgrade
« Reply #3 on: February 14, 2018, 05:37:24 am »
Sorry for leaving that orphan thread - it was  probably part of a problem I fixed another way.    My personal preference is to never use the debmultimedia repo the last few years.  Somehow it got added it-  it conflicted with the original install.  I saw someone else having problems with similar in an unstable irc  and I applied that solution.  I got rid of all dmo's that had crept in and commented out the debmultimedia. 

If you like that debmultimedia repo see pavroo's  post above.
go with
Quote
libgstreamer-plugins-bad1.0 with dmo2 instead of dmo1
 
Don't make a FrankenDebian