Author Topic: Trying to get Steam working  (Read 529 times)

Offline Krik

  • Newbie
  • *
  • Posts: 1
Trying to get Steam working
« on: May 19, 2017, 07:08:27 am »
Getting steam working has been a royal pain. I tried uninstalling and reinstalling via the "Synaptic Package Manager". Then I tried downloading directly from Steam, and installing it. Then I found the install under "APTus Extra" and it just throws an error and does nothing. But all them are the nice part, it gets wild if you use the Steam install in "APTus Gamer". Basically it removed half the packages on the system, it removed network access, it removed the ability to restart and shutdown, and after I used the reset button I found it had actually removed all the desktops (LXDE, Cinnamon, ect.), it just leaves you at the command line login. The "APTus Extra"  Steam install needs to trigger 5 BIG SEPARATE WARNING POPUPS, in a row, saying it is about to destroy Linux. Or better yet it should not even be an option. Fortunately for me I am setting up a new system, so I just grabbed the thumbdrive, I had installed with, and reinstalled.

Now to the issue. I have searched quite bit and I am not finding a solution that works. Basically nothing happens when I click the steam icon. So I tried starting it from the Terminal to see what errors it maybe throwing and here is what I get.
Quote
Repairing installation, linking /home/USERNAME/.steam/steam to /home/USERNAME/.local/share/Steam
Running Steam on sparky 4 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
/home/USERNAME/.local/share/Steam/ubuntu12_32/steam: symbol lookup error: /usr/lib/i386-linux-gnu/libxcb-dri3.so.0: undefined symbol: xcb_send_request_with_fds
/home/USERNAME/.local/share/Steam/steam.sh: line 444: no match: ssfn*

I tried searching for that error and I am not finding much. I am hoping someone knows of a fix or a work around for this.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1668
    • SparkyLinux
Re: Trying to get Steam working
« Reply #1 on: May 19, 2017, 11:25:50 am »
It's from Arch based distro, but similar, so check it out:
https://bbs.archlinux.org/viewtopic.php?id=219522
Nothing is easy as it looks.
Danielle Steel