Author Topic: Strange dependencies problem  (Read 536 times)

Offline RebelCoderRU

  • Newbie
  • *
  • Posts: 3
Strange dependencies problem
« on: March 08, 2017, 06:04:10 pm »
Hi. I use Debian on my main PC and Sparky on my older, portable laptop. I installed Sparky 2 days ago and is is very nice on my older laptop. Everything works out of the box and I am thinking about switching to it on my desktop, bet there is one issue I can't solve.

I am getting constant dependencies issue i don;t see on my main Debian machine. I can't install a lot of software I need:

 
Code: [Select]
sudo apt install freecad
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 freecad : Depends: python-pivy (>= 0.5.0~v609hg-2) but it is not going to be installed
           Depends: python-pyside but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Code: [Select]
sudo apt-get install musique
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 musique : Depends: libtag1c2a (>= 1.6.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Code: [Select]
sudo apt-get install grub-customizer
[sudo] password for jurisl:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 grub-customizer : Depends: libatkmm-1.6-1v5 (>= 2.24.0) but it is not installable
                   Depends: libcairomm-1.0-1v5 (>= 1.12.0) but it is not installable
                   Depends: libglibmm-2.4-1v5 (>= 2.46.0) but it is not installable
                   Depends: libgtkmm-3.0-1v5 (>= 3.18.0) but it is not installable
                   Depends: libpangomm-1.4-1v5 (>= 2.38.0) but it is not installable
                   Depends: libsigc++-2.0-0v5 (>= 2.2.0) but it is not installable
                   Recommends: hwinfo but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

... and much more software would not install.

I have tried following commands:
sudo apt-get install -f
sudo dpkg --configure -a
sudo apt-get autoclean
sudo apt-get update
sudo apt-get dist-upgrade

They don't help. So otherwise brilliant distro, that just picked up all of my hardware correctly, has this strange issue.
Any tips on how to fix that would be much appreciated.

Thanks.
Yuriy.
« Last Edit: March 08, 2017, 07:21:18 pm by RebelCoderRU »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1635
    • SparkyLinux
Re: Strange dependencies problem
« Reply #1 on: March 08, 2017, 06:53:51 pm »
Most of your problems can be update package list related.
You tried to install: python-pivy (>= 0.5.0~v609hg-2)
by the present version is: 0.5.0~v609hg-3.1

So:
Code: [Select]
sudo apt-get updateand try again.
Nothing is easy as it looks.
Danielle Steel

Offline RebelCoderRU

  • Newbie
  • *
  • Posts: 3
Re: Strange dependencies problem
« Reply #2 on: March 08, 2017, 07:20:19 pm »
Hi!

I have tried all the basic things, including what you have suggested. Apt base is all up to date and the OS is up to date. That's why I asked here, as everything seems good but 50% apps have dependencies issues.

Offline RebelCoderRU

  • Newbie
  • *
  • Posts: 3
Re: Strange dependencies problem
« Reply #3 on: March 08, 2017, 07:35:07 pm »
Sorry. My fault.

I have found the root of the problem. I completely forgot, that Sparky is Debian Testing based, and updated sources list to my local country but used Debian Stable. This has now been fixed.