Author Topic: Uninstalling Programms with APTus?  (Read 263 times)

Offline Goofy

  • Newbie
  • *
  • Posts: 31
Uninstalling Programms with APTus?
« on: January 11, 2017, 08:44:43 am »
Dear Members,

a few days ago, I installed the wps-Office (kingsoft-office). Yesterday I just wanted to uninstall it.   ;D
For Newbies it is obvious to take the APTus-tool for this job. ...But which sub-tool does it for me?   ???

In the remove-tab I find the tool "removing packages from the system". I double-clicked it and type in wps-office. One second later it answer me "done"...  ???
But naturally nothing was done!   :(

Pavroo, yes, I know: I must use the Terminal-commands for this.   ;D

I used:

sudo apt-get purge wps-office

and the system removed 500mb without any problem.
...Yes, the problem is solved...   :-\

But which sub-tool, would I take, if I want to do this with the APTus-tool?

And another question: Are these commands the same? Or is there a difference?

sudo apt-get purge
sudo apt-get remove

Offline blaze

  • Jr. Member
  • **
  • Posts: 62
  • blazing away
Re: Uninstalling Programms with APTus?
« Reply #1 on: January 11, 2017, 09:49:52 am »
Hi Goofy!  man apt, check last section. :)


Code: [Select]
install, remove, purge (apt-get(8))
           Performs the requested action on one or more packages specified via
           regex(7), glob(7) or exact match. The requested action can be
           overridden for specific packages by append a plus (+) to the
           package name to install this package or a minus (-) to remove it.

           A specific version of a package can be selected for installation by
           following the package name with an equals (=) and the version of
           the package to select. Alternatively the version from a specific
           release can be selected by following the package name with a
           forward slash (/) and codename (jessie, stretch, sid ...) or suite
           name (stable, testing, unstable). This will also select versions
           from this release for dependencies of this package if needed to
           satisfy the request.

           Removing a package removes all packaged data, but leaves usually
           small (modified) user configuration files behind, in case the
           remove was an accident. Just issuing an installation request for
           the accidentally removed package will restore its function as
           before in that case. On the other hand you can get rid of these
           leftovers by calling purge even on already removed packages. Note
           that this does not affect any data or configuration stored in your
           home directory.
Unstable OpenBoxer

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1505
    • SparkyLinux
Re: Uninstalling Programms with APTus?
« Reply #2 on: January 11, 2017, 12:12:43 pm »
The 'Remove' option removed 'wps-office' package only. (provides 'apt-get remove' command)
All dependencies installed with it can be removed via 'Clean' section-> Remove all unnecessary packages. (provides 'apt-get autoremove' command)
Nothing is easy as it looks.

Offline Goofy

  • Newbie
  • *
  • Posts: 31
Re: Uninstalling Programms with APTus?
« Reply #3 on: January 11, 2017, 04:42:29 pm »
Thank you pavroo, thank you blaze,

Blaze, do you mean the last tab in the APTus-tool called Repository? ...There are only editing-tools for the repositories...  ???

 :)

Offline blaze

  • Jr. Member
  • **
  • Posts: 62
  • blazing away
Re: Uninstalling Programms with APTus?
« Reply #4 on: January 11, 2017, 10:49:43 pm »
No, I meant the last section in the code I posted. That starts with "Removing a package...", it explains the difference between remove and purge. :)

Personally I prefer apt over APTus, out of habit. :)
Unstable OpenBoxer

Offline Goofy

  • Newbie
  • *
  • Posts: 31
Re: Uninstalling Programms with APTus?
« Reply #5 on: January 12, 2017, 08:30:01 am »
Hello blaze,

ok, I understand: You had answered to my secondary question...   ::)

But now, I want to know, how do you do it over APTus.   :)   ...please...
...Because I would also prefer it over APTus...      ;D

Offline blaze

  • Jr. Member
  • **
  • Posts: 62
  • blazing away
Re: Uninstalling Programms with APTus?
« Reply #6 on: January 12, 2017, 10:37:48 am »
APTus... Sparky wiki... ;)
Unstable OpenBoxer

Offline Goofy

  • Newbie
  • *
  • Posts: 31
Re: Uninstalling Programms with APTus?
« Reply #7 on: January 12, 2017, 02:03:46 pm »
Oh blaze,
it is nice, that you know more than I   :-*  But this was exactly my problem, what I've tried to explain at my first post.

I have looked many times in the Sparky-Wiki. And I supposed that there is an answer in subject 'remove'. And the tool 'removing packages from the system' had the right sound in my ear. But as I've tried it, nothing is happend, and now I wanted to know what was wrong... Yes, thats the reason for this topic...  ::)

 ;)

Offline blaze

  • Jr. Member
  • **
  • Posts: 62
  • blazing away
Re: Uninstalling Programms with APTus?
« Reply #8 on: January 12, 2017, 09:49:20 pm »
Ooooh Goofy, no worry, tried the APTus tool myself and...nothing. Did not get it at all. Same frustrations as you described in your first post. ;D So back to apt for me. :)

Unstable OpenBoxer

Offline Goofy

  • Newbie
  • *
  • Posts: 31
Re: Uninstalling Programms with APTus?
« Reply #9 on: January 13, 2017, 11:58:37 am »
Ohh sorry blaze! -I had missunderstood your post! I must make it up immediately!
Hmmm... ok   :-*  (This wa a true kiss)
 ;D

Yes thats the thing: Not all works with the graphical interfaces; And to get answers for that costs hours. I cannot distinguish, if the other users also not knowing about this or if they are thinking, 'what a horrible newcomer is that person' and keep quiet.
I would rather, if they would say 'I also don't know'. Then I would know, that I'm not alone (and the developer perhaps, too).

The background is:
I for myself decided, that I want urgently running a Linux on my computer, which can substantially all things like the MS-Windows. And a lot of friends are thinking similarly. ...But if I can't giving answers to simple things to them, they will still want to wait with the 'Linux-experiment'. And everything remains like it was: 99% uses MS-Windows, 1% uses Linux (thats something overstating  ;) )
 :-\

Offline blaze

  • Jr. Member
  • **
  • Posts: 62
  • blazing away
Re: Uninstalling Programms with APTus?
« Reply #10 on: January 13, 2017, 07:04:19 pm »
Quote
I know: I must use the Terminal-commands for this.

 Bravo, you answered your own question already in your first post of this thread. It is more effective to administer these things with tui instead of gui. It takes some time and effort to learn, sure, but the reward is so much bigger than the effort when the lesson is learned. :)

And there is no way around the fact (fact, in my opinion ;D) that it is really practical to know the basics of it. Especially when you are running testing/unstable. You have come a long way already, so when things go %¤#W%#%¤%", hang in there Goofy, start the black box, and just whip it! ;D
Unstable OpenBoxer

Offline blaze

  • Jr. Member
  • **
  • Posts: 62
  • blazing away
Re: Uninstalling Programms with APTus?
« Reply #11 on: January 17, 2017, 02:15:06 pm »
Just a little follow APTus...  ::) yes it was that dry and bad.

I am running my Sparky Openbox minimal gui with the unstable repo. Last week there were a kernel update from Debian, and the 4.9 kernel were installed. That led to that when shutting  down the system everything froze halfway through the process and I had to kill it with the power button. No matter which command I used or the Sparky exit dialogue box. I also had to push the hard switch for wifi on and off to get it to work. When I booted back into the 4.8 kernel everything worked as normal, so I did not care to investigate further. Yes I know, I am bit lazy.

Then I decided to install the Sparky kernel, so first I added the Sparky unstable repo in /sources.list.d. And installed the Sparky keyring manually with wget. Saw that I could install the Sparky kernel with APTus and decided to try that. Started it from the menu, gave the password as normal, double clicked on the "Install Sparky kernel" symbol. Immediately appeared a terminal window with a prompt that did nothing. I waited and nothing happened. Five minutes later or so I decided to click the terminal window away, and now appeared a dialogue box that said that the Sparky kernel were successfully installed. First I checked with a sudo update-grub, no sign of it. Rebooted, still no sign of it. Installed it manually after the description from the Sparky wiki and everything went really well. My shutdown trouble is now gone so I am happy.

But what is it with the APTus tool that I do not understand? I feel a bit  ???
Unstable OpenBoxer

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1505
    • SparkyLinux
Re: Uninstalling Programms with APTus?
« Reply #12 on: January 17, 2017, 07:50:01 pm »
Quote
Immediately appeared a terminal window with a prompt that did nothing
The latest update of LXterminal which is the default  x-terminal-emulator in Sparky's Openbox, works as you saw.
I upgraded 'sparky-xterm' package last week to provide xterm as the default terminal emulator for sparky tools for all sparky editions.
Probably you haven't upgraded it yet.
Nothing is easy as it looks.

Offline Goofy

  • Newbie
  • *
  • Posts: 31
Re: Uninstalling Programms with APTus?
« Reply #13 on: January 18, 2017, 07:02:59 am »
Good morning...

pavroo, and that means, that the LXTerminal works incorrectly (with the new kernel)? And you would not recommend to use this in the future?
This will change, hopefully soon again to the next Sparky-upgrades, or?

...I like the LXTerminal more than the XTerm, because I can just still recognize the writing... The letters in the XTerm are toooo small, to read it. And I think nobody can tell me how I can change it...   :-\

greatings, goofy

Offline blaze

  • Jr. Member
  • **
  • Posts: 62
  • blazing away
Re: Uninstalling Programms with APTus?
« Reply #14 on: January 18, 2017, 11:06:03 am »
Latest?

Code: [Select]
blaze@blazebx:~$ apt-cache policy sparky-xterm
sparky-xterm:
  Installed: 0.1.10
  Candidate: 0.1.10
  Version table:
 *** 0.1.10 100
        100 /var/lib/dpkg/status

Will not do any dist-upgrade today. On my machine for testing d-u there were some xorg packages being upgraded. The x broke after that d-u. So I will wait for a while with Sparky. :)
Unstable OpenBoxer