Author Topic: [Solved] Logout Error after latest "Safely Upgrade the System"  (Read 606 times)

Offline MadEducator

  • Newbie
  • *
  • Posts: 4
[Solved] Logout Error after latest "Safely Upgrade the System"
« on: December 04, 2016, 08:58:09 pm »
I "safely upgraded' the system last night and this morning when I tried to logout I got this message:

Failed to execute child process "lxde-logout" (No such file or directory)

I don't want to hard boot for fear of not being able to log back into Sparky (I have a triple boot system: Peppermint 7, Sparky Game Over, Windows 7, where Peppermint is default).

I am sort of a Linux Noob and would appreciate any help to resolve this issue.

Thank you in advance.

Update: Aptus was acting as if there were no updates/upgrades (quitting rather quickly).  So, I used Synaptic Package Manager to upgrade the system and now I can logout normally.
« Last Edit: December 04, 2016, 09:51:43 pm by MadEducator »

Offline paxmark1

  • Sr. Member
  • ****
  • Posts: 291
Re: [Solved] Logout Error after latest "Safely Upgrade the System"
« Reply #1 on: December 05, 2016, 12:13:46 am »
1.  The lxde-logout message should not keep you from getting into the Sparky kernel and sytemd.  In theory (and something that can occur in testing) it could keep you from getting into the LXDE DE (Desktop Environment)  If you are going to be triple booting it would be wise to learn some bash and command line tools, especially grub. 

2.  You can always ask for help with the LXDE via irc at OFTC #lxde .   Freenode #lxde is the place to go with LXQT questions. 

3.  I would encourage you to avoid synaptic  for upgrades and dist-upgrades.   Why?  -
    On the command line compare "apt-cache showpkg syaptic "  to "apt-cache showpkg sparky-aptus"    (the apt-cache command does not perform changes, it just gives information - it is safe to use.  "man apt-cache")
     Notice the much larger dependencies of synaptic.  IMHO synaptic is fine for stable Debian for upgrades, but you are in testing.
     Syanaptic is fine in Sparky for getting information, but IMHO for upgrades and dist-upgrades - the fewer dependencies the safer it is for you. 

4.  If your system has i3 cpu or better, enough memory and hdd space, consider using virtualbox instead of triple booting.     
Don't make a FrankenDebian

Offline MadEducator

  • Newbie
  • *
  • Posts: 4
Re: [Solved] Logout Error after latest "Safely Upgrade the System"
« Reply #2 on: December 12, 2016, 03:21:55 am »
Thank you for explaining the differences between Synaptic and Aptus. I will stick with Aptus to safely upgrade. I think my Internet glitching caused something not to upgrade correctly.

I know a few, but learning more bash commands are on my to do list as is learning how to deal with grub. Grub, for some reason confounds me. I've messed grub up many times in the past, following information I've found online on how to edit/change it. One day I'll understand it better.

As for the triple boot, I originally was playing with Fedora, but it was very bossy and locked me out of windows and Sparky. So, I used Peppermint 7 to wipe out Fedora and all has been well ever since. My ultimate goal is to move to Linux permanently and use a VM or Vbox for Windows 7. But that's another story. 

I do appreciate all the information.  :)