Author Topic: Unable to mount usbstick since upgrade (gvfs?)  (Read 166 times)

Offline red.iceman

  • Newbie
  • *
  • Posts: 7
Unable to mount usbstick since upgrade (gvfs?)
« on: November 25, 2016, 08:33:11 am »
Hi,

since thursday I cannot mount usbsticks anymore: "not authorized to perform operation"
In happens in all gvfs based filemanagers like nemo, thunar, pcmanfm, nautilus..., while dolphin works fine.

System: Lenovo X240
Desktop: Budgie, XFCE

Any idea?

Jens



Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #1 on: November 25, 2016, 11:22:12 am »
Make sure you have installed 'policykit-1-gnome' package and 'polkit-gnome-authentication-agent-1' is enabled to start with the system starts.
Nothing is easy as it looks.

Offline red.iceman

  • Newbie
  • *
  • Posts: 7
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #2 on: November 25, 2016, 11:39:31 am »
Code: [Select]
# sudo aptitude search policykit-1
i A policykit-1                                                             - Rahmen für die Verwaltung von Privilegien und administrativen Verfahren         
p   policykit-1:i386                                                        - Rahmen für die Verwaltung von Privilegien und administrativen Verfahren         
p   policykit-1-doc                                                         - Dokumentation für PolicyKit-1                                                   
i A policykit-1-gnome                                                       - XFCE and Unity authentication agent for PolicyKit-1                             
p   policykit-1-gnome:i386                                                  - XFCE and Unity authentication agent for PolicyKit-1

Make sure you have [...] 'polkit-gnome-authentication-agent-1' is enabled to start with the system starts.
How can I verify this?

Jens

Offline Dai_trying

  • Newbie
  • *
  • Posts: 38
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #3 on: November 25, 2016, 12:41:45 pm »
Code: [Select]
apt-cache policy policykit-1if you have a line that says Installed <version> then it is installed, if it says Installed: (none) then it is not installed.

Offline red.iceman

  • Newbie
  • *
  • Posts: 7
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #4 on: November 25, 2016, 01:20:55 pm »
Code: [Select]
# apt-cache policy policykit-1

policykit-1:
  Installiert:           0.112-5.3.1~really-0.105-8
  Installationskandidat: 0.112-5.3.1~really-0.105-8
  Versionstabelle:
 *** 0.112-5.3.1~really-0.105-8 100
        100 /var/lib/dpkg/status
     0.105-17 500
        500 http://ftp.debian.org/debian testing/main amd64 Packages

As far as I understand it doesn't mean that 'polkit-gnome-authentication-agent-1' is enabled.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #5 on: November 25, 2016, 05:15:46 pm »
Check does it work now:
Code: [Select]
pidof polkit-gnome-authentication-agent-1
Nothing is easy as it looks.

Offline red.iceman

  • Newbie
  • *
  • Posts: 7
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #6 on: November 25, 2016, 05:43:18 pm »
Code: [Select]
# pidof polkit-gnome-authentication-agent-1
#
Okay, it is not running.

Code: [Select]
# ls /etc/xdg/autostart/polkit*
/etc/xdg/autostart/polkit-gnome-authentication-agent-1.desktop /etc/xdg/autostart/polkit-mate-authentication-agent-1.desktop
/etc/xdg/autostart/polkit-kde-authentication-agent-1.desktop

So it should be started, shouldn't it?

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1456
    • SparkyLinux
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #7 on: November 25, 2016, 09:38:19 pm »
Copy polkit-gnome-authentication-agent-1.desktop to home dir:
Code: [Select]
~HOME/.config/autostart/polkit-gnome-authentication-agent-1.desktopThen reboot.

And make sure the exec line is:
Code: [Select]
Exec=/usr/lib/polkit-gnome-authentication-agent-1
« Last Edit: November 25, 2016, 09:40:18 pm by pavroo »
Nothing is easy as it looks.

Offline red.iceman

  • Newbie
  • *
  • Posts: 7
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #8 on: November 25, 2016, 10:54:30 pm »
Sorry, still the same error.

Code: [Select]
# pidof polkit-gnome-authentication-agent-1
# ps ax | grep polkit
  930 ?        Ssl    0:00 /usr/lib/policykit-1/polkitd --no-debug
 2145 ?        Sl     0:00 budgie-polkit-dialog
 2553 pts/0    S+     0:00 grep polkit

Offline red.iceman

  • Newbie
  • *
  • Posts: 7
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #9 on: November 25, 2016, 11:15:48 pm »
I have tried the following:

create a simple .xinitrc
Code: [Select]
if [ -d /etc/X11/xinit/xinitrc.d ] ; then
    for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
        [ -x "$f" ] && . "$f"
    done
    unset f
fi

exec budgie-desktop

reboot to init 3.

Now I can mount usb sticks.

So maybe the display manager (lightdm, but I tried slim, too) is the problem.

Offline red.iceman

  • Newbie
  • *
  • Posts: 7
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #10 on: November 27, 2016, 11:15:15 am »
If I start without X (multiuser.target), I can mount USB sticks.
If I start with X (graphical.target), it does not work.

This is not a solution but a workaround.

Further ideas?

Jens